webmin update to 1.560 from 1.556

  • tomsmsp
  • 07/22/11
  • Offline
Posted: Thu, 2011-08-04 17:24

Fresh install with vmin 3.87 on centos 5.6. I tried to add the samba module from webmin>system>software packages. It fails saying it needs webmin 1.560 to install it. System info says all packages are up to date? So I'm stuck there.

Can or should I use yum from command line to install samba with swat? I understand that I should stick to one or the other for system stability.

When is it ok to use centos repos vs virtualmin repos? Are they synced by you folks?

Is there a doc on setting up yum repo priorities...virtmin with centos?

Which way is best? I just want samba-swat installed. I don't want Samba open to the internet, just to the local lan. Do I have to open fwall ports to allow this? Are they 135 and 139? Thx.


Howdy, The version we'd

  • andreychek
  • 01/05/09
  • Offline
  • Thu, 2011-08-04 18:12

Howdy,

The version we'd generally recommend using is the one that's available in the Virtualmin software repository.

The 1.560 version of Webmin is considered a development version, and is available here:

http://download.webmin.com/devel/rpm/

So, while we'd recommend the version in the Virtualmin repo's -- if you really require the Samba module, and it requires Webmin 1.560, you may be stuck using that development version :-)

-Eric


The Samba module is included

  • Joe
  • 10/23/08
  • Offline
  • Sat, 2011-08-06 17:05

The Samba module is included in the standard Webmin package we provide in our repos; we distribute the standard Webmin.com Webmin package...which includes all of the standard modules, and Samba is a standard module. There is no reason to install it, and the module has not changed at all in the tiny version change between 1.556 and 1.560.

If you don't see it, look in the "Un-used modules" menu. If it's there, that means Webmin didn't detect the existence of Samba when it was installed. You just need to use the "Refresh Modules" feature to have it detect the installed services again. If you didn't install Samba from a package provided by your OS vendor (why not?!?) then you'll need to manually configure Webmin to know about where you've installed Samba...but, I really, seriously, recommend you not install stuff from tarballs except as a last resort.


Oh, and 1.560 will be in the

  • Joe
  • 10/23/08
  • Offline
  • Sat, 2011-08-06 17:14

Oh, and 1.560 will be in the repos in about 10 minutes. But, again, nothing has changed in the Samba module, so it's not going to make any difference in this particular use case.


Ok..ty for the info. I did

  • tomsmsp
  • 07/22/11
  • Offline
  • Sun, 2011-08-07 06:30

Ok..ty for the info. I did find samba in unused modules. That's where I tried to install it with the link. I am going to use ftp and ssh for the time being as if the box were a rented vps. Good training I figure. If I get the urge to install it again I'll report back what happens. If 1.560 has just been released that sounds like the fix is there now. Good timing eh. I wish all my tech troubles got solved by a fresh update that fast. ;)

On supporting what you sell...I hope you understand that the samba module didn't flake out the version of webmin balked at installing it...jfyi. Yes i could have installed samba from centos repos but I am trying to stay all virtualmin repo installing. That seems to be the concensus over there...do what you say not the underlying os says...at least if you expect support from here...there they say ask you....and so it goes. It never helps when you say use them and they say use you. The issue is a result of a standard webmin package...but it's you guys who want me to go pro I would suspect (which I hope to do)...but the support can't be a back n forth between you and centos support. When I include a module-package in something I support it...no matter if it uses generic packages. I understand you were just letting me know it's not customized. Can't imagine MSoft for example saying don't click that NFS services button...we don't support that anymore...;) Take the samba module out of vmin if you don't want anybody using it as a supported module. Telling me not to use it? What else can't I or shouldn't I use according to? Common sense security says don't load up a public web server with modules. I get that. Many don't ..I know. Do you have a list of what you support in virtualmin/webmin and what you don't? Let me give you and example...Not everybody will host public sites with virtualmin...it's called an intranet and win-lin (samba) file sharing in that scenario is getting to be a must have. E/W ... Tis all good. I do like what I see so far. So far this is better than using a howtoforge-ispconfigx tut or a blog by whoever that's trying to make a fast internet buck and it's various repos and gotchas. ;)