PHP Warning: Module 'mcrypt' / mod_fcgid

  • anthonyinit2012
  • 04/10/12
  • Offline
Posted: Fri, 2012-06-22 20:31

Hi all, i'm getting these error in my log file after clean install virtualmin. please help me fix this

Quote: PHP Warning: Module 'mcrypt' already loaded in Unknown on line 0 PHP Warning: Module 'mcrypt' already loaded in Unknown on line 0 PHP Warning: Module 'mcrypt' already loaded in Unknown on line 0 PHP Warning: Module 'mcrypt' already loaded in Unknown on line 0 [Sat Jun 23 04:10:34 2012] [warn] mod_fcgid: process 27956 graceful kill fail, sending SIGKILL PHP Warning: Module 'mcrypt' already loaded in Unknown on line 0 PHP Warning: Module 'mcrypt' already loaded in Unknown on line 0 PHP Warning: Module 'mcrypt' already loaded in Unknown on line 0 [Sat Jun 23 04:11:09 2012] [warn] mod_fcgid: process 28167 graceful kill fail, sending SIGKILL [Sat Jun 23 04:11:09 2012] [warn] mod_fcgid: process 28164 graceful kill fail, sending SIGKILL [Sat Jun 23 04:11:09 2012] [warn] mod_fcgid: process 28162 graceful kill fail, sending SIGKILL [Sat Jun 23 04:11:09 2012] [warn] mod_fcgid: process 28160 graceful kill fail, sending SIGKILL [Sat Jun 23 04:11:09 2012] [warn] mod_fcgid: process 27946 graceful kill fail, sending SIGKILL PHP Warning: Module 'mcrypt' already loaded in Unknown on line 0 PHP Warning: Module 'mcrypt' already loaded in Unknown on line 0 [Sat Jun 23 04:11:19 2012] [warn] mod_fcgid: process 28169 graceful kill fail, sending SIGKILL

Thank you


Howdy, That error suggests

  • andreychek
  • 01/04/09
  • Offline
  • Sat, 2012-06-23 08:19

Howdy,

That error suggests that multiple PHP config files have been setup to load the mcrypt extension.

If there's a system-wide config file loading mcrypt, you wouldn't need to also add it to the individual php.ini file in $HOME/etc/php.ini.

-Eric


Hi, that problem fix, but my

  • anthonyinit2012
  • 04/10/12
  • Offline
  • Wed, 2012-06-27 17:35

Hi, that problem fix, but my site keep getting this internal server error / 500 internal server error mostly try to do editing of post submit post. when it happens i chack my apache error log this comes with it

[warn] mod_fcgid: process 391 graceful kill fail, sending SIGKILL

Please i really need some help

Thank you


Is that the error log

  • andreychek
  • 01/04/09
  • Offline
  • Wed, 2012-06-27 21:05

Is that the error log specific to your domain that you're seeing?

Normally, to see website errors for a given domain, you'd look in $HOME/logs/error_log. It almost sounds like the error you're seeing there is in the system-wide Apache error log.

There should hopefully be some application-specific errors in $HOME/logs/error_log.

-Eric


Oh god, until now i didn't

  • anthonyinit2012
  • 04/10/12
  • Offline
  • Wed, 2012-06-27 23:17

Oh god, until now i didn't know about which error log to check so that means all this time i was checking on wrong log file and struggling to fix this errors. finally i found site error log man the log is too much i 'm gonna clean this log file and start from scratch to find the errors i'm getting i will keep you updated if any error found

Thank you so much for letting me know where to find the correct log file :)


Hi,i found this

  • anthonyinit2012
  • 04/10/12
  • Offline
  • Thu, 2012-06-28 01:12

Hi, i found this error

[warn] [client xx.xx.xx.xx] mod_fcgid: read data timeout in 31 seconds, referer: http://www.my-domain.com/admin.php?mod=editnews&action=editnews&id=59326

[error] [client xx.xx.xx.xx] Premature end of script headers: admin.php, referer: http://www.my-domain.com/admin.php?mod=editnews&action=editnews&id=59326

Please help me fix this


That's a timeout error... so

  • andreychek
  • 01/04/09
  • Offline
  • Thu, 2012-06-28 07:49

That's a timeout error... so for some reason, the script is timing out, rather than completing.

The logs don't say why that's the case, so it may require some troubleshooting within your app to determine why that's happening.

Another thing you could try, if you think it needs more time to complete, is to go into Server Configuration -> Website Options, and change the "Maximum PHP script run time" option to a higher value.

-Eric


hi, i did the changes and it

  • anthonyinit2012
  • 04/10/12
  • Offline
  • Thu, 2012-06-28 08:19

hi, i did the changes and it did work well for me, normally in my CMS there is a option to optimize database and this job take a bit of time o complete before when i used to run that i get 500 error but now nothing

Thank you for help :)