php_admin_value

  • app1egenius
  • 01/05/13
  • Offline
Posted: Wed, 2013-06-26 19:19

Hi,

So just reinstalled Virtualmin on my new server. Decided to start fresh as I was going to use virtualmin for my mail this time around.

Anyways I configured everything pretty much the same way as my old install of Virtualmin (well besides enabling mail and stuff) but I noticed Virtualmin wants to add "php_admin_value engine off" in the virtual host section of new virtual servers. I built apache and php the same way as it was on my old server (except for the fact that it was updated version of them, latest) I don't have mod_php and I read on another topic here that php_admin_value engine off ensures that it is off. I am using FCGID under server templates. It's not a huge issue. During server creation Virtualmin complains that the line is unknown to it because of a module.

"invalid command 'php_admin_value', perhaps misspelled or defined by a module not included in the server configuration" is the line that is shown during creation. It doesn't abort the setup and the Virtual server still works fine it's just annoying and I am guessing any of my clients would think there is a problem when they create sub servers. The other thing that Virtualmin complains about it NameVirtualHost since it's set to be deprecated completely. Is there anyway to stop Virtualmin from adding the NameVirtualHost line?

Thank you everyone.


Howdy, Hmm, what Linux

  • andreychek
  • 01/05/09
  • Offline
  • Wed, 2013-06-26 22:35

Howdy,

Hmm, what Linux distro/version are you using?

It is indeed normal that php_admin_value should be disabled... that's a security feature to prevent mod_php from being invoked when FCGID/CGI is being used. That shouldn't be added if mod_php isn't enabled though.

Regarding NameVirtualHost -- that should be valid for Apache versions that ship with distros supported by Virtualmin.

Reviewing the Apache docs though, it does indeed look as if that's deprecated in Apache 2.4... which some adventuresome folks upgrade to :-)

I'll talk to Jamie about not adding that parameter when on Apache 2.4, as we certainly don't want it throwing warnings.

-Eric


Hi, CentOS 6.4 with apache

  • app1egenius
  • 01/05/13
  • Offline
  • Thu, 2013-06-27 12:44

Hi,

CentOS 6.4 with apache 2.4.4 and php 5.5.0. and Virtualmin 4.01 GPL.

HTTPD compile options:

./configure --prefix=/etc/httpd --with-included-apr --with-mpm=event --enable-unixd=static --enable-cgid=static --enable-fcgid=static --enable-proxy=static --enable-proxy-ajp=static --enable-proxy-http=static --enable-rewrite=static --enable-spelling=static --enable-deflate=static --enable-ssl=static --enable-mime-magic=static --disable-autoindex --with-ssl=/usr/local/ssl --enable-suexec=static --with-suexec-caller=apache --with-suexec-userdir=/home --with-suexec-docroot=/home --with-suexec-uidmin=100 --with-suexec-gidmin=100 --with-suexec-logfile=/etc/httpd/logs/suexec_log && make && make suexec && make install

PHP compile options:

LDFLAGS=-L/usr/include/mysql ./configure --with-config-file-path=/etc --sysconfdir=/etc --with-zlib --with-bz2 --enable-zip --with-openssl=/usr/local/ssl --with-mcrypt --with-mhash --with-curl --with-gd --with-jpeg-dir --with-png-dir --enable-ftp --enable-exif --with-freetype-dir --enable-calendar --enable-soap --enable-mbstring --with-libxml-dir=/usr/lib --enable-cgi --with-mm --with-pdo-mysql --with-mysqli --with-mysql --with-pear --enable-intl --with-gettext --enable-gd-native-ttf --with-gmp --with-iconv --enable-sockets --with-pspell --enable-fpm --with-kerberos --libdir=/usr/lib64 && make && make install


Fixed

  • app1egenius
  • 01/05/13
  • Offline
  • Fri, 2013-06-28 13:15

My friend recompiled apache and php (he actually helped me the first time but I was the one actually doing things then) after I reinstalled the OS. Virtualmin works now and the php_admin_value isn't getting added. I probably did something wrong during the configuration of something that caused this.