Loggin in to Virtual DOmain does not work...

  • HarryZink
  • 06/20/07
  • Offline
Posted: Fri, 2005-12-02 11:01

Okay, I created a virtual domain.

I created an admin user that is also a 'website admin user'

Upon going to that URL, and trying to log in to the admin interface, it is impossible, no matter what variant of the login I use.

if the domain is: domain.com and the admin user is: admin and the assigned login is: admin.domain

I am unable to get the user legitimately recognized, no matter what login format I use:

admin admin.domain admin@domain.com admin.domain.com

Whatever?

Logging is as JUST the domain name:

domain

will work, but since it's not an admin, that really doesn't help much.

I have a feeling that this aspect (for whatever reason) still needs a little bit of work.

Harry


Re: Loggin in to Virtual DOmain does not work...

  • Joe
  • 10/23/08
  • Offline
  • Fri, 2005-12-02 19:05

Hi Harry,

The "domain" user is always the Webmin/Virtualmin administrative user. If this login does not have access to Virtualmin and all of the other domain related modules, then a configuration option is wrong (maybe set wrong by the installation or maybe altered since then--I don't know). This is the user that is used for administering the domain: adding mailboxes, aliases, modifying Apache/BIND/etc. settings, uploading content, etc. Let's fix that problem, since that's easy to do. What does your "domain" user have when he logs in?

"Website management user" is a new special limited-privilege user type whose home directory is the documentroot of the domain. The user can login via FTP, and optionally SSH and/or DAV and upload/modify web content. The label just isn't sensible, however, as it can have two very different meanings (the meaning you have inferred, which is "a user with management capabilities over this domain", and the meaning Jamie intended, which is "a user who can only manage website content"), and I think your inferred meaning is the more obvious one. Anyway, the goal was to allow delegation of website duties to a user without granting them any unnecessary privileges--it is behaving as it is designed, but probably not as you would expect given the label of the function.

I'll file a bug about this, as it needs to make more sense. And there probably also needs to be an easy to see way to create new administrative users, just like the "domain" user. It can be done, but not obviously.


Re: Loggin in to Virtual DOmain does not work...

  • HarryZink
  • 06/20/07
  • Offline
  • Fri, 2005-12-02 23:17

Well, as long as the distinction between those user types can be made more obvious (maybe with a textbox underneath the fields, or a pop-up ALT help box), or maybe in (HEY!) some documentation that clarifies this.

What do I get when I log in as the domain administrator:

  • Default screen/Webmin tab -> Change Language and Theme.

  • System Tab -> Change Passwords / Running processes / Scheduled Commands / Scheduled Cronjobs

  • Servers Tab -> AWstats Reporting / Apache Webserver / BIND DNS Server / Mysql Database Server / Read User Mail / SpamAssassin Mail Filter / Virtual Email / Virtualmin Mailman Mailing List / Webalizer

  • Others Tab -> File Manager / Protected Web Directories / SSH/Telnet Login

So, where again, is the scripts drop-down menu supposed to be, to installa scripts?

Harry


Re: Loggin in to Virtual DOmain does not work...

  • Joe
  • 10/23/08
  • Offline
  • Sat, 2005-12-03 00:23

Joe is correct here - a website management user is just one who can login via FTP and upload files to the server's web document directory. It is not a alternate admin login equivalent to the server owner .. although that would be a cool feature to add.


Re: Re: Loggin in to FTP does not work...

  • HarryZink
  • 06/20/07
  • Offline
  • Sun, 2005-12-04 17:14

Please share the magic needed to be able to log in via FTP to a given website.

I have the virtual domain created. I have an admin user, a website admin user, and a regular user. Neither of them can login via FTP to the site.

I get 'connection refused' when trying ftp / ftp + SSL, and I get a 'write error' when trying an SFTP connection.

Is this another of those features where a switch needs to be toggled, that is buried under miles of menus :-)

Please advise,

Harry


Re: Script-INstalls?

  • HarryZink
  • 06/20/07
  • Offline
  • Sat, 2005-12-03 07:08

But the Script-Install link is still nowhere to be seen :-(

Harry


Re: Loggin in to Virtual DOmain does not work...

  • HarryZink
  • 06/20/07
  • Offline
  • Sat, 2005-12-03 15:34

Okay, after widing my way through other threads on here, I found the script-install 'problem' and I now have access to them. Consequently, I've started to send up script-install bug reports.

That being said -- you really should consider turning on the script-install ability by default, and possibly even placing it in their own separate category (maybe a separate icon on webmin, when the user has it turned on, under servers?)