public_html not visible in FTP

  • RichardSydney-Smith
  • 06/20/07
  • Offline
Posted: Thu, 2005-12-22 02:00

Using the command line FTP client that comes with MS XP SP2 and opening a session into a Virtual host created by virtualmin the "homes" and "domains" folders are visible but the "cgi-bin", "log" and "public_html" are not. They do not show in the file directory.

Checking the file permissions all folders have access set to 755 and are owned by the virtual host. I can not see any difference in the file permissions of the folders I can see and those that are invisible.

Looking at the folder from within linux using the domain owners password and the folders are all visible and can be written / browsed.


Re: public_html not visible in FTP

  • Joe
  • 10/23/08
  • Offline
  • Thu, 2005-12-22 23:37

Hey Richard,

I'm as confused by this behavior as you! I've never seen anything like that, but I'll look into it tomorrow when I'm back in the office (I don't have any Windows machines at home).


Re: public_html not visible in FTP

  • RichardSydney-Smith
  • 06/20/07
  • Offline
  • Thu, 2005-12-29 02:29

This may have something to do with samba/ windows.

Some files may have been created on a samba share using a windows xp machine. ( Was still more comfortable with XP)


Re: public_html not visible in FTP

  • RichardSydney-Smith
  • 06/20/07
  • Offline
  • Thu, 2005-12-29 02:44

No sorry, I tested several domains by copying index.htm files from a samba share. These were not detected by apache. Re-created with "nano" and they were detected and displayed.

However this is a separate problem to the "log" and "public_html" directories not showing using windows XP command line FTP program. In this case the directories have been created by virtualmin and not by "human hand" so to speak.