Cant install php7.0-zip php7.1-zip php 7.3-zip i just keep getting "you have held broken packages error"

3 posts / 0 new
Last post
#1 Wed, 03/20/2019 - 22:44
adamjedgar

Cant install php7.0-zip php7.1-zip php 7.3-zip i just keep getting "you have held broken packages error"

can anyone help figure this out. I have tried everything i can think of but this error still keeps popping up. I just need to unzip a bloody file on my server FFS!!!

Does it matter if i am running fpm and dont have fcgi installed?

This is shitting me up the wall, nothing has gone right with this virtualmin install since the day i ran it from the virtualmin auto installer script.

Is there a way i can just reinstall php (all versions from 7.0-7.3 from on a live server?)

Thu, 03/21/2019 - 05:40
adamjedgar

To some extent i am on the pathway to resolving my problem i think...i dumped the idea of using apt, and installed "aptitude"

Aptitude seems to be a much more powerful and has put me on the pathway to resolving some of those damned broken packages.

AJECreative is the home of $5 webhosting, $15/month VPS servers (1cpu,1gb RAM, 25GB storage)
Centos7, Debian9, or Ubuntu18LTS
Available Control Panels = Centos-Webpanel, Cyberpanel, or Virtualmin

https://ajecreative.com.au

Sat, 03/23/2019 - 22:36
adamjedgar

ok so for those on this forum who, when the "sound advice providers" on this forum go bye byes (which it appears they have recently...doing a great disservice to this brand on google searches), tear their hair out trying to get answers to simple questions...

Here is the answer to my problem (and i wont be the only one to experience this)

My only advice with using aptitude is this..."with great power comes great responsibility"

A. if used incorrectly and without being absolutely sure of what allowing its recommendations will do you can easily stuff your webserver install. You must check that doing so wont wipe important stuff off your system! I inadvertently made a mistake first time trying this and uninstalled Virtulamin on a production webserver! (fortunately, i had a cloud backup that i could very quickly restore) B. ALWAYS HAVE CURRENT BACKUPS before doing this kind of thing!!!

  1. Do not try to fix this using atp-get (it wont work without a lot more knowledge than what the alternative method requires)
  2. Install aptitude "apt-get install aptitude" as root user or "sudo apt-get install aptitude" as sudoer.
  3. using aptitude, try to reinstall php7.0-zip
sudo apt-get update
sudo apt-get install aptitude
sudo aptitude update
sudo aptitude install php7.0-common php7.0-zip -y  (note i did not choose the "-y" option...i would suggest you first try without adding  -y switch)

aptitude will make some recommendations...quite likely wanting to downgrade some stuff and possibly even remove a couple of php extensions that do not match up with the php7.0-zip extension repository version I was trying to install. For me this downgrading was necessary.

once it completed the downgrade it installed php7.0-zip without an issue.

Sorry i cant go into more detail...i am writing this an hour after sorting my problem. I am sure the guru's here can correct my omissions and ambiguity! The  solution was to use aptitude and not apt-get!

AJECreative is the home of $5 webhosting, $15/month VPS servers (1cpu,1gb RAM, 25GB storage)
Centos7, Debian9, or Ubuntu18LTS
Available Control Panels = Centos-Webpanel, Cyberpanel, or Virtualmin

https://ajecreative.com.au