Virtualmin Bleeding Edge Packages for CentOS/RHEL 5

This legacy document is here only to insure incoming links continue to work. You likely want to start with the new documentation index or search for what you want to know about. This document is unmaintained!

Virtualmin Bleeding Edge Packages

This legacy document is here only to insure incoming links continue to work. You likely want to start with the new documentation index or search for what you want to know about. This document is unmaintained!

Virtualmin Bleeding Edge Packages

Virtualmin, Inc. provides a set of yum repositories for CentOS/RHEL 5 that includes bleeding edge versions of several common web service related packages, including PHP.

We do not recommend using third party packages, including ours, unless you must have the bleeding edge versions of the provided packages. They are very likely not as stable or reliable as packages provided by the RHEL OS repository.

We get a lot of support queries, several per week, about third party repositories that are incompatible with the OS-standard packages, causing breakage in various ways. Thus, we're providing these packages which are known not to cause those kinds of issues. While we test and support these packages as best we can, and we use them on our own servers, they are still bleeding edge packages with dramatically less testing than standard CentOS/RHEL packages, however, and should be treated accordingly.

In short, if you don't need a newer version than what comes with CentOS, we recommend you stick with the standard package. If you do need a newer version, we recommend you use our packages rather than those from other third party repositories. We are not suggesting that any specific third party repository is poor quality, or poorly maintained. Merely that there are many subtle differences in the way various maintainers package things, and those small differences can cause hard to diagnose issues. We, obviously, also cannot support packages not provided by us. We have no control over them, and thus cannot fix bugs, and we don't use them and so we don't know anything about them. Issues relating to third party packages will generally be closed with little to no comment, as there's nothing we can do to help.

You can use the yum includepkgs options to select which packages you wish to use from these repositories. We recommend you do this to only use the packages you really need to be bleeding edge versions. New packages will be rolled into this repository occasionally, and it could potentially be a rude surprise to have your MySQL or Ruby or other major package upgraded without proper planning. I cannot stress this strongly enough. Use only the packages you must have from the bleeding edge repository, and choose those packages explicitly in your virtualmin-bleed.repo file.

That repository URLs are:

i386: http://software.virtualmin.com/bleed/centos/5/i386/

x86_64: http://software.virtualmin.com/bleed/centos/5/x86_64/

There is also a release package to automatically configure yum to use these repositories, which can be installed with the following command:

rpm -ivh http://software.virtualmin.com/bleed/centos/5/i386/virtualmin-bleed-release-1.0-1.rhel.noarch.rpm