[Solved] - EMail and FTP Problems

12 posts / 0 new
Last post
#1 Tue, 06/30/2009 - 02:48
theashman

[Solved] - EMail and FTP Problems

Hi there, I recently installed virtualmin on ubuntu 8.04. I initially had a bit of trouble getting it work correctly (as Eric knows). Eric (one of the admins/developers here?) made some changes on my server to get it to work.

However, i never checked to see if email and ftp were working before the changes.

My problems are as follows: Email: - - Emails send perfectly, but when replying/sending emails back to the same email address it came from, it doesn't appear in the inbox. i do not receive an error message saying that the message was undelivered either.

FTP: - - Any of the FTP users i create cannot login via a FTP client.

if there are any logs that i need to post, please let me know (i'm unsure which ones would help troubleshoot)

Thanks in advanced

Ashley

Tue, 06/30/2009 - 07:47
ronald
ronald's picture

logs for mail and proc for email. on a centos box it would be /var/log/maillog and /var/log/procmail.log

if you think the mail was delivered then it should show in the procmail.log, a line ending with Mode:None. Depending on your spamsettings and Mode:Spam, you might not see the mail.

Sometimes in the main.cf of postfix the line myorigin is not commented out, e.g. #myorigin. This often creates trouble too.

Then it's always worth to check out dns just in case. My favourite tool is www.intodns.com

Tue, 06/30/2009 - 08:56
theashman

This is what i have added for my dns records.

Mail (MX) Records
Prefix  TTL Distance Value
        600 0        vps12.vz1.ramhost.us

Web Site (A & CNAME) Records
Prefix TTL  Type  Value
       600  A   208.110.69.206
www    600  A    208.110.69.206

thanks for the link. but i'm a total n00b when it comes to DNS. i got a few blue ( i )'s and a red ( i ). i have no idea what they mean/how to fix them either :( my result: http://www.intodns.com/bimblebox.co.uk so if something is wrong please help :)

EDIT: also i should mention, these records are held at the company where i purchased the domain

Tue, 06/30/2009 - 09:00 (Reply to #3)
andreychek

Howdy,

Well, the blue ones are okay, they're just informational.

Red ones usually indicate a problem -- it says it's not seeing an IP for your 'www' record, though I'm seeing one here. So I don't think that part is the problem.

However, when I run this command:

# host bimblebox.co.uk bimblebox.co.uk has address 208.110.69.206 bimblebox.co.uk mail is handled by 0 vps12.vz1.ramhost.us.bimblebox.co.uk.

That mail record there seems unusual. Are you hoping to have email go back to your bimblebox.co.uk server there?

But I think that's the problem -- the MX record (vps12.vz1.ramhost.us.bimblebox.co.uk) doesn't actually resolve to anything. My guess is that you'd want to change it to "bimblebox.co.uk ".

It looks like your nameservers are ns1.turbodns.co.uk and ns2.turbodns.co.uk -- so you'd be updating that MX record with turbodns.co.uk.

-Eric

Tue, 06/30/2009 - 09:11
ronald
ronald's picture

so it looks like you have no mx record and A record. that would explain why mail isn't delivered. Probably there are no A records for your FTP which explains why no one can log in.

At your registrar for bimblebox.co.uk add A records for ftp, mail and www

There should be a zone file on your server for your domain, it would also hold mx records. Thats the one to use at the registrar. I dont think you would use your VPS provider's address.

so mail.bimblebox.co.uk then add the IP of your server as that would be the A record. When creating subdomains, be sure to add A records for that too at your registrar.

What this does is, you tell your registrar to tell the world were to find your services, such as domain, www, ftp, mail, subdomain by adding each service including the IP.

Tue, 06/30/2009 - 09:43
theashman

Hi both of you. Thanks for your replies.

I have taken your advice into account, ronald, and these are now the records i have in place at my registrar:

Mail (MX) Records
Prefix  TTL     Distance  Value
        600     0         mail.bimblebox.co.uk

Web Site (A & CNAME) Records
Prefix  TTL     Type    Value
        600     A     208.110.69.206
ftp     600     A     208.110.69.206
www     600     A     208.110.69.206
mail 600     A     208.110.69.206

Eric: I only just added the www record as i made the post so thats why it will say there isn't one.

i guess i will have to wait a few hours before i can test it again. are the records i added correct?

Tue, 06/30/2009 - 10:01
theashman

hmm, i tested # host bimblebox.co.uk and it came up and said

# host bimblebox.co.uk
bimblebox.co.uk has address 208.110.69.206
bimblebox.co.uk mail is handled by 0 mail.bimblebox.co.uk.bimblebox.co.uk.

for some reason it's adding the value of the mx record in front of the domain. is it mean to do this?

Tue, 06/30/2009 - 10:04
ronald
ronald's picture

the result is: bimblebox.co.uk. 86400 IN SOA ns1.turbodns.co.uk. hostmaster.bimblebox.co.uk. (

2009063015 ; Serial 28800 ; Refresh 7200 ; Retry 604800 ; Expire 600 ) ; Minimum TTL

bimblebox.co.uk. 86400 IN NS ns1.turbodns.co.uk.

bimblebox.co.uk. 86400 IN NS ns2.turbodns.co.uk.

bimblebox.co.uk. 600 IN MX 0 mail.bimblebox.co.uk.bimblebox.co.uk.

bimblebox.co.uk. 600 IN A 208.110.69.206

this is either propagation or misconfiguration on your box, but the mx record isn't okay yet

per haps this: Mail (MX) Records Prefix TTL Distance Value 600 0 mail.bimblebox.co.uk should be Mail (MX) Records Prefix TTL Distance Value 600 0 mail. or you should need to add a . (dot) after the mail.blabla.co.uk

you can give it a play and check with http://www.squish.net/dnscheck/ Enter the domainname and choose any. This is almost immediate.

Tue, 06/30/2009 - 10:15
theashman

Ronald, thank you for your advice.

I have followed what you said and have updated my current mx record to: "600 0 mail."

if this doesnt work then i will change it to mail.bla.tld

on a plus side, FTP is not working! :D one down two to go! :P

much appreciated!

Ashley

Tue, 06/30/2009 - 10:34
ronald
ronald's picture

so it must be mail.bimblebox.co.uk. with the dot at the end and probably some priority set to 5 instead of 0

good on the ftp ;)

Tue, 06/30/2009 - 11:11
theashman

wooohooo. everything finally works!

Thank you so much Eric and Ronald for you help!

much appreciated!

Kind regards Ashley

Tue, 06/30/2009 - 16:47
ronald
ronald's picture

great. Two things..

You have no reverse DNS (PTR) entries. 206.69.110.208.in-addr.arpa -> no reverse (PTR) detected

You should contact your ISP and ask him to add a PTR record for your IP. Per haps bimblebox.co.uk.

You need to have a rDNS else you might be seen as a spammer when sending mail.

Then you oughta shoulda have some priority set for your MX. 5 instead of 0