clamav-filesystem conflicts with clamav

Hi,

Virtualmin said there was a new clamv package (0.95.3-1.el5.rf) so I did the update which failed as follows:

Now updating clamav ..

Installing package(s) with command yum -y install clamav .. Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * addons: mirrors.combinetworks.com * base: mirror.skiplink.com * extras: mira.sunsite.utk.edu * updates: mirrors.bigtennetwork.com Setting up Install Process Resolving Dependencies --> Running transaction check ---> Package clamav.i386 0:0.95.3-1.el5.rf set to be updated --> Processing Dependency: clamav-db for package: clamav --> Processing Dependency: clamav-lib = 0.95.2-1.vm.el5 for package: clamav-server --> Running transaction check ---> Package clamav-db.i386 0:0.95.3-1.el5.rf set to be updated --> Processing Dependency: clamav-server = 0.95.2-1.vm.el5 for package: clamav-server-sysv ---> Package clamd.i386 0:0.95.3-1.el5.rf set to be updated --> Processing Conflict: clamav-filesystem conflicts clamav > 0.95.2-1.vm.el5 --> Finished Dependency Resolution clamav-filesystem-0.95.2-1.vm.el5.i386 from installed has depsolving problems --> clamav-filesystem conflicts with clamav clamav-server-sysv-0.95.2-1.vm.el5.i386 from installed has depsolving problems --> Missing Dependency: clamav-server = 0.95.2-1.vm.el5 is needed by package clamav-server-sysv-0.95.2-1.vm.el5.i386 (installed) Error: clamav-filesystem conflicts with clamav Error: Missing Dependency: clamav-server = 0.95.2-1.vm.el5 is needed by package clamav-server-sysv-0.95.2-1.vm.el5.i386 (installed) You could try using --skip-broken to work around the problem You could try running: package-cleanup --problems package-cleanup --dupes rpm -Va --nofiles --nodigest The program package-cleanup is found in the yum-utils package. .. install failed!

From an earlier support request I saw you asked for

yum list updates | grep clam

response:

clamav.i386 0.95.3-1.el5.rf dag

Thanks for your help.

Status: 
Active

Comments

Yeah, it sounds like you're using a third party repository, the DAG repository, and the ClamAV package from there is conflicting with the one you have installed now.

Packages from third party repositories are capable of causing conflicts with packages provided by CentOS and/or Virtualmin, so you may need to disable that repository in order to avoid any problems.