redmine installer doesn't work.

Hi,

the current redmine (v0.94) installation script doesn't work on CentOS 5.4 / VMPro 3.78. The error I get is:

Now installing redmine version 0.9.4 ..

Mongrel GEM install failed : ERROR: While executing gem ... (Gem::GemNotFoundException) Could not find mongrel (> 0) in any repository

.. failed! See the error message above for the reason why.

Status: 
Active

Comments

That looks like something wrong with the gem command on your system, as mongrel is a very common Ruby package.

If you run gem list --remote , what does it output? You should see a huge list of packages ..

That's very odd .. I see the mongrel gem in that list.

If you SSH in as root and run gem install mongrel , does it work OK?

Sorry for the delays

Now the problem is the ruby version. The redmine version, the script installs, requires mysql, which needs a ruby version newer than 1.8.5 (this is the current version under CentOS 5).

Now installing redmine version 0.9.4 .. Rails MySQL driver install failed : INFO: gem install -y is now default and will be removed INFO: use --ignore-dependencies to install only the gems you list ERROR: Error installing mysql: mysql requires Ruby version >= 1.8.6 .. failed! See the error message above for the reason why.

I also tried to install Ruby on Rails Result:

Installing Ruby Gem test-spec .. .. done Installing Ruby Gem camping .. .. done

Installing Ruby Gem fcgi .. .. Gem install failed : INFO: gem install -y is now default and will be removed INFO: use --ignore-dependencies to install only the gems you list Building native extensions. This could take a while... ERROR: Error installing fcgi: ERROR: Failed to build gem native extension. /usr/bin/ruby extconf.rb install fcgi --include-dependencies -- --with-mysql-include=/usr/include/mysql --with-mysql-lib=/usr/lib/mysql checking for fcgiapp.h... no checking for fastcgi/fcgiapp.h... no *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers. Check the mkmf.log file for more details. You may need configuration options. Provided configuration options: --with-opt-dir --without-opt-dir --with-opt-include --without-opt-include=${opt-dir}/include --with-opt-lib --without-opt-lib=${opt-dir}/lib --with-make-prog --without-make-prog --srcdir=. --curdir --ruby=/usr/bin/ruby --with-fcgi-dir --without-fcgi-dir --with-fcgi-include --without-fcgi-include=${fcgi-dir}/include --with-fcgi-lib --without-fcgi-lib=${fcgi-dir}/lib Gem files will remain installed in /usr/lib64/ruby/gems/1.8/gems/fcgi-0.8.8 for inspection. Results logged to /usr/lib64/ruby/gems/1.8/gems/fcgi-0.8.8/ext/fcgi/gem_make.out

I added the two result files

Cheers

Gerald

If the mysql gem really does need a newer ruby version, I'm not sure what can be done here, sorry :-(

Unfortunately ruby dependencies change so fast that they get ahead of distribution-provided packages..