mod_fcgid: ap_pass_brigade errors

Over the last two weeks I've been receiving a flood of errors reported in the logs for all our php sites. The error is as follows:

[warn] (103)Software caused connection abort: mod_fcgid: ap_pass_brigade failed in handle_request function

I have been playing with mod_fcgid parameters and extending time-out values etc. but these are still occurring in the logs very frequently

I've also attempted to update APC and receive this error. the epel repo has anewer version available. Could hese issues be related?

php-pecl-apc-3.0.19-2.el5.x86_64 from epel has depsolving problems --> Missing Dependency: php-zend-abi = 20050922 is needed by package php-pecl-apc-3.0.19-2.el5.x86_64 (epel) Error: Missing Dependency: php-zend-abi = 20050922 is needed by package php-pecl-apc-3.0.19-2.el5.x86_64 (epel) You could try using --skip-broken to work around the problem You could try running: package-cleanup --problems package-cleanup --dupes rpm -Va --nofiles --nodigest
Status: 
Active

Comments

Joe's picture
Submitted by Joe on Mon, 10/18/2010 - 18:23 Pro Licensee

I'm not sure about the apc dependency errors. They look like incompatibilities between the PHP version you have installed and the module you're trying to install. Which PHP packages are you using? Our bleeding edge repos, the CentOS standard, or some other source?

But I'm in the midst of rolling a new version of mod_fcgid for CentOS, which may or may not have some effect on the ap_pass_bride errors (I have no idea what they mean, though, so this is just chicken blood and chanting; no science to my theory that it might help).

The PHP I have installed is from vmbleed

The version of APC in the vm repo is 3.0.19-1.el5.vm in epel it's 3.0.19-2.el5

Thanks for the info .. looking forward to the mod_fcgid update.

Cheers, Ryan