[Resolved] https://*:10000 gives ERR_CONNECTION_REFUSED in browser

4 posts / 0 new
Last post
#1 Sun, 04/24/2011 - 14:35
Guardia

[Resolved] https://*:10000 gives ERR_CONNECTION_REFUSED in browser

Hello,

First I would like to say that Virtualmin has been fantastic for me and I really appreciate there being a GPL version. I've installed Virtualmin GPL on a few different servers before and everything went perfect, but this time it is giving me a little bit of trouble.

The webmin login should be: https://vps.grassrootsmarketing.ca:10000/ The virtualmin install log is also attached below.

I've had the server providers open ports 10000 and 20000 and they seem to be open. Both httpd and webmin are running and using 'netstat -tulpn | less' returns the following:

Active Internet connections (only servers) Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name tcp 0 0 0.0.0.0:20000 0.0.0.0:* LISTEN 3573/perl tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 3283/mysqld tcp 0 0 0.0.0.0:10000 0.0.0.0:* LISTEN 8033/perl tcp 0 0 69.27.107.84:53 0.0.0.0:* LISTEN 3101/named tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 3101/named tcp 0 0 127.0.0.1:5432 0.0.0.0:* LISTEN 3364/postmaster tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 3444/master tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN 3101/named tcp 0 0 :::993 :::* LISTEN 3380/dovecot tcp 0 0 :::995 :::* LISTEN 3380/dovecot tcp 0 0 :::110 :::* LISTEN 3380/dovecot tcp 0 0 :::143 :::* LISTEN 3380/dovecot tcp 0 0 :::80 :::* LISTEN 4106/httpd tcp 0 0 :::22 :::* LISTEN 3196/sshd tcp 0 0 ::1:953 :::* LISTEN 3101/named tcp 0 0 :::443 :::* LISTEN 4106/httpd udp 0 0 0.0.0.0:10000 0.0.0.0:* 8033/perl udp 0 0 0.0.0.0:20000 0.0.0.0:* 3573/perl udp 0 0 69.27.107.84:53 0.0.0.0:* 3101/named udp 0 0 127.0.0.1:53 0.0.0.0:* 3101/named

Showing that webmin is infact on and listening on port 10000. iptables also has the ports open on my end as they should be.

The other oddity is that using telnet from a different server to port 10000 gives the desired response (saying that it is a bad request and to use https because it is in ssl mode), but when accessing from a browser I just get a ERR_CONNECTION_REFUSED even from http://vps.grassrootsmarketing.ca:10000/ , which should ask me to redirect.

I'm at a lose for what the issue could be. Any help would be greatly appreciated.

Update: I moved mysql from 3306 for now and bound webmin there. I can now access it. Obviously I'm being blocked from port 10000 somehow. I'm trying to get that resolved with my host now. Thanks for the responses.

Sun, 04/24/2011 - 15:31
ronald
ronald's picture

I can connect to that url with no issues ...

Sun, 04/24/2011 - 15:53 (Reply to #2)
Guardia

Hello Ronald,

You can see the webmin login page? That is very interesting, but seeing as how odd this is from my end that doesn't completely surprise me.

I'll go ahead and confirm with a few other people I know. Unfortunately the still leaves me at a loss of what to do from here. I've flushed my DNS, but it must be interference from my network than or something. I'll post again once I've confirmed that I'm the only one in the dark.

Thanks.

Update: So it is only me / my network after all. What in the world could cause this?

Sun, 04/24/2011 - 18:09
Locutus

I'm getting a connection failure on that address as well.

Name resolution and ping works. Port 10000 though gives a "connection refused".

Judging by the fact that the reply takes about 2 seconds, it means that either no service is listening on that port, or an intermediate firewall is actively rejecting the connection. It is not getting dropped though (timeout would be about 10 seconds then).