"Typo" script installer fails

Error message during install:

Installing Ruby Gem fcgi .. .. Gem install failed : INFO: `gem install -y` is now default and will be removed INFO: use --ignore-dependencies to install only the gems you list Building native extensions. This could take a while... ERROR: Error installing fcgi: ERROR: Failed to build gem native extension. /usr/bin/ruby1.8 extconf.rb extconf.rb:1:in `require': no such file to load -- mkmf (LoadError) from extconf.rb:1 Gem files will remain installed in /var/lib/gems/1.8/gems/fcgi-0.8.8 for inspection. Results logged to /var/lib/gems/1.8/gems/fcgi-0.8.8/ext/fcgi/gem_make.out
Status: 
Active

Comments

Howdy -- if you install the ruby-dev package, does the installation work?

If so, we may need to add ruby-dev as a dependency for that Install Script.

You may also need to install the libfcgi-dev package, as it is needed for the fcgi gem to compile.

Installing both of the suggested packages fixed the first problem.

Now it bails out at this step:

Installing Ruby Gem typo version 5.5 .. .. Gem install failed : INFO: `gem install -y` is now default and will be removed INFO: use --ignore-dependencies to install only the gems you list Building native extensions. This could take a while... ERROR: Error installing typo: ERROR: Failed to build gem native extension. /usr/bin/ruby1.8 extconf.rb checking for sqlite3.h... no sqlite3.h is missing. Try 'port install sqlite3 +universal' or 'yum install sqlite3-devel' and check your shared library search path (the location where your sqlite3 shared library is located). *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers. Check the mkmf.log file for more details. You may need configuration options. Provided configuration options: --with-opt-dir --without-opt-dir --with-opt-include --without-opt-include=${opt-dir}/include --with-opt-lib --without-opt-lib=${opt-dir}/lib --with-make-prog --without-make-prog --srcdir=. --curdir --ruby=/usr/bin/ruby1.8 --with-sqlite3-dir --without-sqlite3-dir --with-sqlite3-include --without-sqlite3-include=${sqlite3-dir}/include --with-sqlite3-lib --without-sqlite3-lib=${sqlite3-dir}/lib Gem files will remain installed in /var/lib/gems/1.8/gems/sqlite3-1.3.3 for inspection. Results logged to /var/lib/gems/1.8/gems/sqlite3-1.3.3/ext/sqlite3/gem_make.out

I installed sqlite3, no change.

(Note that I'm not actually intending to use Typo, I just tried out some script installers and thought you might be interested in such fails.)

Try installing the "libsqlite3-dev" package, that provides the missing "sqlite3.h" file.

Next problem fixed, next problem occuring. ;)

Installing Ruby Gem typo version 5.5 .. .. done   Now installing Typo version 5.5 .. The typo command could not be found   .. failed! See the error message above for the reason why.

Does the typo command exist anywhere on your system? You can find it with a command like :

find / -name typo -type f