Ridding server of Google Analytics

3 posts / 0 new
Last post
#1 Tue, 01/17/2012 - 08:04
VyouFinder

Ridding server of Google Analytics

I tried to move my virtualmin domains to another server today and now I am down. Upon trying to restore all domains on the new server, I got an error about google-analytics:

Warning - the following features were enabled in one or more of the domains in the backup, but are not enabled on this system : Plugin virtualmin-google-analytics

This backup cannot be restored without breaking the configuration of this system.

I had no idea that I had installed it, wasn't using it, didn't want it, so I figured I would just remove Google Analytics from the old server and then try the export again without the Google Analytics stuff. Bad idea. I removed Google Analytics from each domain individually in the server template, now Apache will not start and I get:

Failed to start service :

  • Starting web server apache2 [Tue Jan 17 06:58:53 2012] [warn] NameVirtualHost 192.168.5.99:443 has no VirtualHosts ...fail!

What's happened?

Tue, 01/17/2012 - 09:30
andreychek

Howdy,

Well, what you're seeing there is just a warning, that shouldn't be responsible for why Apache isn't starting.

If you look in the Apache logs, either /var/log/apache2/error_log or /var/log/httpd/error_log, do you see any errors listed in there?

-Eric

Sat, 01/21/2012 - 07:58
VyouFinder

It was weird, I had to go into Virtualmin>System Settings>Features and Plugins and disable Virtualmin Analytics for each domain I host. Then I had no troubles starting Apache, or backing up and restoring to the new server.

I thought I had done this already but I guess not. Oops.