outlook express configuration

16 posts / 0 new
Last post
#1 Tue, 07/24/2012 - 18:34
matimont

outlook express configuration

Hi

I installed webmin and virtualmin on a fresh ubuntu image. I created a virtual server and everything seems ok. I can send and receive mails but i would like to configure outlook. how can i do it? I saw devcot or something with imap pop 3 options but i am not sure how to do it.. i tried but outlook cant connect to my domain at all...

Wed, 07/25/2012 - 03:00
Wed, 07/25/2012 - 10:17
matimont

Thank you!

Actually I know how to configure outlook express, my doubt is that I can't figure out how to set up mail.mydomain.com in Virtualmin.

When I enter my domain name in the pop3 or smtp fields it can't connect. I don't have created a mail.mydomain.com entry on my server, not sure how to do it or what to do to make it work. On my previous shared hosting, I had a mail.whatever.com, but that was set up by cpanel whenever I created a new domain, I can't find it in Virtualmin...

Any additional help will be appreciated!

Wed, 07/25/2012 - 11:40
andreychek

What port are you connecting to on your server? And what error is it that you receive?

-Eric

Wed, 07/25/2012 - 12:47
matimont

I opened ports 110 and 143 on my VPS control panel and still can't connect. I receive error: I first get: "an encrypted connection to your server can't be established, try with unencrypted", then it comes up with this error: "Log onto incoming mail server pop3: Outlook cannot connect to your incoming (pop3) email server. If you continue to receive this message, contact your server administrator or internet provider (ISP)"

The incoming mail server I put is: mydomain.com where "mydomain" is the domain name I have created under virtualmin.

Wed, 07/25/2012 - 13:06
ronald
ronald's picture

the incoming and outgoing mailserver would be: mail.mydomain.com
When you create a server then it will create the mx records for your domain. Also you need to create a mailbox obviously.

a mailserver is never just " domain.com" Some ISP's use pop.domain.com and smtp.domain.com. On virtualmin it is mail.domain.com

Under Edit Users you can create mailboxes/users like info@domain.com which you then use in outlook as the user connecting to your mailserver

Wed, 07/25/2012 - 13:02
matimont

Good, now where I see the mx records for my domain? I figured I needed to enter mail.mydomain.com but I can't find where to set that up in Virtualmin..

I think I have the mailbox created, I installed roundcube and I can access webmail, send and receive mails as normal...

If you could tell me how I create mail.mydomain.com in virtualmin I will appreciate it.

Thank you for your help!

Wed, 07/25/2012 - 13:08
ronald
ronald's picture

if you choose to create a server/domain with mail enable then the MX record is created automatically. Else look in the DNS records of the domain under Server Configuration - DNS Records

Wed, 07/25/2012 - 13:22
matimont

When I go to Configuration - DNS Records I see this:

Change Domain Name Change IP Address Clone Virtual Server Edit Proxy Website Email Settings Move Virtual Server PHP Versions Website Options Website Redirects

I can't find DNS Records..

Wed, 07/25/2012 - 14:36
ronald
ronald's picture

in that case try -webmin - Servers - BIND DNS server - then click on the domain in the right section.
Now you can click on the record Mail Server.
If there's nothing there then now you can add them.

Since you can send and receive email, I doubt you need to add or change anything in the DNS records.
I would first try to set up Outlook manually instead of let it search for the correct settings.

Wed, 07/25/2012 - 16:43
matimont

Ok, I activated Bind DNS as it was not in the feature list and when I saved, I can see a master zone for my virtual server and I see the mail.mydomain.com

Now, It's a worth to say that I'm using a 3rd party (sitelutions) for my DNS management. Should I change it there instead of the BIND DNS in the server?

Thanks!

Wed, 07/25/2012 - 17:51
matimont

Ok, I was able to connect now using IMAP. but... I can't connect using Pop3. not even doing telnet to my domain.. Here's the interesting thing, If I telnet to my VPS public IP on port 110 I get a Devcot Ok, then If I do the same but for my domain.com it says it can't connect. If I run the same excercice for port 143 works like a charm. Port 25 also doesn't work with my domain, but works with my ip. Weird stuff...

Wed, 07/25/2012 - 22:18
andreychek

It sounds like you may have multiple issues going on there... regarding Dovecot with port 110, what output do you see if you run this command:

netstat -an | grep :110

Also, which Ubuntu version are you using?

And did you install Virtualmin using the install.sh script?

-Eric

Thu, 07/26/2012 - 14:40
matimont

Hi,

I just solved it, I was on a VPN when I tested ports, so now I'm on regular internet service works fine.

Now, another challenge: I can't send to Hotmail, I've search in google and there are 2 possible causes: my ip is blacklisted or my IP doesn't have Reverse DNS, which is true, I checked with my VPS provider and they don't provide Reverse DNS, additionally, I get this when running a blacklist check:

Checking Block List "SpamHaus Policy Block List (PBL)" The IP address was found on block list.

But when I go to their website to try unblock there's a warning indicating it is normal that my IP is in the PBL, so I'm stucked with the reverse DNS, any suggestions?

Thu, 07/26/2012 - 15:03
andreychek

Thanks for letting us know how you fixed it!

We get confused easily around here (at least I do), and things get difficult to follow when there's too many topics in a given forum thread.

Is there any chance you could start a new thread, and post your Hotmail question there?

Be sure to let us know any errors you see in your mail logs when you try to send an email to Hotmail.

Thanks!

-Eric

Thu, 07/26/2012 - 15:46
matimont

Sure, I've created a new one, should be in the recent posts now.

thank you for your help!