Checking Configuration fails because I don't use procmail

Hello there

For my mail stack I use the postfix/dovecot combo and have purged anything related to procmail. It works like a charm.

But webmin is complaining at some places because procmail isn't installed nor configured.

Can this somehow be ignored? Not sure if this is a bug or a feature request.

Cheers Michael

Here an example of the output generated when checking the configuration:

The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active ..

Your system has 1.61 GB of memory, which is at or above the Virtualmin recommended minimum of 256 MB. Mail server Postfix is installed and configured. Postfix can support per-domain outgoing IP addresses, but is not currently configured to do so. This can be setup in the Postfix Mailserver module. MySQL is installed and running. Logrotate is installed. The Procmail program needed for spam filtering does not appear to be installed on your system, or has not yet been set up properly in Webmin's Procmail Mail Filter module. If your system does not use spam filtering, it should be disabled in Virtualmin's module configuration page.

.. your system is not ready for use by Virtualmin.

Status: 
Active

Comments

Howdy -- well, procmail is a dependency of Virtualmin, and a number of Virtualmin features won't work without it.

In particular -- the warning you're seeing is explaining that the Virtualmin Spam Filtering feature is enabled on your system... but for that to work, procmail would need to be there.

You could always go into System Settings -> Features and Plugins, and disable both the Spam Filtering and Virus Scanning features.

After you do that, does the Re-Check Config run successfully?