virtualmin restore-domain always get killed

Hi,

i was upgrading my old hosting server to a new one. but i'm having trouble restoring big backup data. (7GB)

i already split the backup per domain, even per user. but the process always exit with "killed" status right after configuring apache

below are the output

Checking for missing features .. .. all features in backup are supported

Starting restore.. Extracting backup archive files .. .. done

Re-creating virtual server ditptksd.go.id .. Creating administration group t95639 .. .. done

Creating administration user t95639 .. .. done Creating aliases for administration user .. .. done Adding administration user to groups .. .. done Creating home directory .. .. done Creating mailbox for administration user .. .. done Adding new DNS zone .. .. done Adding to email domains list .. .. done Adding default mail aliases .. .. done Adding new virtual website .. Adding webserver user www-data to server's group .. .. done Performing other Apache configuration ..
Status: 
Active

Comments

This could happen if Virtualmin's parsing of the apache config goes into an infinite loop and uses up all the memory on your system. There was a bug in older versions that could cause this, but it should be fixed in 3.99 release.

Which version are you using?

Webmin version 1.620 Virtualmin version 3.97.gpl GPL Operating system Ubuntu Linux 12.04.2 Running processes 152
Real memory 1001.18 MB total, 517.29 MB used Virtual memory 1020 MB total, 374.32 MB used Local disk space 158.73 GB total, 44.99 GB used

Package updates All Virtualmin packages are up to date. 4 updates to system packages are available. Use the Virtualmin Package Updates module to install them selectively.

It looks like you have Virtualmin 3.97 there. We'd recommend upgrading to the most recent version, 3.99, which contains a number of bugfixes.

Once you upgrade to Virtualmin 3.99, try restoring your domain again, and see if that resolves your problem.