Amazon Linux not supported?

19 posts / 0 new
Last post
#1 Sun, 06/02/2013 - 23:42
Jim Boy

Amazon Linux not supported?

2013.03 is now the only option for EC2 Amazon Linux images. Virtualmin supports the 2011 and 2012 versions. I tried to be sneaky by changing the release type on the instance, but virtualmin installation eventually crashed.

Any news on when a 12.03.03 version will be out as the Amazon Linux distribution is the best distribution on EC2.?

Tue, 06/04/2013 - 22:19
andreychek

Thanks for the heads up, I'll talk to Joe about support for that version.

-Eric

Fri, 06/28/2013 - 22:56
popowich

I am interested in Virtualmin supporting the latest Amazon Linux 2013.03 too.

Mon, 07/01/2013 - 16:07
popowich

Hi Jim Boy,

This process worked for me:

http://www.raymondpopowich.com/sys-admin/install-virtualmin-amazon-linux...

It worked for me, use at your own risk :) (but it should be fine)

Fri, 10/11/2013 - 18:13
rogeriobrito

Hello all,

I've tried the above but it did not work... the version now is Amazon Linux 2013.09.

Please help Thanks

Tue, 03/18/2014 - 02:14
digerati

Hello,

I am also interested in installing virtualmin on Amazon Linux 2013.09 and it is not compatible. Unfortunately, it is not possible to create a new instance using the older image. I'm completely lost without virtualmin.

Thanks

Tue, 03/18/2014 - 09:24
andreychek

Howdy,

We did some work on the Amazon Linux support, and hopefully that should be working now! Could you give that another try with the current Amazon Linux version?

If you run into any problems just let us know... thanks!

-Eric

Tue, 03/18/2014 - 11:24
digerati

It still isn't working. I just setup a brand new instance of Amazon Linux 2013.09. It prompted me to update the packages with sudo yum update, so I did allow it to complete the update. Then I ran sudo wget http://software.virtualmin.com/gpl/scripts/install.sh to download the current install script.

Thank you for your help.

Here is the same error that I received last night when I try to run install.sh:

[ec2-user@ip-172-31-25-209 ~]$ sudo sh ./install.sh

Welcome to the Virtualmin GPL installer, version 1.1.0

WARNING:

The installation is quite stable and functional when run on a freshly installed supported Operating System.

If you have existing websites, email users, or if you manually installed Virtualmin via a Webmin 'wbm' module, you are likely to run into problems. Please read the Virtualmin Administrators Guide before proceeding if your system is not a freshly installed and supported OS.

This script is not intended to update your system! It should only be used to perform your initial Virtualmin installation. If you have previously run the Virtualmin installer, you can perform upgrades and updates from within Virtualmin itself, or using your system's package manager. Once Virtualmin is installed, you never need to run this script again.

The systems currently supported by install.sh are: CentOS and RHEL 5-6 on i386 and x86_64 Scientific Linux 6 on i386 and x86_64 Debian 6.0 and 7.0 on i386 and amd64 Ubuntu 8.04 LTS and 10.04 LTS, and 12.04 LTS on i386 and amd64 Amazon Linux 2012.03 on i386 and x86_64 FreeBSD 7.0 and 8 on i386 and amd64

If your OS is not listed above, this script will fail. More details about the systems supported by the script can be found here:

http://www.virtualmin.com/os-support.html

Continue? (y/n) y Checking for HTTP client...found /usr/bin/curl -s -O Checking for perl...found /usr/bin/perl Loading log4sh logging library... INFO - Started installation log in /root/virtualmin-install.log INFO - Checking for fully qualified hostname... INFO - Hostname OK: fully qualified as ip-172-31-25-209.ec2.internal INFO - Installing serial number and license key into /etc/virtualmin-license INFO - Loading OS selection library... INFO - Download of http://software.virtualmin.com/lib/oschooser.pl Succeeded. INFO - Loading OS list... INFO - Download of http://software.virtualmin.com/lib/os_list.txt Succeeded. INFO - Operating system name: Amazon Linux INFO - Operating system version: 2013.09 INFO - Configuring package manager for Amazon Linux 2013.09... INFO - Download of http://software.virtualmin.com/gpl/amazon/2013.09/x86_64/virtualmin-rele... Succeeded. warning: virtualmin-release-latest.noarch.rpm: Header V3 DSA/SHA1 Signature, key ID a0bdbcf9: NOKEY INFO - Succeeded. INFO - Installing dependencies using command: /usr/bin/yum -y -d 2 install bind bind-utils caching-nameserver httpd postfix spamassassin procmail perl-DBD-Pg perl-DBD-MySQL quota iptables openssl python mailman subversion mysql mysql-server mysql-devel postgresql postgresql-server rh-postgresql rh-postgresql-server logrotate webalizer php php-xml php-gd php-imap php-mysql php-odbc php-pear php-pgsql php-snmp php-xmlrpc php-mbstring mod_perl mod_python cyrus-sasl dovecot spamassassin mod_dav_svn cyrus-sasl-gssapi mod_ssl ruby ruby-devel rubygems perl-XML-Simple perl-Crypt-SSLeay mlocate ...in progress, please wait... |Warning: RPMDB altered outside of yum. INFO - /usr/bin/yum -y -d 2 install bind bind-utils caching-nameserver httpd postfix spamassassin procmail perl-DBD-Pg perl-DBD-MySQL quota iptables openssl python mailman subversion mysql mysql-server mysql-devel postgresql postgresql-server rh-postgresql rh-postgresql-server logrotate webalizer php php-xml php-gd php-imap php-mysql php-odbc php-pear php-pgsql php-snmp php-xmlrpc php-mbstring mod_perl mod_python cyrus-sasl dovecot spamassassin mod_dav_svn cyrus-sasl-gssapi mod_ssl ruby ruby-devel rubygems perl-XML-Simple perl-Crypt-SSLeay mlocate: Succeeded. INFO - Succeeded. INFO - Installing Virtualmin and all related packages now using the command: INFO - yum clean all Loaded plugins: priorities, update-motd, upgrade-helper Cleaning repos: amzn-main amzn-updates virtualmin virtualmin-universal Cleaning up everything INFO - yum -y -d 2 install virtualmin-base ...in progress, please wait... /

Transaction check error: file /usr/bin/ab from install of httpd24-tools-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-tools-1:2.2.21-1.19.el6.vm.x86_64 file /usr/bin/htdbm from install of httpd24-tools-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-tools-1:2.2.21-1.19.el6.vm.x86_64 file /usr/bin/htdigest from install of httpd24-tools-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-tools-1:2.2.21-1.19.el6.vm.x86_64 file /usr/bin/htpasswd from install of httpd24-tools-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-tools-1:2.2.21-1.19.el6.vm.x86_64 file /usr/bin/logresolve from install of httpd24-tools-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-tools-1:2.2.21-1.19.el6.vm.x86_64 file /usr/share/man/man1/ab.1.gz from install of httpd24-tools-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-tools-1:2.2.21-1.19.el6.vm.x86_64 file /usr/share/man/man1/htdbm.1.gz from install of httpd24-tools-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-tools-1:2.2.21-1.19.el6.vm.x86_64 file /usr/share/man/man1/htdigest.1.gz from install of httpd24-tools-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-tools-1:2.2.21-1.19.el6.vm.x86_64 file /usr/share/man/man1/htpasswd.1.gz from install of httpd24-tools-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-tools-1:2.2.21-1.19.el6.vm.x86_64 file /usr/share/man/man1/logresolve.1.gz from install of httpd24-tools-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-tools-1:2.2.21-1.19.el6.vm.x86_64 file /etc/httpd/conf.d/README from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/README from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/README from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/dir.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/doc.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/forward.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/forward.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/text.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/text.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/down.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/up.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/binary.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/binary.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/image.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/unknown.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/unknown.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/blank.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/blank.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/left.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/right.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/folder.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /etc/httpd/modules from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/back.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/back.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/index.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/index.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/index.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/index.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/back.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/back.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_rewrite.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/unknown.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/unknown.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/ps.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/ps.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/doc.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/image.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pdf.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/script.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/text.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/text.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /etc/logrotate.d/httpd from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /etc/rc.d/init.d/httpd from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /etc/sysconfig/httpd from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/sbin/httpd from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /etc/httpd/conf.d/notrace.conf from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /etc/httpd/conf.d/welcome.conf from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /etc/httpd/conf/httpd.conf from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /etc/httpd/conf/magic from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /etc/httpd/logs from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /etc/httpd/run from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/sbin/htcacheclean from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_actions.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_alias.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_asis.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_auth_basic.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_auth_digest.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_authn_anon.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_authn_dbd.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_authn_dbm.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_authn_file.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_authz_dbm.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_authz_groupfile.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_authz_host.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_authz_owner.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_authz_user.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_autoindex.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_cache.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_cgi.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_cgid.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_dav.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_dav_fs.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_dbd.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_deflate.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_dir.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_dumpio.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_env.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_expires.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_ext_filter.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_file_cache.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_filter.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_headers.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_include.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_info.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_log_config.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_log_forensic.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_logio.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_mime.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_mime_magic.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_negotiation.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_proxy.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_proxy_ajp.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_proxy_balancer.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_proxy_connect.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_proxy_ftp.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_proxy_http.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_proxy_scgi.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_reqtimeout.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_setenvif.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_speling.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_status.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_substitute.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_suexec.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_unique_id.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_userdir.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_usertrack.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_version.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/lib64/httpd/modules/mod_vhost_alias.so from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/sbin/apachectl from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/sbin/rotatelogs from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/sbin/suexec from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/share/man/man8/apachectl.8.gz from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/share/man/man8/htcacheclean.8.gz from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/share/man/man8/httpd.8.gz from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/share/man/man8/rotatelogs.8.gz from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /usr/share/man/man8/suexec.8.gz from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/HTTP_BAD_GATEWAY.html.var from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/HTTP_BAD_REQUEST.html.var from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/HTTP_FORBIDDEN.html.var from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/HTTP_GONE.html.var from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/HTTP_INTERNAL_SERVER_ERROR.html.var from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/HTTP_LENGTH_REQUIRED.html.var from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/HTTP_METHOD_NOT_ALLOWED.html.var from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/HTTP_NOT_FOUND.html.var from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/HTTP_NOT_IMPLEMENTED.html.var from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/HTTP_PRECONDITION_FAILED.html.var from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/HTTP_REQUEST_ENTITY_TOO_LARGE.html.var from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/HTTP_REQUEST_TIME_OUT.html.var from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/HTTP_REQUEST_URI_TOO_LARGE.html.var from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/HTTP_SERVICE_UNAVAILABLE.html.var from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/HTTP_UNAUTHORIZED.html.var from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/HTTP_UNSUPPORTED_MEDIA_TYPE.html.var from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/HTTP_VARIANT_ALSO_VARIES.html.var from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/contact.html.var from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/include/bottom.html from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/include/spacer.html from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/error/include/top.html from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/README.html from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/a.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/a.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/alert.black.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/alert.black.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/alert.red.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/alert.red.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/apache_pb.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/apache_pb.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/apache_pb2.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/apache_pb2.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/ball.gray.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/ball.gray.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/ball.red.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/ball.red.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/binary.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/binary.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/binhex.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/binhex.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/binhex.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/binhex.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/blank.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/blank.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/bomb.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/bomb.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/box1.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/box1.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/box2.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/box2.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/broken.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/broken.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/broken.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/broken.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/burst.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/burst.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/burst.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/burst.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/c.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/c.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/comp.blue.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/comp.blue.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/comp.gray.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/comp.gray.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/compressed.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/compressed.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/compressed.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/compressed.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/continued.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/continued.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/continued.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/continued.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/dir.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/diskimg.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/diskimg.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/down.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/dvi.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/dvi.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/f.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/f.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/folder.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/folder.open.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/folder.open.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/folder.sec.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/folder.sec.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/forward.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/forward.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/generic.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/generic.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/generic.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/generic.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/generic.red.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/generic.red.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/generic.sec.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/generic.sec.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/hand.right.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/hand.right.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/hand.up.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/hand.up.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/icon.sheet.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/icon.sheet.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/image1.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/image1.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/image2.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/image2.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/image2.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/image2.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/image3.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/image3.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/layout.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/layout.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/left.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/link.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/link.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/movie.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/movie.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/movie.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/movie.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/p.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/p.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/patch.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/patch.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/patch.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/patch.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pdf.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pie0.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pie0.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pie1.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pie1.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pie2.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pie2.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pie3.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pie3.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pie4.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pie4.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pie5.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pie5.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pie6.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pie6.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pie7.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pie7.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pie8.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/pie8.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/portal.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/portal.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/poweredby.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/ps.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/ps.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/quill.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/quill.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/right.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/screw1.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/screw1.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/screw2.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/screw2.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/script.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/comp1.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/comp1.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/comp2.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/comp2.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/generic2.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/generic2.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/generic3.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/generic3.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/key.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/key.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/rainbow.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/rainbow.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/sound.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/sound.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/sound2.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/sound2.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/sound2.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/sound2.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/tar.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/tar.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/tar.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/tar.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/transfer.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/transfer.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/transfer.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/transfer.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/uu.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/uu.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/small/uu.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/uu.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/sound1.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/sound1.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/sphere1.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/sphere1.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/sphere2.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/sphere2.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/tex.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/tex.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/up.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/uuencoded.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/uuencoded.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/world1.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/world1.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/world2.gif from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64 file /var/www/icons/world2.png from install of httpd24-2.4.6-2.49.amzn1.x86_64 conflicts with file from package httpd-1:2.2.21-1.19.el6.vm.x86_64

Error Summary

yum -y -d 2 install virtualmin-base failed. Error (if any): 0

Displaying the last 15 lines of /root/virtualmin-install.log to help troubleshoot this problem: wbt-virtual-server-mobile noarch 2:2.5-1 virtualmin-universal 72 k wbt-virtual-server-theme noarch 2:8.7-1 virtualmin-universal 2.2 M webmin noarch 1.675-1 virtualmin-universal 21 M

Transaction Summary

Install 1 Package (+29 Dependent packages)

Total download size: 84 M Installed size: 154 M

Downloading packages:

Total 3.3 MB/s | 84 MB 00:25
Running transaction check Running transaction test

FATAL - Fatal Error Occurred: Installation failed: 0 FATAL - Cannot continue installation. FATAL - Attempting to remove virtualmin repository configuration, so the installation can be FATAL - re-attempted after any problems have been resolved. warning: /etc/yum.repos.d/virtualmin.repo saved as /etc/yum.repos.d/virtualmin.repo.rpmsave FATAL - Removing temporary directory and files. FATAL - If you are unsure of what went wrong, you may wish to review the log FATAL - in /root/virtualmin-install.log [ec2-user@ip-172-31-25-209 ~]$

Wed, 03/19/2014 - 19:53
popowich

I am getting the same results form the latest release, the combination of packages it's trying to install is causing it to try and yum install both httpd and httpd24.

Thu, 03/20/2014 - 11:31
andreychek

What output do you receive if you run this command:

rpm -qa | grep httpd

Thu, 03/20/2014 - 20:46
popowich

There is no httpd installed on a new instance:

[ec2-user@ip-x-x-x-x ~]$ rpm -qa | grep httpd

[ec2-user@ip-x-x-x-x ~]$

virtualmin is trying to install both the httpd and httpd24 packages on a fresh system.

It appears due to the dependencies of the other packages being installed.

Fri, 03/28/2014 - 10:47
popowich

In addition to new systems not installing, yum update of existing systems on amazon linux are failing now too:

--> Processing Dependency: perl(:MODULE_COMPAT_5.10.1) for package: perl-IO-Tty-1.08-3.el6.x86_64 --> Finished Dependency Resolution Error: Package: perl-IO-Tty-1.08-3.el6.x86_64 (@virtualmin) Requires: perl(:MODULE_COMPAT_5.10.1) Removing: 4:perl-5.10.1-136.21.amzn1.x86_64 (@amzn-updates) perl(:MODULE_COMPAT_5.10.1) Updated By: 4:perl-5.16.3-280.30.amzn1.x86_64 (amzn-main) ~perl(:MODULE_COMPAT_5.16.3) ~perl(:MODULE_COMPAT_5.16.2) ~perl(:MODULE_COMPAT_5.16.1) ~perl(:MODULE_COMPAT_5.16.0) You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

Tue, 04/01/2014 - 07:38
PlayGod

I have a couple of existing instances (webmin and virtualmin pro), and Amazon Linux is now at 2014.03. Testing update: it chokes on perl 5.16:

11 package(s) needed for security, out of 223 available
Run "sudo yum update" to apply all updates.
Amazon Linux version 2014.03 is available.

[ec2-user@blahblah ~]$ sudo yum update --downloadonly

Loaded plugins: priorities, update-motd, upgrade-helper
amzn-main/latest                                         | 2.1 kB     00:00    
amzn-updates/latest                                      | 2.3 kB     00:00    
15 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check

(...)

--> Finished Dependency Resolution
--> Running transaction check
---> Package kernel.x86_64 0:3.4.76-65.111.amzn1 will be erased
---> Package perl.x86_64 4:5.10.1-136.21.amzn1 will be updated
--> Processing Dependency: perl(:MODULE_COMPAT_5.10.1) for package: perl-IO-Tty-1.08-3.el6.x86_64
--> Finished Dependency Resolution
Error: Package: perl-IO-Tty-1.08-3.el6.x86_64 (@virtualmin)
           Requires: perl(:MODULE_COMPAT_5.10.1)
           Removing: 4:perl-5.10.1-136.21.amzn1.x86_64 (@amzn-updates)
               perl(:MODULE_COMPAT_5.10.1)
           Updated By: 4:perl-5.16.3-280.34.amzn1.x86_64 (amzn-updates)
              ~perl(:MODULE_COMPAT_5.16.3)
              ~perl(:MODULE_COMPAT_5.16.2)
              ~perl(:MODULE_COMPAT_5.16.1)
              ~perl(:MODULE_COMPAT_5.16.0)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
Tue, 04/01/2014 - 07:40
PlayGod

...subscribing to thread...

Mon, 04/14/2014 - 10:10
mdelorimier

Hi,

I can confirm that i have this problem on 2 amazon instances that we manage. This prevents me from upgrading OpenSSL at this time.

Thank you for you're support

Mon, 04/14/2014 - 10:08
PlayGod

This is obviously an extremely critical issue, given recent security announcements re: SSL.

I requested private support on the issue, and Jamie suggested a workaround that allowed me to upgrade kernel and SSL-related packages.

yum update was hanging up on perl-IO-Tty dependencies. Jamie said Virtualmin should be able to operate without that package.

rpm -e --nodeps perl-IO-Tty allowed yum to complete the transactions.

Mon, 04/14/2014 - 11:05
popowich

The above updates might complete successfully, but on several systems I maintain picking and choosing partial updates resulted in some services such as FTP breaking. Double check your service health if you did partial updates instead of removing virtualmin from the server.

Mon, 04/14/2014 - 18:39
PlayGod

Good advice, popowich. I could not find any processes using perl-IO-Tty, and server health is good, so removal of that package seems to have had no effect on Webmin or Virtualmin server. My servers have very locked-down access... SFTP and SSH only for permitted accounts that require and request SSH access. Virtualmin/Webmin likewise restricted.

Thank for the input, and hopefully Joe & Jamie & Andreychek will continue strong support for Amazon Linux.

Fri, 09/04/2015 - 21:16 (Reply to #18)
geolaw

I just got this working on a new Amazon instance that was just spun up today.

I tweaked this to install httpd24 and php56 ... So far it seems to be working fine - I have set up my first website and php is working, although I have it set up as the apache module, not fastcgi

  1. I installed perl-io-tty first separately.
  2. I am not sure which of these might have been there from the base amazon image, vs the first, second, or third time virtualmin failed to install. Removed http httpd-tools and all of the base php images. 40 sudo yum remove httpd 42 sudo yum remove httpd-tools 62 sudo yum remove rpm -qa |grep php
  3. download the installer. ... I had to make 2 changes a. RH dependacies on line 113. change httpd to httpd24 and all php to php56, as well as mod24_python, etc ...

rhdeps="bind bind-utils caching-nameserver httpd24 postfix spamassassin procmail perl-DBD-Pg perl-DBD-MySQL quota iptables openssl python mailman subversion mysql mysql-server mysql-devel mariadb mariadb-server postgresql postgresql-server rh-postgresql rh-postgresql-server logrotate webalizer php56 php56-xml php56-gd php56-imap php56-mysql php56-odbc php56-pear php56-pgsql php56-snmp php56-xmlrpc php56-mbstring mod24_perl mod24_python cyrus-sasl dovecot spamassassin mod24_dav_svn cyrus-sasl-gssapi mod24_ssl ruby ruby-devel rubygems perl-XML-Simple perl-Crypt-SSLeay mlocate perl-LWP-Protocol-https"

b. add as line 620 to force "latest" as the amazon linux version - os_version='latest' This will make the download link : http://software.virtualmin.com/gpl/amazon/latest/x86_64/virtualmin-base-...

  1. Run the installer - and it will still fail, but it will get the base line out there.
  2. Download http://software.virtualmin.com/gpl/amazon/latest/x86_64/virtualmin-base-...
  3. This is where it got tricky. a. Install rpmrebuild. http://downloads.sourceforge.net/project/rpmrebuild/rpmrebuild/2.11/rpmr... b. $> rpmrebuild -e -p virtualmin-base-1.0-63.rh.noarch.rpm this will open the rpm spec file up in vi ... line 70: change to httpd24 line 71: change to mod24_ssl line 77: change to mod24_dav_svn write and quit out of vi, when asked Do you want to continue ? (y/N) answer y this will build and write the file out, somewhere like /root/rpmbuild/RPMS/noarch/virtualmin-base-1.0-63.rh.noarch.rpm
  4. yum install /root/rpmbuild/RPMS/noarch/virtualmin-base-1.0-63.rh.noarch.rpm