Can't update httpd

29 posts / 0 new
Last post
#1 Sun, 08/25/2013 - 04:11
aleppos

Can't update httpd

yum --disablerepo="*" --enablerepo="virtualmin" update<br />
Loaded plugins: fastestmirror, priorities, protectbase, security<br />
Determining fastest mirrors<br />
virtualmin                                                                                                                                              | 1.2 kB     00:00<br />
virtualmin/primary                                                                                                                                      |  30 kB     00:00<br />
virtualmin: [##################################################################################################################################################       ] 96/1000 packages excluded due to repository protections<br />
Setting up Update Process<br />
Resolving Dependencies<br />
--> Running transaction check<br />
---> Package httpd.x86_64 1:2.2.15-28.el6.vm.2 will be updated<br />
---> Package httpd.x86_64 1:2.2.15-29.el6.vm will be an update<br />
--> Processing Dependency: httpd-tools = 2.2.15-29.el6.vm for package: 1:httpd-2.2.15-29.el6.vm.x86_64<br />
---> Package httpd-tools.x86_64 1:2.2.15-28.el6.vm.2 will be updated<br />
---> Package httpd-tools.x86_64 1:2.2.15-29.el6.vm will be an update<br />
---> Package mod_ssl.x86_64 2:2.2.15-28.el6.vm.2 will be updated<br />
---> Package mod_ssl.x86_64 2:2.2.15-29.el6.vm will be an update<br />
--> Finished Dependency Resolution<br />
Error: Package: 1:httpd-2.2.15-29.el6.vm.x86_64 (virtualmin)<br />
           Requires: httpd-tools = 2.2.15-29.el6.vm<br />
           Removing: 1:httpd-tools-2.2.15-28.el6.vm.2.x86_64 (@virtualmin)<br />
               httpd-tools = 1:2.2.15-28.el6.vm.2<br />
           Updated By: 1:httpd-tools-2.2.15-29.el6.vm.x86_64 (virtualmin)<br />
               httpd-tools = 1:2.2.15-29.el6.vm<br />
           Available: httpd-tools-2.2.15-15.el6.i386 (virtualmin)<br />
               httpd-tools = 2.2.15-15.el6<br />
           Available: 1:httpd-tools-2.2.15-5.el6.vm.x86_64 (virtualmin)<br />
               httpd-tools = 1:2.2.15-5.el6.vm<br />
           Available: 1:httpd-tools-2.2.15-9.el6.2.vm.x86_64 (virtualmin)<br />
               httpd-tools = 1:2.2.15-9.el6.2.vm<br />
           Available: 1:httpd-tools-2.2.15-15.el6.x86_64 (virtualmin)<br />
               httpd-tools = 1:2.2.15-15.el6<br />
           Available: 1:httpd-tools-2.2.15-15.el6.vm.x86_64 (virtualmin)<br />
               httpd-tools = 1:2.2.15-15.el6.vm<br />
           Available: 1:httpd-tools-2.2.15-15.el6.vm.1.x86_64 (virtualmin)<br />
               httpd-tools = 1:2.2.15-15.el6.vm.1<br />
           Available: 1:httpd-tools-2.2.15-28.el6.vm.x86_64 (virtualmin)<br />
               httpd-tools = 1:2.2.15-28.el6.vm<br />
           Available: 1:httpd-tools-2.2.15-28.el6.vm.1.x86_64 (virtualmin)<br />
               httpd-tools = 1:2.2.15-28.el6.vm.1<br />
You could try using --skip-broken to work around the problem<br />
You could try running: rpm -Va --nofiles --nodigest<br />
Sun, 08/25/2013 - 04:54
boyosof

please help me ... i have the above problem appeared today

Sun, 08/25/2013 - 05:19
Dingo

Hi

I also have the same problem with 3 updates that appeared today. httpd, httpd-tools & mod_ssl.

Regards

Dingo

Sun, 08/25/2013 - 06:22
Schnuecks

I also have the same problem too. The 3 updates are httpd, httpd-tools and mod_ssl.

Greetings

Schnuecks

Sun, 08/25/2013 - 07:25
webwzrd

Same here.

Package Description Version
httpd Apache HTTP Server 2.2.15-29.el6.vm mod_ssl SSL/TLS module for the Apache HTTP Server 2.2.15-29.el6.vm

Sun, 08/25/2013 - 07:38
JamesSimpson

Yep also get the same error message today with the two new updates

Installing package(s) with command yum -y install httpd ..   Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: mirror.bytemark.co.uk * extras: centos.hyve.com * rpmforge: ftp.nluug.nl * updates: mirrors.coreix.net Setting up Install Process Resolving Dependencies --> Running transaction check ---> Package httpd.x86_64 1:2.2.15-28.el6.vm.2 will be updated --> Processing Dependency: httpd = 1:2.2.15-28.el6.vm.2 for package: 2:mod_ssl-2.2.15-28.el6.vm.2.x86_64 --> Processing Dependency: httpd = 1:2.2.15-28.el6.vm.2 for package: 1:httpd-devel-2.2.15-28.el6.vm.2.x86_64 ---> Package httpd.x86_64 1:2.2.15-29.el6.vm will be an update --> Processing Dependency: httpd-tools = 2.2.15-29.el6.vm for package: 1:httpd-2.2.15-29.el6.vm.x86_64 --> Running transaction check ---> Package httpd.x86_64 1:2.2.15-29.el6.vm will be an update --> Processing Dependency: httpd-tools = 2.2.15-29.el6.vm for package: 1:httpd-2.2.15-29.el6.vm.x86_64 ---> Package httpd-devel.x86_64 1:2.2.15-28.el6.vm.2 will be updated ---> Package httpd-devel.x86_64 1:2.2.15-29.el6.vm will be an update ---> Package mod_ssl.x86_64 2:2.2.15-28.el6.vm.2 will be updated ---> Package mod_ssl.x86_64 2:2.2.15-29.el6.vm will be an update --> Finished Dependency Resolution Error: Package: 1:httpd-2.2.15-29.el6.vm.x86_64 (virtualmin) Requires: httpd-tools = 2.2.15-29.el6.vm Installed: 1:httpd-tools-2.2.15-28.el6.vm.2.x86_64 (@virtualmin) httpd-tools = 1:2.2.15-28.el6.vm.2 Available: httpd-tools-2.2.15-15.el6.i386 (virtualmin) httpd-tools = 2.2.15-15.el6 Available: httpd-tools-2.2.15-26.el6.centos.x86_64 (base) httpd-tools = 2.2.15-26.el6.centos Available: httpd-tools-2.2.15-28.el6.centos.x86_64 (updates) httpd-tools = 2.2.15-28.el6.centos Available: httpd-tools-2.2.15-29.el6.centos.x86_64 (updates) httpd-tools = 2.2.15-29.el6.centos Available: 1:httpd-tools-2.2.15-5.el6.vm.x86_64 (virtualmin) httpd-tools = 1:2.2.15-5.el6.vm Available: 1:httpd-tools-2.2.15-9.el6.2.vm.x86_64 (virtualmin) httpd-tools = 1:2.2.15-9.el6.2.vm Available: 1:httpd-tools-2.2.15-15.el6.x86_64 (virtualmin) httpd-tools = 1:2.2.15-15.el6 Available: 1:httpd-tools-2.2.15-15.el6.vm.x86_64 (virtualmin) httpd-tools = 1:2.2.15-15.el6.vm Available: 1:httpd-tools-2.2.15-15.el6.vm.1.x86_64 (virtualmin) httpd-tools = 1:2.2.15-15.el6.vm.1 Available: 1:httpd-tools-2.2.15-28.el6.vm.x86_64 (virtualmin) httpd-tools = 1:2.2.15-28.el6.vm Available: 1:httpd-tools-2.2.15-28.el6.vm.1.x86_64 (virtualmin) httpd-tools = 1:2.2.15-28.el6.vm.1 Available: 1:httpd-tools-2.2.15-29.el6.vm.x86_64 (virtualmin) httpd-tools = 1:2.2.15-29.el6.vm You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest   .. install failed!

And then

Now updating mod_ssl ..   Installing package(s) with command yum -y install mod_ssl ..   Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: mirror.bytemark.co.uk * extras: centos.hyve.com * rpmforge: ftp.nluug.nl * updates: mirrors.coreix.net Setting up Install Process Resolving Dependencies --> Running transaction check ---> Package mod_ssl.x86_64 2:2.2.15-28.el6.vm.2 will be updated ---> Package mod_ssl.x86_64 2:2.2.15-29.el6.vm will be an update --> Processing Dependency: httpd = 1:2.2.15-29.el6.vm for package: 2:mod_ssl-2.2.15-29.el6.vm.x86_64 --> Running transaction check ---> Package httpd.x86_64 1:2.2.15-28.el6.vm.2 will be updated --> Processing Dependency: httpd = 1:2.2.15-28.el6.vm.2 for package: 1:httpd-devel-2.2.15-28.el6.vm.2.x86_64 ---> Package httpd.x86_64 1:2.2.15-29.el6.vm will be an update --> Processing Dependency: httpd-tools = 2.2.15-29.el6.vm for package: 1:httpd-2.2.15-29.el6.vm.x86_64 --> Running transaction check ---> Package httpd.x86_64 1:2.2.15-29.el6.vm will be an update --> Processing Dependency: httpd-tools = 2.2.15-29.el6.vm for package: 1:httpd-2.2.15-29.el6.vm.x86_64 ---> Package httpd-devel.x86_64 1:2.2.15-28.el6.vm.2 will be updated ---> Package httpd-devel.x86_64 1:2.2.15-29.el6.vm will be an update --> Finished Dependency Resolution Error: Package: 1:httpd-2.2.15-29.el6.vm.x86_64 (virtualmin) Requires: httpd-tools = 2.2.15-29.el6.vm Installed: 1:httpd-tools-2.2.15-28.el6.vm.2.x86_64 (@virtualmin) httpd-tools = 1:2.2.15-28.el6.vm.2 Available: httpd-tools-2.2.15-15.el6.i386 (virtualmin) httpd-tools = 2.2.15-15.el6 Available: httpd-tools-2.2.15-26.el6.centos.x86_64 (base) httpd-tools = 2.2.15-26.el6.centos Available: httpd-tools-2.2.15-28.el6.centos.x86_64 (updates) httpd-tools = 2.2.15-28.el6.centos Available: httpd-tools-2.2.15-29.el6.centos.x86_64 (updates) httpd-tools = 2.2.15-29.el6.centos Available: 1:httpd-tools-2.2.15-5.el6.vm.x86_64 (virtualmin) httpd-tools = 1:2.2.15-5.el6.vm Available: 1:httpd-tools-2.2.15-9.el6.2.vm.x86_64 (virtualmin) httpd-tools = 1:2.2.15-9.el6.2.vm Available: 1:httpd-tools-2.2.15-15.el6.x86_64 (virtualmin) httpd-tools = 1:2.2.15-15.el6 Available: 1:httpd-tools-2.2.15-15.el6.vm.x86_64 (virtualmin) httpd-tools = 1:2.2.15-15.el6.vm Available: 1:httpd-tools-2.2.15-15.el6.vm.1.x86_64 (virtualmin) httpd-tools = 1:2.2.15-15.el6.vm.1 Available: 1:httpd-tools-2.2.15-28.el6.vm.x86_64 (virtualmin) httpd-tools = 1:2.2.15-28.el6.vm Available: 1:httpd-tools-2.2.15-28.el6.vm.1.x86_64 (virtualmin) httpd-tools = 1:2.2.15-28.el6.vm.1 Available: 1:httpd-tools-2.2.15-29.el6.vm.x86_64 (virtualmin) httpd-tools = 1:2.2.15-29.el6.vm You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest   .. install failed!
Sun, 08/25/2013 - 08:14
andreychek

Yeah, there's a problem with the Apache packages -- I've notified Joe so that he can look into that. It should be fixed shortly!

-Eric

Sun, 08/25/2013 - 08:55
nflix

hi, i'm receiving the same issue on centos 6 64bit. is there a way to install an old working virtualmin script? i was going crazy before i've read this thread. thank you so much

Sun, 08/25/2013 - 12:35
szehau

Hi, it is now ok for the updates but I can't start apache!

[Sun Aug 25 17:16:54 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec) [Sun Aug 25 17:16:54 2013] [error] Server should be SSL-aware but has no certificate configured [Hint: SSLCertificateFile] (/etc/httpd/conf/httpd.conf:1379)

Please help! [I disabled port 443 and apache is able to start]

Sun, 08/25/2013 - 12:54
andreychek

Howdy,

The issue should be corrected now -- be sure to run yum clean all prior to attempting the upgrade or installation again, as yum has incorrect dependency info in it's metadata.

-Eric

Sun, 08/25/2013 - 13:00
bvansomeren

Andreychek.

Did this also fix the "not being able to restart Apache" problem from szehau. Reluctant to update anything if there is a chance of breakage.

Sun, 08/25/2013 - 13:32
andreychek

We haven't been able to reproduce an issue that prevents Apache from starting.

The update worked properly on all the systems we attempted it on, including the virtualmin.com server.

If anyone else sees that issue, please let us know so we can perform further review. Be sure to mention what distro/version you're using in that report.

The Apache package is identical to what CentOS provides, except with suexec compiled to use /home rather than /var/www.

However, if there's any concern about that, there's no harm in waiting a day, or trying it first on a test server, to make sure nothing unusual is going on.

-Eric

Sun, 08/25/2013 - 13:49
bvansomeren

You're right, it works fine on a test server. Thanks :)

Sun, 08/25/2013 - 15:07
Dingo

All fine here too. Many thanks.

Regards

Dingo

Sun, 08/25/2013 - 15:12
prooi

Updating works fine again :)

Sun, 08/25/2013 - 22:45
szehau

I'm not sure why but it seems that my SSL settings for VirtualServer *:443 gone after the update. I can enable SSL and start apache after I have added the default settings back

DocumentRoot /var/www/html allow from all Options +Indexes SSLEngine on SSLProtocol +SSLv3 +TLSv1 SSLCertificateFile /etc/pki/tls/certs/localhost.crt SSLCertificateKeyFile /etc/pki/tls/private/localhost.key

Mon, 08/26/2013 - 00:37
boyosof

It works fine now :)

Mon, 08/26/2013 - 01:11
aleppos

after upgrade PHP not work, only work with one virtual host ?

please help me to fix this problem ?

Mon, 08/26/2013 - 07:18 (Reply to #18)
andreychek

That sounds like a PHP issue, possibly related to having third party repositories enabled... could you start a new Forum thread for that issue, and in that new thread, include the output of the command rpm -qa | grep php-.

Thanks!

-Eric

Sat, 08/29/2015 - 06:17
ivanbg

Hello, I have the same problem with the last update of httpd (august 2015)

Linux 2.6.32-042stab085.20 on i686 CentOS Linux 6.7 Virtualmin version 4.18 httpd Apache HTTP Server New version 2.2.15-47.el6.vm httpd-devel Development interfaces for the Apache HTTP server New version 2.2.15-47.el6.vm
httpd-tools Tools for use with the Apache HTTP Server New version 2.2.15-47.el6.vm V mod_ssl SSL/TLS module for the Apache HTTP Server New version 2.2.15-47.el6.vm

yum update

Complementos cargados:fastestmirror Configurando el proceso de actualización Loading mirror speeds from cached hostfile * base: mirror.cc.columbia.edu * extras: mirrors.lga7.us.voxel.net * updates: mirror.ash.fastserv.com Resolviendo dependencias --> Ejecutando prueba de transacción ---> Package httpd.i686 1:2.2.15-39.el6.vm will be actualizado ---> Package httpd.i686 1:2.2.15-47.el6.vm will be an update --> Procesando dependencias: httpd-tools = 2.2.15-47.el6.vm para el paquete: 1:httpd-2.2.15-47.el6.vm.i686 ---> Package httpd-devel.i686 1:2.2.15-39.el6.vm will be actualizado ---> Package httpd-devel.i686 1:2.2.15-47.el6.vm will be an update ---> Package httpd-tools.i686 1:2.2.15-39.el6.vm will be actualizado ---> Package httpd-tools.i686 1:2.2.15-47.el6.vm will be an update ---> Package mod_ssl.i686 2:2.2.15-39.el6.vm will be actualizado ---> Package mod_ssl.i686 2:2.2.15-47.el6.vm will be an update --> Resolución de dependencias finalizada Error: Paquete: 1:httpd-2.2.15-47.el6.vm.i686 (virtualmin) Necesita: httpd-tools = 2.2.15-47.el6.vm Eliminando: 1:httpd-tools-2.2.15-39.el6.vm.i686 (@virtualmin) httpd-tools = 1:2.2.15-39.el6.vm Actualizado por: 1:httpd-tools-2.2.15-47.el6.vm.i686 (virtualmin) httpd-tools = 1:2.2.15-47.el6.vm Disponible: httpd-tools-2.2.15-45.el6.centos.i686 (base) httpd-tools = 2.2.15-45.el6.centos Disponible: httpd-tools-2.2.15-47.el6.centos.i686 (updates) httpd-tools = 2.2.15-47.el6.centos Disponible: 1:httpd-tools-2.2.15-9.el6.2.vm.i686 (virtualmin) httpd-tools = 1:2.2.15-9.el6.2.vm Disponible: 1:httpd-tools-2.2.15-9.sl6.vm.i386 (virtualmin) httpd-tools = 1:2.2.15-9.sl6.vm Disponible: 1:httpd-tools-2.2.15-15.el6.vm.i386 (virtualmin) httpd-tools = 1:2.2.15-15.el6.vm Disponible: 1:httpd-tools-2.2.15-15.el6.vm.1.i686 (virtualmin) httpd-tools = 1:2.2.15-15.el6.vm.1 Disponible: 1:httpd-tools-2.2.15-28.el6.vm.i686 (virtualmin) httpd-tools = 1:2.2.15-28.el6.vm Disponible: 1:httpd-tools-2.2.15-28.el6.vm.1.i686 (virtualmin) httpd-tools = 1:2.2.15-28.el6.vm.1 Disponible: 1:httpd-tools-2.2.15-29.el6.vm.i686 (virtualmin) httpd-tools = 1:2.2.15-29.el6.vm Disponible: 1:httpd-tools-2.2.15-29.el6.vm.1.i686 (virtualmin) httpd-tools = 1:2.2.15-29.el6.vm.1 Disponible: 1:httpd-tools-2.2.15-30.el6.vm.i686 (virtualmin) httpd-tools = 1:2.2.15-30.el6.vm Disponible: 1:httpd-tools-2.2.15-31.el6.centos.vm.i686 (virtualmin) httpd-tools = 1:2.2.15-31.el6.centos.vm Podría intentar utilizar el comando --skip-broken para sortear el problema Podría intentar ejecutar: rpm- Va --nofiles --nodigest

Tue, 09/01/2015 - 09:14 (Reply to #20)
andreychek

Joe is looking into this issue, hopefully he'll have it resolved shortly.

-Eric

Tue, 09/01/2015 - 21:00
kiteplans

Hey guys,

I am running into this problem as well.

I have cleared Yum Cache via -

yum clean all

But when I try to update I still get

(1/3): httpd-2.2.15-47.el6.vm.1.i686.rpm                 | 828 kB     00:00    
(2/3): httpd-tools-2.2.15-47.el6.vm.1.i686.rpm           |  76 kB     00:00    
(3/3): mod_ssl-2.2.15-47.el6.vm.1.i686.rpm               |  95 kB     00:00    
--------------------------------------------------------------------------------
Total                                           1.2 MB/s | 1.0 MB     00:00    


Package httpd-tools-2.2.15-47.el6.vm.1.i686.rpm is not signed
Tue, 09/01/2015 - 22:53 (Reply to #22)
andreychek

Howdy,

Did you try that shortly before posting? Joe had pushed out new packages to the repo today, but if you tried that just before posting it's possible there was a problem with the packages he pushed out.

-Eric

Tue, 09/01/2015 - 22:59 (Reply to #23)
kiteplans

Yes, I tried it just before posting - I tried it again just now.

[root@server server]# yum clean all
Loaded plugins: fastestmirror, security
Cleaning repos: base extras longview updates virtualmin virtualmin-universal
Cleaning up Everything
Cleaning up list of fastest mirrors
[root@server server]# yum update
Loaded plugins: fastestmirror, security
Setting up Update Process
Determining fastest mirrors
* base: centos.sonn.com
* extras: mirror.hmc.edu
* updates: mirrors.easynews.com
base                                                     | 3.7 kB     00:00    
base/primary_db                                          | 3.6 MB     00:00    
extras                                                   | 3.4 kB     00:00    
extras/primary_db                                        |  26 kB     00:00    
longview                                                 | 2.9 kB     00:00    
longview/primary_db                                      |  30 kB     00:00    
updates                                                  | 3.4 kB     00:00    
updates/primary_db                                       | 1.3 MB     00:00    
virtualmin                                               | 1.2 kB     00:00    
virtualmin/primary                                       |  37 kB     00:00    
virtualmin                                                              131/131
virtualmin-universal                                     | 1.2 kB     00:00    
virtualmin-universal/primary                             | 8.2 kB     00:00    
virtualmin-universal                                                      55/55
Resolving Dependencies
--> Running transaction check
---> Package httpd.i686 1:2.2.15-39.el6.vm will be updated
---> Package httpd.i686 1:2.2.15-47.el6.vm.1 will be an update
---> Package httpd-tools.i686 1:2.2.15-39.el6.vm will be updated
---> Package httpd-tools.i686 1:2.2.15-47.el6.vm.1 will be an update
---> Package mod_ssl.i686 2:2.2.15-39.el6.vm will be updated
---> Package mod_ssl.i686 2:2.2.15-47.el6.vm.1 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package           Arch       Version                    Repository        Size
================================================================================
Updating:
httpd             i686       1:2.2.15-47.el6.vm.1       virtualmin       828 k
httpd-tools       i686       1:2.2.15-47.el6.vm.1       virtualmin        76 k
mod_ssl           i686       2:2.2.15-47.el6.vm.1       virtualmin        95 k

Transaction Summary
================================================================================
Upgrade       3 Package(s)

Total download size: 1.0 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): httpd-2.2.15-47.el6.vm.1.i686.rpm                 | 828 kB     00:00    
(2/3): httpd-tools-2.2.15-47.el6.vm.1.i686.rpm           |  76 kB     00:00    
(3/3): mod_ssl-2.2.15-47.el6.vm.1.i686.rpm               |  95 kB     00:00    
--------------------------------------------------------------------------------
Total                                           1.2 MB/s | 1.0 MB     00:00    


Package httpd-tools-2.2.15-47.el6.vm.1.i686.rpm is not signed
Wed, 09/02/2015 - 11:29
andreychek

Okay, can you try it again now?

-Eric

Thu, 09/03/2015 - 04:16
kiteplans

Great it works now!

Updated:
  httpd.i686 1:2.2.15-47.el6.vm.1      httpd-tools.i686 1:2.2.15-47.el6.vm.1  
  mod_ssl.i686 2:2.2.15-47.el6.vm.1  

Complete!
Fri, 06/03/2016 - 12:16
cursor

I am still getting the same error as yesterday. I did a "yum clean all":

[root@server ~]# yum clean all Loaded plugins: fastestmirror, langpacks Cleaning repos: base epel extras main-peer1 rpmforge updates virtualmin virtualmin-universal Cleaning up everything Cleaning up list of fastest mirrors [root@server ~]# yum upgrade Loaded plugins: fastestmirror, langpacks base | 3.6 kB 00:00:00
epel/x86_64/metalink | 6.5 kB 00:00:00
epel | 4.3 kB 00:00:00
extras | 3.4 kB 00:00:00
main-peer1 | 3.0 kB 00:00:00
rpmforge | 1.9 kB 00:00:00
updates | 3.4 kB 00:00:00
virtualmin | 2.5 kB 00:00:00
virtualmin-universal | 2.5 kB 00:00:00
(1/11): base/7/x86_64/group_gz | 155 kB 00:00:00
(2/11): epel/x86_64/group_gz | 170 kB 00:00:00
(3/11): base/7/x86_64/primary_db | 5.3 MB 00:00:00
(4/11): epel/x86_64/updateinfo | 558 kB 00:00:00
(5/11): main-peer1/7/x86_64/group_gz | 871 B 00:00:00
(6/11): main-peer1/7/x86_64/primary_db | 25 kB 00:00:00
(7/11): extras/7/x86_64/primary_db | 132 kB 00:00:00
(8/11): epel/x86_64/primary_db | 4.1 MB 00:00:00
(9/11): virtualmin-universal/primary_db | 35 kB 00:00:00
(10/11): virtualmin/7/x86_64/primary_db | 98 kB 00:00:00
(11/11): updates/7/x86_64/primary_db | 4.9 MB 00:00:02
rpmforge/primary_db | 125 kB 00:00:00
Determining fastest mirrors * base: mirrors.unifiedlayer.com * epel: mirror.prgmr.com * extras: mirror.ancl.hawaii.edu * main-peer1: yum01lax.peer1.com * rpmforge: mirror.hmc.edu * updates: bay.uchicago.edu Resolving Dependencies --> Running transaction check ---> Package httpd.x86_64 1:2.4.6-31.el7.centos.1.vm will be updated ---> Package httpd.x86_64 1:2.4.6-40.el7.centos.vm.1 will be an update ---> Package httpd-manual.noarch 1:2.4.6-31.el7.centos.1.vm will be updated ---> Package httpd-manual.noarch 1:2.4.6-40.el7.centos.vm.1 will be an update --> Processing Dependency: httpd = 2.4.6-40.el7.centos.vm.1 for package: 1:httpd-manual-2.4.6-40.el7.centos.vm.1.noarch ---> Package httpd-tools.x86_64 1:2.4.6-31.el7.centos.1.vm will be updated ---> Package httpd-tools.x86_64 1:2.4.6-40.el7.centos.vm.1 will be an update ---> Package mod_ssl.x86_64 2:2.4.6-31.el7.centos.1.vm will be updated ---> Package mod_ssl.x86_64 2:2.4.6-40.el7.centos.vm.1 will be an update --> Finished Dependency Resolution Error: Package: 1:httpd-manual-2.4.6-40.el7.centos.vm.1.noarch (virtualmin) Requires: httpd = 2.4.6-40.el7.centos.vm.1 Removing: 1:httpd-2.4.6-31.el7.centos.1.vm.x86_64 (@virtualmin) httpd = 1:2.4.6-31.el7.centos.1.vm Updated By: 1:httpd-2.4.6-40.el7.centos.vm.1.x86_64 (virtualmin) httpd = 1:2.4.6-40.el7.centos.vm.1 Available: httpd-2.4.6-40.el7.centos.x86_64 (base) httpd = 2.4.6-40.el7.centos Available: httpd-2.4.6-40.el7.centos.1.x86_64 (updates) httpd = 2.4.6-40.el7.centos.1 Available: 1:httpd-2.4.6-17.el7.centos.centos.1.vm.x86_64 (virtualmin) httpd = 1:2.4.6-17.el7.centos.centos.1.vm Available: 1:httpd-2.4.6-18.el7.centos.vm.x86_64 (virtualmin) httpd = 1:2.4.6-18.el7.centos.vm Available: 1:httpd-2.4.6-18.el7.centos.vm.1.x86_64 (virtualmin) httpd = 1:2.4.6-18.el7.centos.vm.1 Available: 1:httpd-2.4.6-19.el7.centos.vm.x86_64 (virtualmin) httpd = 1:2.4.6-19.el7.centos.vm Available: 1:httpd-2.4.6-19.el7.centos.vm.2.x86_64 (virtualmin) httpd = 1:2.4.6-19.el7.centos.vm.2 Available: 1:httpd-2.4.6-31.el7.centos.vm.x86_64 (virtualmin) httpd = 1:2.4.6-31.el7.centos.vm You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

Fri, 06/03/2016 - 12:20 (Reply to #27)
cursor

I did not notice that this is a problem from years ago. I just did a search and I have the exact same problem today!

Wed, 06/08/2016 - 04:31
inaciose

If you dont care about the httpd-manual try:

rpm -e httpd-manual

Then you can update the others httpd packages

Advised at: https://www.virtualmin.com/node/40993

Regards