Wembim Squid Module

Dear, guys, hi!

Happy New Year first of all!! ;)

I'd like to know if there is a Squid module for Webmin that supports version 3+? Now, I have a message that only version 1 and 2 are supported?

Is this correct in any way?

Ilia

Status: 
Active

Comments

The Squid module supports version 3 just fine. Where are you seeing the message about lack of version 3 support?

Ilia's picture
Submitted by Ilia on Sat, 01/18/2014 - 13:31

I see the following error message when running Squid module:

Your version of Squid is not supported by Webmin. Only versions from 1.1 to 2.7 are supported by this module.   The command squid -v returned :   Squid Cache: Version 3.4.1

Besides another problem using Jabber module: I see the following error message:

The Jabber config file /etc/jabber.xml does not exist. Either Jabber is not installed, or your module configuration is incorrect.

I install Jabber, using:

yum install jabberd

Package name: jabberd-2.2.14-5.el6.x86_64

Is there something wrong? Is there an alternative good Jabber Server?

Ok, it seems there is a but that breaks suport for Squid 3.4 - I will fix that in the next release.

As for Jabber, does that /etc/jabber.xml file get created after installer jabberd ?

Ilia's picture
Submitted by Ilia on Sat, 01/18/2014 - 14:12

Squid:

Thank you, will wait for an update! (Even though it's already up and working just fine, I'd like to have some visuals.. and ability to edit confs with web browser, if needed)

Jabber:

No, the new installation of jabberd2, has 4 different xml files (really ridiculous really). I might use openfire instead! Take a look at new rpm package to update the module accordingly:

http://dl.fedoraproject.org/pub/epel/6/x86_64/jabberd-2.2.14-5.el6.x86_64.rpm

Sincerely, ilia

Ok, unfortunately Webmin only supports jabberd version 1.