Authentic is Webmin/Usermin theme based on Bootstrap and Font Awesome that you just longed to get.

273 posts / 0 new
Last post
Sun, 11/30/2014 - 01:41 (Reply to #51)
Ilia
Ilia's picture

I see. It will also fail working with my theme unless I update it, right?

Sun, 11/30/2014 - 03:08 (Reply to #52)
Joe
Joe's picture

I'm not sure how it will be migrated in Virtualmin, though it's very likely that what already works in existing themes (of which there's really only the Virtualmin Framed Theme that is fully functional, and your theme that's close to being fully functional, and maybe the also-new Finally theme is also mostly functional, for Virtualmin) will continue to work as-is for a long while.

But, merging the new function into your code should be much easier than all the other menu stuff you've worked on. And, it'll probably provide a bit of code you can add to your theme.pl (or your index.cgi) to convert the data structure provided by this function into HTML that you can style and customize however you like.

In short, it shouldn't be hard to update your theme to use the new function. If it is, We can tweak it until it's nicer.

--

Check out the forum guidelines!

Sun, 11/30/2014 - 03:21 (Reply to #53)
Ilia
Ilia's picture

Great, I will keep watching over up-coming updates. ;)

Thanks, Joe!

Mon, 12/01/2014 - 15:36
Ilia
Ilia's picture

Updated to version 6.6.0

  • Added basic support for Cloudmin module
  • Added TinyMCE text editor for Mail modules
  • Fixed display issues in Mail modules
  • Fixed login page being displayed inside of the right frame, when session is expired
  • Fixed all possible issues with missing input fields, in all modules, including ProFTPd module
  • Fixed minor UI bugs

Notice: There are some probles with graphs in Virtualmin Pro versions and in some other places, I'm aware of that and will fix it next time.

Sun, 12/21/2014 - 11:14
Ilia
Ilia's picture

Please welcome, new and very big update of Authentic Theme, v.7.0.0.

https://github.com/qooob/authentic-theme

I will look into the new menu generating Webmin functions codes after the Xmas.

Hope you like new 7.0.0 update.

Thank you.

Mon, 12/22/2014 - 02:43
fakemoth
fakemoth's picture

Updated. Thanks Ilia, love your work!

Don't take the name of root in vain...

Mon, 12/22/2014 - 02:50 (Reply to #57)
Ilia
Ilia's picture

Thank you! :D

Sun, 01/04/2015 - 16:18
Ilia
Ilia's picture

Updated to version 8.0.0

  • Added Quick Search. No more searching through the menus. Hit Alt+S (⌥S) and start typing to see what you get. When you use suggestions from dropdown, you get quick access to the modules; if you just type and hit enter you get the regular search
  • Added Quick Toggle. It lets you quickly switch between Webmin/Virtualmin/Cloudmin. To toggle use Alt+W (⌥W) / Alt+V (⌥V) / Alt+C (⌥C)
  • Added support for TimePlot for Pro versions of Virtualmin to display System Statistics
  • Added search for CodeMirror files
  • Added basic support for Webminstats module :paperclip:
  • Updated CodeMirror to the latest version 4.10
  • Updated DataTables to the latest version 1.10.4 *Fixed stray tag :paperclip:
  • Fixed sticking out tables on very long content :paperclip:
  • Fixed ConfigServer Security & Firewall UI bugs
  • Fixed minor UI bugs fixes
Sun, 01/04/2015 - 18:46 (Reply to #59)
Joe
Joe's picture

How'd you convince TimePlot to work alongside the JQuery in Boostrap? I found it wouldn't work, even when configured to use the noConflict mode and fixed paths, but I didn't dig too deep as I'm already working on a Rickshaw based history module that will replace System Statistics graphs.

--

Check out the forum guidelines!

Mon, 01/05/2015 - 02:11 (Reply to #60)
Ilia
Ilia's picture

Rickshaw is cool. I was looking at it yesterday. I could integrate it with ease as data-formats are not the same. TimePlot was annoying a bit, yes! To make it work, the point was to make sure that TimePlot api loads before any other js scripts - then TimePlot and all the rest of the apps are fine. :) Sometimes it's much more simple than we expect.

Wed, 01/07/2015 - 08:34
fakemoth
fakemoth's picture

Hello Ilia. And a (late) Happy New Year to everyone! Updated to vs8, first thing I noticed is that in the search field I got something like:

Search in Webmin (⌥S)

Also the Alt+S brings up nothing. What is supposed to happen in fact?

Don't take the name of root in vain...

Wed, 01/07/2015 - 09:00 (Reply to #62)
Ilia
Ilia's picture

Alt+S suppose to focus you on search field. You are seeing this (⌥S) because you don't have UTF-8 encoding set in Webmin configuration. It will be fixed soon in few days.

Alt+S - is a toggle actually for search field. If console is closed, that you get main focus on the document and that's when it always work. If it doesn't just click somewhere on the empty space on inside of the document.

Wed, 01/07/2015 - 09:01 (Reply to #63)
Ilia
Ilia's picture

By the way, did you see after update/install a modal popup window when going to system information?

Wed, 01/07/2015 - 13:52
tpnsolutions
tpnsolutions's picture

Hi,

It took a little to wrap my head around the theme, but in the end I really do like it :-)

Any chance of implementing some "branding" options, like for instance a logo and/or custom color schema?

Best Regards,
Peter Knowles
TPN Solutions

Email: pknowles@tpnsolutions.com
Phone: 604-782-9342
Skype: tpnsupport
Website: http://www.tpnsolutions.com
Best Regards,
Peter Knowles | TPN Solutions
Email: pknowles@tpnsolutions.com | Skype: tpnassist
Thu, 01/08/2015 - 00:30 (Reply to #65)
Ilia
Ilia's picture

Peter, hi! I could try to do it but I would want you to try to think, what would you want this custom branding look like? Try making some screenshot and placing a logo whenever you think/want it to be?

Thu, 01/08/2015 - 01:04 (Reply to #66)
tpnsolutions
tpnsolutions's picture

Hi,

Check out the screenshot at:

http://cdn.tpnimg.com/vmin/authentic-branding.png

This is what I was thinking about for the main UI, just a simple logo above the left menu. It'd make sense that if someone didn't want branding that the UI would appear as it currently does.

Best Regards,
Peter Knowles
TPN Solutions

Email: pknowles@tpnsolutions.com
Phone: 604-782-9342
Skype: tpnsupport
Website: http://www.tpnsolutions.com
Best Regards,
Peter Knowles | TPN Solutions
Email: pknowles@tpnsolutions.com | Skype: tpnassist
Thu, 01/08/2015 - 01:13 (Reply to #67)
Ilia
Ilia's picture

Looks interesting! Let me think of it. I might add it in the next or the next after release!

Thu, 01/08/2015 - 01:15 (Reply to #68)
tpnsolutions
tpnsolutions's picture

Hi,

Check out the screenshot at:

http://cdn.tpnimg.com/vmin/authentic-login-branding.png

This is what I think about for the login screen, just a simple logo above the login form replacing the "Webmin" text. Again, if someone didn't want this, it would be best to default to what you already have.

Best Regards,
Peter Knowles
TPN Solutions

Email: pknowles@tpnsolutions.com
Phone: 604-782-9342
Skype: tpnsupport
Website: http://www.tpnsolutions.com
Best Regards,
Peter Knowles | TPN Solutions
Email: pknowles@tpnsolutions.com | Skype: tpnassist
Thu, 01/08/2015 - 01:39 (Reply to #69)
tpnsolutions
tpnsolutions's picture

Hi,

For the immediate future, I was able to update "index.cgi" and "session_login.cgi" adding my logo, and commenting out the "Webmin" text on the login screen.

Best Regards,
Peter Knowles
TPN Solutions

Email: pknowles@tpnsolutions.com
Phone: 604-782-9342
Skype: tpnsupport
Website: http://www.tpnsolutions.com
Best Regards,
Peter Knowles | TPN Solutions
Email: pknowles@tpnsolutions.com | Skype: tpnassist
Thu, 01/08/2015 - 03:13
fakemoth
fakemoth's picture

Yes Ilia, there was a modal pop-up with a short changelog.

+1 for a custom logo, always had that, both in the login field and the left column.

Don't take the name of root in vain...

Thu, 01/08/2015 - 09:12
Ilia
Ilia's picture

Ohh. If it was there already it will be very doable. Thanks for advising! :D

Thu, 01/08/2015 - 10:46
7stars

Hi Ilia :-) as you certainly know Virtualmin 4.13 is out...

can you do something for the new "Change language" link on the left, please? that solves the lang cache issues and auto reloads the page with the correct language without the user interaction...

thank you

Thu, 01/08/2015 - 10:54
Ilia
Ilia's picture

You want You**** :)) like style dropdown for changing language?

Thu, 01/08/2015 - 11:42
7stars

:-))) Iliaaaaa :p

well, Jamie did an awesome work for sure with the link on the left... even if... maybe you could do it different, eg. transform that page which is linked once you click the link, in a direct dropdown... if you can! i don't know if the API allows you to do that... you could try OR leave it as it is now with the "Change Language" link which takes you to the second page... that is, Jamie understood the functions to be implemented and it works as it should, but OR he didn't think to the direct dropdown or he wanted by purpose to do it in this way... I don't know

regards ;-)

Fri, 01/09/2015 - 10:15 (Reply to #75)
Ilia
Ilia's picture

Alright, I will try doing it in next couple releases. Thanks for advising!

Mon, 01/12/2015 - 22:01
tpnsolutions
tpnsolutions's picture

Hi,

Is there a way to set the default right panel to show the "system information" as it currently defaults to a list of Virtual Servers but IMHO the system information page is a great starting point as an admin and well, looks pretty :-)

Aside from the above which frankly isn't super important just a personal preference, here's a feature I think most would agree would be cool.

In addition to searching Webmin with auto-suggestion which is pretty darn cool, I think it'd also be nifty if you could search for a hosted "virtual server" or "sub-server" by domain name. This would make it quick and easy to manage a domain when there are potentially hundreds of domains on the server.

Keep up the great work!

*** I've been installing Authentic on all our server nodes, and those I install for others ***

Best Regards,
Peter Knowles
TPN Solutions

Email: pknowles@tpnsolutions.com
Phone: 604-782-9342
Skype: tpnsupport
Website: http://www.tpnsolutions.com
Best Regards,
Peter Knowles | TPN Solutions
Email: pknowles@tpnsolutions.com | Skype: tpnassist
Tue, 01/13/2015 - 04:28
Ilia
Ilia's picture

Yes you could (and I will try to make it optional later).

Goto to Authentic Theme installation folder (authentic-theme) that is in /usr/libexec/webmin (on RHEL systems for sure), and edit index.cgi and line number 736, changing it from:

$goto = '/virtual-server/index.cgi';

to

$goto = '/body.cgi';

Searching virtual servers will be added also later. It's not a problem really.. Just need more time for working on the theme.

Regards

Tue, 01/13/2015 - 11:34 (Reply to #78)
tpnsolutions
tpnsolutions's picture

Hi,

Thanks, and thanks!

Happy coding...

Best Regards,
Peter Knowles
TPN Solutions

Email: pknowles@tpnsolutions.com
Phone: 1-604-782-9342
Skype: tpnsupport
Website: http://www.tpnsolutions.com
Best Regards,
Peter Knowles | TPN Solutions
Email: pknowles@tpnsolutions.com | Skype: tpnassist
Sun, 02/01/2015 - 03:08
Ilia
Ilia's picture

Version 9.0.0. is out - most amazing release of Authentic Theme.

YouTube presentation: http://www.youtube.com/watch?v=gfuPFuGpyv8 Please like, comment, report bugs!

Added most wanted features:

  • Changed: Overall UI redesign for better experience
  • Changed: Code core complete rewrite for both server and client-side. Improved speed and browser/plugin compatibility
  • Added support for Virtualmin/Cloudmin missing left menu, for currently selected virtual server/machine. Attention: You need latest Virtualmin installation to make it work. (For Virtualmin Pro, minimum version requirement is 4.13 and for GPL users minimum is 4.14)
  • Added autocomplete for currently opened module in Webmin, currently selected domain and list of all available virtual domains/machines in Virtualmin/Cloudmin modules
  • Added complete mobile support. Navigation menu now has absolutely same functionality for both desktop/mobile versions
  • Added custom logo support. Manual for using it is below
  • Added screen-saver effect (using pure CSS) after 2 minutes of inactivity
  • Added shortcut Alt+R for reloading right frame
  • Added Chinese translation by Dreista
Sun, 02/01/2015 - 11:59 (Reply to #80)
tpnsolutions
tpnsolutions's picture

Hi,

First off, vast improvement from an already cool theme!

Added autocomplete for currently opened module in Webmin, currently selected domain and list of all available virtual domains/machines in Virtualmin/Cloudmin modules

Can you elaborate on what this feature is?

Best Regards,
Peter Knowles
TPN Solutions

Email: pknowles@tpnsolutions.com
Phone: 604-782-9342
Skype: tpnsupport
Website: http://www.tpnsolutions.com

Ask me about my new support plans which include a FREE copy of Virtualmin Pro!!!

Best Regards,
Peter Knowles | TPN Solutions
Email: pknowles@tpnsolutions.com | Skype: tpnassist
Sun, 02/01/2015 - 12:06 (Reply to #81)
Ilia
Ilia's picture

Yes,

At first go to search and start typing something to understand what autocomplete is.

  1. Webmin. Go to, let's say Webmin-Webmin Configuration. After it's loaded and when you again go to Search. All links that are on the right (in Webmin Configuration in this case) will be searchable/clickable through autocomplete.
  2. Same for when you in Virtualmin/Cloudmin.

You can see it in video presentation on YouTube http://www.youtube.com/watch?v=gfuPFuGpyv8

Sun, 02/01/2015 - 12:14 (Reply to #82)
tpnsolutions
tpnsolutions's picture

Hi,

I understand what autocomplete is. I just tried searching for a domain in the search box and totally overlooked that you integrated the domain search requested using autocomplete which is just super.

BTW, not sure if it was a bug or a caching issue, but until installing 9.0.1 onto some nodes this morning, under Virtualmin tab, the "domain dropdown", along with "Create Virtual Server" through "Logs and Reports" (Virtualmin GPL) didn't show up above the "Search" field.

Aside from that, this release definitely is pretty kick ass!

*** I've installed this version onto around half a dozen nodes already within my own infrastructure, and the former 8.x version onto about half a dozen client servers in the past month. ***

Best Regards,
Peter Knowles
TPN Solutions

Email: pknowles@tpnsolutions.com
Phone: 604-782-9342
Skype: tpnsupport
Website: http://www.tpnsolutions.com

Ask me about my new support plans which include a FREE copy of Virtualmin Pro!!!

Best Regards,
Peter Knowles | TPN Solutions
Email: pknowles@tpnsolutions.com | Skype: tpnassist
Sun, 02/01/2015 - 12:23 (Reply to #83)
Ilia
Ilia's picture

Yes, it was most strange behavior of Firefox I ever seen.

I only tweaked it in version 9.0.1. It's very important to upgrade to it.

Thanks, I'm endlessly happy that you're liking it!! :)

Sun, 02/01/2015 - 12:34 (Reply to #84)
tpnsolutions
tpnsolutions's picture

Hi,

Looks like the missing section may have been a bug caused by Virtualmin itself (perhaps in combination with something in your code), as a system which I upgraded to 9.0.1 of your theme still exhibited the issue until I also upgraded Virtualmin from 4.13 to 4.14.

Best Regards,
Peter Knowles
TPN Solutions

Email: pknowles@tpnsolutions.com
Phone: 604-782-9342
Skype: tpnsupport
Website: http://www.tpnsolutions.com

Ask me about my new support plans which include a FREE copy of Virtualmin Pro!!!

Best Regards,
Peter Knowles | TPN Solutions
Email: pknowles@tpnsolutions.com | Skype: tpnassist
Sun, 02/01/2015 - 12:28 (Reply to #85)
tpnsolutions
tpnsolutions's picture

Hi,

I found what may be a bug in the new "cool" custom logo feature.

When the menu on the left has a lot of items open, the logo appears to be overlapped by the content giving you the effect found in the screenshot at:

http://cdn.tpnimg.com/vmin/authentic-logo-overlapping.png

Just thought perhaps instead of allowing this, you could "dedicate" space in the bottom right corner for showing the logo. This way when scrollable content is on screen it is separate from the logo area causing no more overlapping.

*** perhaps as an added benefit even offer the ability in a future release to make the logo "linkable" (just crossed my mind, heh heh). ***

Best Regards,
Peter Knowles
TPN Solutions

Email: pknowles@tpnsolutions.com
Phone: 604-782-9342
Skype: tpnsupport
Website: http://www.tpnsolutions.com

Ask me about my new support plans which include a FREE copy of Virtualmin Pro!!!

Best Regards,
Peter Knowles | TPN Solutions
Email: pknowles@tpnsolutions.com | Skype: tpnassist
Sun, 02/01/2015 - 12:35 (Reply to #86)
Ilia
Ilia's picture

It's not a bug really. Increse the height of your transparent PNG and move your logo at the very bottom of it. ;)

Sun, 02/01/2015 - 12:50 (Reply to #87)
tpnsolutions
tpnsolutions's picture

Hi,

I wasn't referring to where the logo appeared in the panel, yes that was related to the size of the logo itself originally used.

The issue is, content when it spans the whole height of the menu area still renders "on top" of the logo.

Check out the following updated screen shot:

http://cdn.tpnimg.com/vmin/authentic-logo-overlapping-2.png

Best Regards,
Peter Knowles
TPN Solutions

Email: pknowles@tpnsolutions.com
Phone: 604-782-9342
Skype: tpnsupport
Website: http://www.tpnsolutions.com

Ask me about my new support plans which include a FREE copy of Virtualmin Pro!!!

Best Regards,
Peter Knowles | TPN Solutions
Email: pknowles@tpnsolutions.com | Skype: tpnassist
Mon, 02/02/2015 - 03:28 (Reply to #88)
Ilia
Ilia's picture

Well, no, my friend, it's not a bug, because if you scroll down the menu, the logo will not be overlapping menu content, right? :)

I had two options. 1. To make solid color for logo and make all menu content slide underneath of it. 2. To keep it transparent and make logo kindda float.

Do you think it's better to make it with bg (I mean same color as menu)?

Mon, 02/02/2015 - 19:41 (Reply to #89)
tpnsolutions
tpnsolutions's picture

Hi,

I just installed version 9.0.2 onto a system running Cloudmin KVM 8.0.

When clicking on the "Cloudmin" tab at the top, the only menu options were:

"System Information" and "List Managed Systems" while logged in as "root".

In the default theme by Virtualmin Inc, there are a number of menu options including the ability to configure the host, create VPS', etc...

Seems like this is either a bug, or unimplemented feature thus far. Thought I'd bring this to your attention.

*** a screenshot can be provided if needed ***

Best Regards,
Peter Knowles
TPN Solutions

Email: pknowles@tpnsolutions.com
Phone: 604-782-9342
Skype: tpnsupport
Website: http://www.tpnsolutions.com

Ask me about my new support plans which include a FREE copy of Virtualmin Pro!!!

Best Regards,
Peter Knowles | TPN Solutions
Email: pknowles@tpnsolutions.com | Skype: tpnassist
Tue, 02/03/2015 - 03:24 (Reply to #90)
Ilia
Ilia's picture

Please see YouTube video presentation to see actual situation - there is a menu in the theme. http://www.youtube.com/watch?v=gfuPFuGpyv8

Second, to fix your issue until Jamie releases new Cloudmin GPL is here: https://github.com/qooob/authentic-theme/issues/75

Good luck, Ilia

Sun, 02/01/2015 - 10:47
Welshman
Welshman's picture

Looking real good, your work is just getting better all the time. :) I just updated, love it.

Chaos Reigns Within, Reflect, Repent and Reboot, Order Shall Return.

Sun, 02/01/2015 - 10:57 (Reply to #92)
Ilia
Ilia's picture

Thanks. I'm learning! ;)

Sun, 02/01/2015 - 11:07
Welshman
Welshman's picture

50% of the way there ;) I take functionality for granted, it's how it looks that really does it for me.

Chaos Reigns Within, Reflect, Repent and Reboot, Order Shall Return.

Sun, 02/01/2015 - 11:15 (Reply to #94)
Ilia
Ilia's picture

I'm not sure I understood, what you meant about 50%? :)

Functionality wise version 9.0.0 is doing 95% of what Virtualmin Framed Theme is doing.

Sun, 02/01/2015 - 12:09
pcfreak30

Two big pitfalls that limit me and make me feel frustrated.

I can not use the search to look up a domain or have a dropdown for one.

And there is no possible way to create sub-servers or domain aliases, only primary servers. The features of a server are not even in the menus or accessible in any way I can see and it just makes it not usable for virtualmin.

Sun, 02/01/2015 - 12:18 (Reply to #96)
Ilia
Ilia's picture

About the first. What do you mean you can't search it? In case you're using Firefox and Theme version 9.0.0 then yes. It was a bug. Which is already fixed in version 9.0.1. Update to version 9.0.1 using Chrome, for instance.

about the second, all you have to do is to update to Webmin 1.730 and Virtualmin to 4.14. Everything will work then..

See that is in requirements. https://github.com/qooob/authentic-theme

See that it's there in presentation: http://www.youtube.com/watch?v=gfuPFuGpyv8

If you have problem in Cloudmin GPL then this will help you before Jamie updates Cloundmin GPL: https://github.com/qooob/authentic-theme/issues/75

Sun, 02/01/2015 - 12:15
pcfreak30

Sigh, and it seems I had to upgrade virtualmin rpm to get this working. Big fail on me.

Sun, 02/01/2015 - 12:20 (Reply to #98)
Ilia
Ilia's picture

Yes, that what I was writing above. And make sure you're running version 9.0.1 of the theme.

Sun, 02/01/2015 - 12:38
Welshman
Welshman's picture

Hence the 50% there, please take that tongue in cheek, your doing brilliant work.

Chaos Reigns Within, Reflect, Repent and Reboot, Order Shall Return.

Sun, 02/01/2015 - 12:42 (Reply to #100)
Ilia
Ilia's picture

:)) Thanks!

Pages