Authentic is Webmin/Usermin theme based on Bootstrap and Font Awesome that you just longed to get.

273 posts / 0 new
Last post
Sun, 02/01/2015 - 12:44
fakemoth
fakemoth's picture

Everything ok on my side. But in Firefox mobile, Android L, the menu doesn't work fine... Just test it to see what I mean. Latest Webmin btw.

Don't take the name of root in vain...

Mon, 02/02/2015 - 03:24 (Reply to #102)
Ilia
Ilia's picture

The only wieredness I see when using Firefox Mobile on Android L is when using Autocomplete and clicking on one of the options. Menu should hide after each active click on it and it doesn't so far. Will fix this in 9.0.2. Did you mean this or it was something else?

Mon, 02/02/2015 - 03:51 (Reply to #103)
fakemoth
fakemoth's picture

Nope, but it is OK you found something else :) Most of the time the menu doesn't expand, and everything is jitterish, the page or when scrolling the menu.

Also, the menu button in my case (Nexus 6 device) is overlapping the refresh button on the first page, maybe you should have left the other upper toolbar in place... just sayin', also because it is annoying to have the buttons bellow the menu.

The problem on my firefox is that is hardly scrolling - and when you do stuff, "convincing" it to scroll - you risk in fact clicking something because of the lag - and that's not good in a control panel.

Don't take the name of root in vain...

Mon, 02/02/2015 - 04:21 (Reply to #104)
Ilia
Ilia's picture

I see but I can't reproduce it.. I first though that your phone CPU is weak. But than I compared my phone (HTC One M8) with yours and figured out that yours has more performance power.. so it's not the case. Probably firmware.. Nothing is jitterish in my Firefox. (I am on Cynogenmod with Android L).

Did you try Chrome?

About the refresh button and menu button, well yeah.. it's the only place it overlaps an active button.. will try to do something about it!

Sun, 02/01/2015 - 13:12
Welshman
Welshman's picture

I just made a donation as I know your passionate about this theme, when the Min team make it default I will multiply it by 10.

Thank you for your dedication.

David

Chaos Reigns Within, Reflect, Repent and Reboot, Order Shall Return.

Mon, 02/02/2015 - 03:30 (Reply to #106)
Ilia
Ilia's picture

Merci beaucoup, David for your donation and your support! ;)

Sun, 02/01/2015 - 15:00
Joe
Joe's picture

9.0.1 is wonderful! I just noticed some other cool stuff you've added since I last spent time with it: Tooltip help on ui elements that have help files (which is something I have an implementation of from the old ExtJS theme I was working on in the past, but haven't added to my Bootstrap theme yet, but I think you've done it beautifully), live updating tables (I'm stealing that for Bootstrap!), and the implementation of search with auto-complete is so good!

I'm gonna send another tip from Virtualmin your way shortly, Ilia.

I encourage others to also contribute, as this is a monumental amount of time and effort that Ilia has put into this. Theming Webmin and Virtualmin and Cloudmin is not easy (for the time being anyway, once my theme ui functions roll into Webmin 2.0 things will get somewhat easier, but that's months away, Authentic is amazing now!) and it's just incredible how much he's been able to accomplish with the current codebase without a lot of core changes.

Has anyone who uses a screenreader tried this yet? Does anyone know anyone who uses a screenreader who could try this out? I'm sure there will be a lot of accessibility work needed, due to the huge number of changes (old themes are actually pretty accessible, and virtual-server-mobile is still likely to be the preferred theme for blind users for years to come, as it switches to an entirely multi-stage menu layout, which is much easier for people using screenreaders to grok). But, without a base level of accessibility it might be possible for this theme to lock blind users out of Webmin without sighted assistance, which we want to avoid.

--

Check out the forum guidelines!

Mon, 02/02/2015 - 03:50 (Reply to #108)
Ilia
Ilia's picture

Joe, thank you very much for your kind comment and most of all, thank you for your understanding - the work on the theme happened to be very exhausting, and it's all after, I just started it for myself as I wanted to get some more from Webmin/Virtualmin.

Also thank you for the generous donations you have already sent to me! They mean a lot for me and most importantly for my wife, as for her, it's the only real reason not to come to my computer room with an axe and chop everything apart!! :D

I would like to hear reviews from users with screenreader, as I couldn't even remotely imagine that it was the case at the first place. I most likely will need guidance about this subject if something particular has to be done/implemented.

Joe, about the ToolTips for help, well, it was in the theme before (it's not innovation of 9 version), I just didn't write about it much (only on changelog I think). :)

Again thank you, Joe and everyone else who has supported my efforts one way or the other.

Thu, 02/05/2015 - 11:19
Welshman
Welshman's picture

Awstats report not loading for me, not sure if it's theme related?

Edit...

If I switch to default theme awstats loads fine?

Switch back to authentic and problem persists.

Chaos Reigns Within, Reflect, Repent and Reboot, Order Shall Return.

Thu, 02/05/2015 - 13:19 (Reply to #110)
Ilia
Ilia's picture

You mean when you click view report the spinner just constantly spins? If so at first click on it 2 times to remove it. Second I can confirm that the loader is not going away.

The reason is because this Module doesn't use Webmin's neither theme_header nor theme_footer. As a result you have stuck loader. Same with some other old modules.

It could be redone on the theme side, which is wrong really. I could afford fully doing it only for ConfigServer Security and Firewall (CSF). I might take a look at AWStat and Webminstats later. But it's better to ask Webmin/Virtualmin developers to make sure that the module uses theme_header and theme_footer.

Thu, 02/05/2015 - 14:27
Welshman
Welshman's picture

Thanks Ilia, it does indeed do as you say.

Thanks.

Chaos Reigns Within, Reflect, Repent and Reboot, Order Shall Return.

Sat, 02/21/2015 - 11:24
fakemoth
fakemoth's picture

Hello Ilia - happy to announce that now the theme it's in production in my case. 300 users I guess they will find more of the remaining bugs :)

Speaking of bugs (it's pretty obvious, maybe you know about it?):

-on the first Virtualmin landing page, the Quotas and the Bandwidth bars are all at 0% in my case, even if the figures are corect;

-this also happens in Usermin > System information > Disk quotas;

-the theme has now (lately?) a kind of a screensaver, a courtain/shadowbox effect; when that thing starts Chrome slows down horribly, I mean I can see that process in Chrome at 30% CPU and > 280MB RAM by himself can I stop it somehow? It seems to me related but I might be wrong.

Don't take the name of root in vain...

Sat, 02/21/2015 - 11:39 (Reply to #113)
Ilia
Ilia's picture

I am very glad that there are that many people who is interested in my work. :)

I'm working on new version 10.0 that should bring better interface, added support for usermin-webmail and many bug fixes.

Speaking about screensaver I will remove it from the next release (or make it optional), it was done more for fun. Speaking about Quotas, there is a quick fix, that can be downloaded from here:

https://github.com/qooob/authentic-theme/issues/110

Please test it and let me know how does it work for you. It's important for me to know how it works before I include it to final version (it will do no harm in any way, no worries about that)

I already asked Joe about that Charts array containing third value - I still have no idea of what it is? Could you please write me few lines about it? The example of the arrays can be found from the link above.

Sat, 02/21/2015 - 11:53
fakemoth
fakemoth's picture

They are not "really" interested, but I am enforcing this upon them as it's the default theme on the server :)

Will do but now I will go watch a movie :) 9hrs it too much work done in the weekend.

Where is the custom logo supposed to appear? I uploaded a logo.png to the specified location and nothing.

A few other things:

-the HTML bar in Usermin is too low, and has some defect on the left side;

-ideea: if possible please separate somehow the fonts of the interface from the fonts used in reading emails in Usermin or elsewhere - in my case the diacritics don't look OK, and as you might guess, there will be a lot of problems in almost all the languages on the globe if you don't use a websafe font, or at least a larger set. It's fine to use something fancy in the interface though!

-the progress bar when uploading files for example is weird;

Thanks once again!

Don't take the name of root in vain...

Sat, 02/21/2015 - 12:15 (Reply to #115)
7stars

"Where is the custom logo supposed to appear? I uploaded a logo.png to the specified location and nothing."

I'm on CentOS 7, uploaded to /etc/webmin/authentic-theme

refreshed the page and it appears on the bottom left, under the menu...

the only issue is when you switch to Virtualmin menu.. 'cause it stays behind the text because of the long menu, even for this reason I suggested to shorten that menu in some way...

Sun, 02/22/2015 - 07:31 (Reply to #116)
Ilia
Ilia's picture

I hope you enjoyed the movie! ;) (what was it, by the way?)

I got you with your logo on login page - will see what I can do.

About the HTML bar in Usermin is too low - I didn't understand what you mean, please be kind explaining with more details.

And progress bar when uploading files for example is weird (it looks ok for me (i didn't tweak it really)).

Sun, 02/22/2015 - 08:21 (Reply to #117)
fakemoth
fakemoth's picture

Birdman - the best seen this year if you are into that kind of (dying genre) artish movies. It's from 2014 though. And it's in one shot, no cutting between the scenes, it's just flowing endlessly :)

Can't really "explain" none of the bugs. The WYSIWYG bar when composing an email in Usermin is off in Chrome (using Chromium Version 39.0.2171.65 (64-bit) openSUSE 13.1), it's lower than it should be from the upper border of the table where you compose the email, the body zone.

The progress bar window it's too small , everything gets out of it, nothing displayed in progress bars, and it doesn't integrate with your design.

http://postimg.org/image/qq02253wf/

http://postimg.org/image/8yofnoohr/

Ilia - the diacritics, romanian special chars don't get displayed ok only in the subject, when viewing all the emails, Read Mail in Usermin. When you read an email, they are fine, so it must be something else?

see here http://postimg.org/image/wekhjc7kf/

It should spell something like: Aș dori să vă adaug în rețeaua mea profesională pe LinkedIn

But instead it's: Aș dori să vă adaug în rețeau a mea profesională pe LinkedIn

Beware, for most of us Usermin is very important, that's where all the users form the server go to read their emails and stuff...

Don't take the name of root in vain...

Sun, 02/22/2015 - 09:29 (Reply to #118)
Ilia
Ilia's picture

Yes, started watching Birdman couple of days ago but was interrupted at the very beginning.. Thanks for reminding!! :))

Now I see.. Not sure at all where this extra gap is coming from.. will try to figure out and fix. Also will try to do something about that upload popup window.. Yes, it's a bit small..

About the fonts - yes, I will consider what you're saying and will fix it!

Thanks, pal!!

Sun, 02/22/2015 - 01:04
fakemoth
fakemoth's picture

Got it, it works, was uploading where the github told me, which is /usr/libexec/something...

One more request: on the login page it would be cool if you could also add this image, the personalized logo, instead of the webmin logo - that was the important part for me; if not, will hack it myself, but I don't want it overwritten and stuff via updates.

Don't take the name of root in vain...

Sun, 02/22/2015 - 08:53
fakemoth
fakemoth's picture

About the image, how do I do the same thing in Usermin? It seems, no /authentic-theme folder exists?

PS: for me the logos would be just perfect to have them in both places: where it is now, down in the menu iframe, with the nice effect and also in the login page.

Don't take the name of root in vain...

Sun, 02/22/2015 - 09:37 (Reply to #121)
Ilia
Ilia's picture

It's simple - just copy the same authentic-theme folder to /etc/usermin and it will work the same way.

I heard you about logo on login page - will see what I can do!

P.S. I have a problem confirming Font bug with Aș dori să vă adaug.. It's working fine in Usermin. Make sure that you set UTF-8 language on both Webmin/Usermin. Contact me via my website or using Jabber/XMPP in case it's still doesn't work.

Sun, 02/22/2015 - 11:26
fakemoth
fakemoth's picture

Regarding the language pls forget about it as it didn't occur to me that this was the first thing I should check :/ In my defense I never changed, for years, not once, the language in Webmin/Usermin, though I did thought about translating the panel into Romanian as you can see here https://www.transifex.com/projects/p/virtualmin-romanian/ quite embarrassing ... :)

Don't take the name of root in vain...

Mon, 03/02/2015 - 01:42
fakemoth
fakemoth's picture

Another small bug: in the left column, with the menu, if you don't scroll right till the end of it, you can't click anything, for example the latest menu items or the logout/lang/refresh buttons. In my case it's about 10% of the total height.

Don't take the name of root in vain...

Mon, 03/02/2015 - 05:21 (Reply to #124)
Ilia
Ilia's picture

It could only happen in case you have custom logo set. Another possibility is that I have already fixed that as I can't reporoduce the bug right now.

Version 10.0.0 is coming very soon - it has massive amount of improvements!

Wed, 03/04/2015 - 13:31
Ilia
Ilia's picture

Authentic Theme Major Update (version 10.0.0)

Changelog:

  • Changed theme repo location to GitHub. Attention: It's required that your Perl installation can handle https connections. Make sure to have installed, either LWP::Protocol::https or Bundle::LWP modules to make future automatic updates work
  • Improved left menu design to be more flat-like (complete page reload is required)
  • Improved the look of old ui_hidden collapse, to look more like new Bootstrap collapse
  • Added support for Webmail in Usermin #104
  • Added dataTables search, in case table contains more than 10 rows
  • Added dataTables on filesize, to properly sort columns containing filesize data #103
  • Added custom logo support for login screen #116. Read the manual for using it
  • Added support for basic settings to control the theme (disable loaders and more). Read the manual for using it
  • Added extended controls to System Information page for ConfigServer Security & Firewall
  • Added complete support for scrolling on iPhone/iPad #115
  • Fixed server-side search that stopped working after adding autocomplete
  • Fixed select issue in Internet Explorer browser #99
  • Fixed package updates showing wrong numbers on System Information page #112
  • Fixed quotas charts issue, displaying incorrect numbers in System Information/Quotas #110
  • Fixed missing left menu reload upon importing new virtual server
  • Fixed stuck loader appearing in certain cases #117
  • Fixed stuck loader in all third party modules, like AWStat, Webminstat and OpenVPN + CA #106
  • Fixed hotkeys triggers, which now is executed only in case the switch is not already active #118
  • Fixed fatal error happening when changing domain in Webmin/Virtualmin domain owner mode
  • Fixed System Statistics link to be shown only in administrative mode
  • Fixed Virtualmin->Administration Options->Switch To Server's Admin link, being opened in __parent window
  • Fixed WYSIWYG bar being lower than it should be from the upper border, when composing new message
  • Fixed login page throwing an error to the console
  • Removed screen-saver, as it was eating a lot of memory



Enjoy!!

Thu, 03/05/2015 - 17:57
Rubin

Nicely done Ilia , this new update has made the interface a lot more faster , i must say by a lot .

Keep up the good work , donation coming your way pretty soon .

Now i can tell the people saying "virtualmin looks dated" , to go home ..

Fri, 03/06/2015 - 02:54 (Reply to #127)
Ilia
Ilia's picture

Thanks a lot, pal, pleasure to hear that!

Have a good day.

Fri, 03/06/2015 - 08:54
Welshman
Welshman's picture

Hi, yeah thanks for the updates.

I noticed when the theme is used for a 'domain owner' and not just root there does not seem to be a webmin tab to switch to?

Also the awstats log still needs a double click for it to appear.

Chaos Reigns Within, Reflect, Repent and Reboot, Order Shall Return.

Fri, 03/06/2015 - 08:57 (Reply to #129)
Ilia
Ilia's picture

Yes, it's meant to be by Webmin itself. There is Webmin Modules tab on the left. ;)

Sat, 03/14/2015 - 22:20
volupheles

I Ilia,

Firstly, I love your work with Authentic theme. I am considering rolling it out to my virtualmin servers.

There is just one issue with a 3rd party module I use named Installatron. It doesn't load if I click it. If I right click, and open in new window or tab is works fine. Similar to the awstats issue described above.

Sun, 03/15/2015 - 02:21 (Reply to #131)
Ilia
Ilia's picture

Thanks! I hope you have latest version of the theme installed., which is 10.1.2. I can not reproduce your problem. I have fixed AWStat a while ago. Please take a look at the screencast and in case it's not the way it is, make your own one and let me see the bug alive.

https://rostovtsev.ru/pub/AWStat.webm

Make sure you have cleared cache in your browser after installing new theme. I shouldn't be need in most case but when you face problems clear cache and restart browser.

What Browser do you use?

Sun, 03/15/2015 - 03:32 (Reply to #132)
Ilia
Ilia's picture

Ooops. Just notice some error.

Please open /authentic-theme/unauthenticated/js/incompatibility.min.js and replace in it default.src.js with default.min.js. My bad, forgot to change it back.

It should fix all issues. Right? ;)

Sun, 03/15/2015 - 12:13 (Reply to #133)
Ilia
Ilia's picture

It's fixed in version 10.2.0 - please update. Sorry about that (AWStat and other). Should be working now as expected.

Mon, 03/16/2015 - 06:36 (Reply to #134)
volupheles

I had a look at your video. I can access awstats via the shortcut you used, but it's inaccessible (sort of) via the virtualmin menu, under the specified domain. Installatron is the same (is is accessed under services).

Screenshot: http://volupheles.com/virtualmin.jpg

If I double click the area it will work. Otherwise the loading screen just spins.

Tue, 03/17/2015 - 14:13 (Reply to #135)
Ilia
Ilia's picture

Yes, confirmed! I will try to fix it in the next 10.30 release in couple of days.

Mon, 03/16/2015 - 06:55 (Reply to #136)
fakemoth
fakemoth's picture

I can confirm the behaviour, in awstats (from Virtualmin > MyDomain > Logs and Reports > AwStats Report); weird because I updated to 10.2.0...

Also Ilia if you remember I told you about some problems with Firefox Mobile on stock Google Android L (Nexus 6 here so no performance issues). I updated yesterday to Android 5.1.0 and it's even worse, can't you still reproduce the behaviour? Lag is a small word, the menu just jumps from place to place, if at all... Please note that everything else is ok, so we can exclude Firefox/Android problems.

Don't take the name of root in vain...

Tue, 03/17/2015 - 14:20 (Reply to #137)
Ilia
Ilia's picture

Yes, AWStat issue is confirmed.

Sorry for a delay. Just had time to install Firefox on my Android L 5.0.2 and test it (CM12). If you don't believe me, I will make a video for you :)) but menu in Firefox works just fine. I would grade it's smoothness 4,3 out of 5 and ability to click what I intend 5 out of 5. There is no terrible lag. The Authentic Theme is heavy in it's nature but as far as I'm aware Nexus 6 is faster than my HTC One M8 and I have no issues with it what so ever.

I would guess you have problems with you GPU settings.. Let me ask you something: 1. Are you on custom firmware? 2. What happens if you load the theme in Chrome/Safari (on iPhone/iTab) ?

Sun, 03/15/2015 - 23:46
drguild

No-one has said it here, congrats for getting included in the official public webmin update pushed out today to all users of webmin, I'm running it now and love it so far.

I presume your theme is a secondary theme for now for all webmin installs rather than the default but still to be officially included in the main package is a massive thing so thanks to everyone.

I know mid last year I suggested in the blue skies forum etc about a new theme and working with theme devs with licenses as a thanks a few months before all this came about, I don't know how much that post helped as stuff was starting to be lightly talked at at that time but Joe's theme looks a little like the other management system I suggested to take hints from so I would like to think my post there inspired something a bit more and I helped spark something in some way.

Overall congrats for getting included and really great and I am really overjoyed to see the massive leaps in themeing and even how its affected the main code from reading with menu items and stuff related to modules.

Great we are starting to see a modern version of webmin integrated with eye-candy functionality being worked on.

Mon, 03/16/2015 - 07:55 (Reply to #139)
Ilia
Ilia's picture

Thanks for your kind words, mate!! ;) I'm also very happy, that my theme has been included in the package. It's a big thing for me! I will keep up with making it even better.

Tue, 03/17/2015 - 10:07
mvander25

Wow, just tried out the new theme - great first impression - looks fantastic. Job well done!

Tue, 03/17/2015 - 13:43 (Reply to #141)
Ilia
Ilia's picture

You are very welcome! Enjoy!

Tue, 03/17/2015 - 13:05
Welshman
Welshman's picture

Hi Ilia, multiplied my donation by 10 I know I said I would do it when your theme was default but sometimes Christmas comes early, great to see the VM team added your theme with the last update and I hope the donation will help you get it up to speed and the default theme very soon. :)

I also would advise all users of VM to make a donation to Ilia, it's programmers like this with dedication to see a project through and a happy healthy face that deserve all the support they can get :)

David

Chaos Reigns Within, Reflect, Repent and Reboot, Order Shall Return.

Tue, 03/17/2015 - 13:30 (Reply to #143)
Ilia
Ilia's picture

Thank you very much, my friend! :D I appreciate this a lot!! I will continue to improve the theme little by little, step by step!

Tue, 03/17/2015 - 13:36
Welshman
Welshman's picture

I still have to double click the spinner when loading awstats though for it to load, thought that was fixed?

Chaos Reigns Within, Reflect, Repent and Reboot, Order Shall Return.

Wed, 03/25/2015 - 14:33
Ilia
Ilia's picture

Please welcome version 11.00 with many new features and improvements.

Changelog

Version 11.00 (Mar 25, 2015)

  • Added window automatic scrolling, upon page is populated from server-side.Test it and see it in action in such modules as Fetchmail Mail Retrieval, Software Package Updates and others. Intended mouse-scroll done by user, during auto-scrolling, will make it stop. Loader will be automatically hidden upon this features is triggered. This feature can be disabled using settings
  • Added in settings: settings_security_notify_on_pre_login_request, settings_security_notify_on_login_request, settings_security_notify_on_login_success, settings_window_autoscroll, settings_sysinfo_theme_updates, settings_sysinfo_csf_updates, settings_leftmenu_button_language, settings_leftmenu_singlelink_icons, settings_leftmenu_vm_installscripts, settings_leftmenu_vm_webpages and settings_leftmenu_vm_backup_amazon. Read the manual for using it
  • Added automatically stretching inputs for long text #121
  • Added auto-detection/redirection to Mailbox module upon logging in to Usermin
  • Added Dutch translation by Richard van Laak
  • Added Russian translation
  • Fixed appearing loader on changing select, even though it was disabled in settings #127
  • Fixed text not being wrapped in pre tag and now scrollable horizontally instead #123
  • Fixed left menu output issue in uncategorised mode #128
  • Fixed encoding issue #129
  • Fixed stuck loader in Virtualmin, while using third party modules
  • Fixed left menu being shown irrespectively to the right frame #131
  • Fixed external custom links not being opened in new window in Virtualmin module #130
  • Improved UI of the right frame - dozens of improvements on fonts, tables, buttons, scrollbars and etc
  • Remove all dependencies #125
Fri, 03/27/2015 - 09:08
fakemoth
fakemoth's picture

Congratulations for becoming a Webmin default theme!

One minor bug but this one is really annoying: if you have a custom logo, the links near or right above it cannot be clicked in the left menu, also the scroll doesn't work, can you please take a look to why is this happening? Only if you are with the mouse pointer above the logo, or close to it... kinda'

Don't take the name of root in vain...

Fri, 03/27/2015 - 10:07 (Reply to #147)
Ilia
Ilia's picture

It was discussed just today and here is the fix:

https://github.com/qooob/authentic-theme/issues/143

It will be added to the branch next release.

Sun, 03/29/2015 - 17:21
volupheles

Thanks for the updates Ilia! It's looking and functioning fantastically.

I have finally waved goodbye to the old framed default theme!

Sun, 03/29/2015 - 17:45 (Reply to #149)
Ilia
Ilia's picture

Thanks! :) Very good to hear it.

Fri, 04/10/2015 - 01:09
fakemoth
fakemoth's picture

Hello Ilia! A few (more) usability requests:

  • the scroll bar in logs for example is very thin, can you make it a bit wider, so we can easy grab it with the mouse? Also your theme alters the scroll bar of the browser; this one should definitely be wider or leave the default one.

  • when one switches between Virtualmin/Webmin/Cloudmin the right iframe reloads, with the system info; this is maybe an unnecessary wasted/waiting time;

  • I am really "living" in Virtualmin; and I was using it by opening multiple tabs, for example to take a look at the log in a browser tab, and open the file manager in another/virtualmin domain settings in one, the command line in other/different domains in different tabs etc. This is no longer possible as the theme loads in the same tab. Can we get back the old behavior, ie CTRL+CLICK to open in another tabs, is it possible/easy?

  • I noticed some "bug" maybe; when temporarily loosing connection the theme just keeps loading, it kinda freezes; for example it is very weird to work on the (standard iptables) firewall. It goes to an extent of not being able to change the rules when applying - not always, but had a few issues.

  • possible bug: installed Virtualmin on a couple of CentOS7 servers I am working on and the theme was changed from Webmin as it was already included. Problem is, it doesn't get updated automatically nor manually and it looks like it is stuck on the default installed version, can anyone else confirm this?

  • the Firefox mobile issues with the left menu are still there, it is barely usable at least in my case; updated to Android 5.1, on my Nexus 6, always the latest Firefox; mentioned this a few times here in the thread, please take a look at my previous posts.

Thanks! These are merely personal wishes; great theme top to bottom!

Don't take the name of root in vain...

Pages