Authentic is Webmin/Usermin theme based on Bootstrap and Font Awesome that you just longed to get.

273 posts / 0 new
Last post
Mon, 09/21/2015 - 00:28
fakemoth
fakemoth's picture

Yeah you should look into it, it is a nice feature. But I already have those settings in the file and received over night another 100 mails or so...

If you can, separate the notifications please, the ones for Webmin from the ones from Usermin. Also for those of us using symlinked theme in Usermin.

Thanks!

Don't take the name of root in vain...

Sun, 10/25/2015 - 07:05
Welshman
Welshman's picture

Hi Ilia, will you be adding one click color changes? Would like a dark grey/black or an Ubuntu orange one for example.

Thanks.

Chaos Reigns Within, Reflect, Repent and Reboot, Order Shall Return.

Sun, 10/25/2015 - 12:11 (Reply to #253)
Ilia
Ilia's picture

I already added 11 default color palettes and ability to add 10 custom ones in version 17.01. Did you mean this or something else?

Mon, 10/26/2015 - 02:39
Welshman
Welshman's picture

Thanks Ilia, I up graded to the latest release and now can see them.

Brilliant.

Chaos Reigns Within, Reflect, Repent and Reboot, Order Shall Return.

Sat, 01/09/2016 - 05:09
ronald
ronald's picture

Really awesome work done.
congrats and a big thank you!

Sun, 01/10/2016 - 16:42
Ilia
Ilia's picture

New release fixes a lot of bug. Please upgrade.

Changelog
Version 17.40 (January 10, 2016)

* Added triggers to automatically dismiss loader and perform window autoscroll in Virtualmin/Cloudmin #39237
* Added documentation links next to product's version on System Information page. Custom documentation links set in Virtualmin/Cloudmin configuration are now also supported #39225
* Added sorting/filter ability for Installed Scripts in Virtualmin #39237
* Added an option to show HTML snippet for administrators only
* Added an ability to edit custom-lang file from theme extensions' editor
* Changed previously removed Virtualmin/Cloudmin links from Webmin navigation menu from enforced to optional #39237
* Fixed hardcoded strings in some Perl and JavaScript files
* Fixed hotkeys execution to be performed in the right context
* Fixed removed obsolete logo options in Virtualmin/Cloudmin configuration page #39225
* Fixed missing input field on the navigation menu, when domain display limits are imposed using Virtualmin Configuration #39219
* Fixed Notification Slider to be unfixed disregard of visibility settings on mobile devices
* Fixed bugs #321 #322 #323 #326 #328
* Fixed other bugs

Regards,
Ilia

Thu, 01/21/2016 - 05:05
Ilia
Ilia's picture

Please upgrade to 17.50

Changelog

Version 17.50 (January 21, 2016)

  • Added right click context menu for Filemin for extra convenience (Comming later features: Folder size calculations, combined chown/chmod dialogs and more)
  • Added state of the art color management for the palettes, using theme's settings. It is possible now to control grayscale, sepia, saturate, hue-rotate, invert, brightness, contrast filters for navigation menu and grayscale, saturate, hue-rotate for content page. It enables you to generate hundreds of color palettes with ease
  • Added White Snow contrast theme, to resemble old Virtualmin Framed Theme #39344
  • Added line numbers for System Logs module
  • Added ability to choose color palettes for CodeMirror viewer/editor
  • Added title notification counter, to extend already existing favicon counter
  • Improved dynamic title output in Virtualmin/Cloudmin
  • Fixed login and password autocomplete to be off on login page #39271
  • Fixed reseller account couldn't be saved, due to missing some form fields 39348
  • Fixed default page for Usermin in Mail mode is set to Inbox. Default page for Usermin in non-mail mode is also respected and can be set in Webmin->Usermin Configuration->User Interface 39324
  • Fixed bugs #333 #334 #335 #336 #340
  • Fixed dozens of other issues
Tue, 03/08/2016 - 20:21
tripkin

Hi Ilia, this is all looking great! It seems to me that in the old default theme, the virtualmin system info would show the virtualmin version along with the webmin version. Would it be possible to add this? I don't use Cloudmin, yet, but it might be nice in there as well to show the versions of each of the installed webmin/virtualmin/cloudmin installations.

Thanks for your hard work and the time you take to keep this theme up and running!

Tue, 03/15/2016 - 02:47
simon1066

One comment on the Authentic Theme using Virtualmin GPL,

The old default theme gave the current Virtualmin version on the System Information page, this is no longer visible with Authentic - to save navigating to other parts of the system to get this info I think reinstating it would be of benefit.

EDIT: Just read the previous post and some other bright spark had the same idea - typical.

Tue, 04/26/2016 - 01:21
AllanIT

Hi llia. I love the authentic theme but since the latest version came out I've been having a few problems and had to switch back to the virtualmin framed theme. I was wondering if there was anyway you could correct these problems.

The first problem is if I attempt to open any link in a new tab or window the page never loads. For example Virtualmin> Logs and Reports> Apache Access Log> Right click open in a new tab. All I get is a blank grey screen.

The second problem is when I try to load either the log pages or a page in filemin for editing the scrollbar that should be at the bottom of the screen to allow you to scroll left or right is situated somewhere off the bottom of the screen, making it impossible to scroll and look at what is not visible.

If I have not been clear enough here please don’t hesitate to ask for mor information

Thanks

Tue, 04/26/2016 - 02:09
AustinTX

@AllaniT I agree with you. I really like keeping several management pages open at once. The "authentic" theme, since a week or two, no longer allows that. I switched back to the old theme and it is like I have a brand new server! I can do what I need and the pages are very very much faster.

Wed, 05/18/2016 - 23:27
tripkin

Hi Simon1066! Thanks for the kind comment!

Ilia, I see that the virtualmin version is now displayed on the Info page - I am sorry I did not look until I needed it, but there it was when I did! Thank you! Theme is great (albeit a little slow on my ancient hardware!).

Fri, 12/02/2016 - 09:04
AllanIT

HI guys. I recently enabled Authentic on usermin and initially all went well. Then one of my users reported that their screen layout was strange and unusable. So I logged in to usermin and had no problems. I then logged in to usermin with their login and was presented with a screen that looks like the following three screen shots. If I switch themes back to Gray Framed Theme the screen layout all works, for that theme of course, but if I switch back to Authentic it again looks like the screen shots. Can you please give me some help to fix this problem?

 photo Profile 1_zpsjgnsj6nm.jpgScreen shot1

 photo Profile 2_zps0gxggwtu.jpgScreen shot2

 photo Profile 3_zps79bz0uqo.jpgScreen shot3

Sat, 12/03/2016 - 19:33 (Reply to #264)
Joe
Joe's picture

Whoah! I've never seen that before.

Ordinarily when something looks weird like that, it just takes a reload in the browser (maybe forcing clearing of the local cache with Shift-Refresh or Ctrl-Refresh or Cmd-Refresh, depending on the OS and browser), but that looks pretty far off from anything I've seen.

I wonder if maybe something is going wrong during loading...maybe the OOM killer is killing the Usermin process before all of the resources are loaded (Usermin can be somewhat resource intensive for very large mailboxes, at least in terms of memory usage, and in particular if the user has configured a very large number of messages to display on one page).

The fact that it looks normal for you, but weird for one user, while you're using the same browser, is really strange, too. That would indicate it probably actually isn't anything related to your browser or cache, and is related to something unique about their mailbox or Usermin configuration. They've only got 219 emails, so that can't be the problem (I currently have 65,000 emails in my inbox, and several hundred thousand across all mailboxes, and I don't run into this problem). So, maybe it's the Usermin configuration...You could try moving the user's .usermin folder to another directory name, and restart Usermin so it starts fresh. It'll need reconfiguring if the user has special requirements, but might resolve this if it's due to something unique about their config.

If you figure out what it is, please let us know, as we'd obviously like to fix it. Since we've never seen it, I wouldn't know where to start.

--

Check out the forum guidelines!

Tue, 07/11/2017 - 11:12 (Reply to #265)
unborn
unborn's picture

@AllanIT

...well no one can fix your issue as you using well outdated xp... get a life and update.. if you have no money or something else - use linux there should be some guidelines to postpone morrons on xp - xp is windows not and linux and you should be following xp windows documentation - means you are outdated very much... and it would leave you to dead end - ergo back to us.... please stop posting issues which are not issues any more as no one out there using wonder some windows xp.. : no one care about xp any more - it was abandoned about 7 years ago if not more ;)

edit: - joe xp is out.. stop helping the folks about xp issues save your time out there.. ;)

Configuring/troubleshooting Debian servers is always great fun

Wed, 12/07/2016 - 09:02
AllanIT

Hi Joe

Thanks for your response. On one level I am glad to see I am not the only one who was perplexed by those screen shots. However it gets even more confusing.

Rather than renaming the users .usermin folder and restarting Usermin, I setup a testing user and copied the problem .usermin folder to the new testing user. Then I switched the Usermin theme to Authentic and to my surprise the screen loaded correctly. I then opened a new browser and logged in as the user with the problem and their screen loaded correctly as well. I have not yet had the user test it on their machine. As soon as I do I will let you know what the result is.

The only thing I can think is there has been a number of updates on the server and browsers recently and some combination fixed the problem.

Thu, 12/15/2016 - 01:34
AllanIT

Hi Joe

The user has tested and all is working as it should. Sorry I dont have any idea what caused it or what we did to fix it. Hopfully it does not come back.

Tue, 07/11/2017 - 11:32 (Reply to #268)
unborn
unborn's picture

hi, do you have any server logs to show ? or ?

Configuring/troubleshooting Debian servers is always great fun

Tue, 07/11/2017 - 11:35
unborn
unborn's picture

..in end of the day - is your issue real?

Configuring/troubleshooting Debian servers is always great fun

Mon, 10/15/2018 - 01:40
rfanch3r

I would just like to add that with this theme, if you click on the Java Filemanager you cannot click into the very last folder or file as the bar at the bottom is in the way.

Mon, 10/15/2018 - 04:59 (Reply to #271)
Joe
Joe's picture

Java File Manager is deprecated, and won't be enhanced going forward and will be removed from the base distribution pretty soon (it'll remain available in the module repository for a while). Java in the browser is no longer a reasonable platform, since most browsers make it very difficult to run Java applets.

If there are things you use Java File Manager for that you can't do with the new file manager, let us know and we'll try to implement it (but, as far as I know, there is feature parity, and in fact the new File Manager does a bunch of stuff the old one doesn't).

--

Check out the forum guidelines!

Tue, 10/16/2018 - 07:03
Ilia
Ilia's picture

@rfanch3r That wouldn't be possible as Java File Manager opened on the new/blank browser's tab.

Pages

Topic locked