Backup fail after upgrade to Virtualmin

17 posts / 0 new
Last post
#1 Wed, 01/07/2015 - 14:27
rhostager

Backup fail after upgrade to Virtualmin

Just upgraded the wbm-virtual-server package to 4.13-1 and then tried a backup of a virtual server. Got this error:

Dumping MySQL database api .. .. dump failed!

mysqldump: Got error: 1045: Access denied for user 'api'@'localhost' (using password: YES) when trying to connect Backup failed! See the progress output above for the reason why.

The backup worked fine yesterday before the Virtualmin package update this morning.

  • Rob
Wed, 01/07/2015 - 16:35
anrikun

Same exact problem here

Wed, 01/07/2015 - 17:14
cerebrum

Same problem here on Debian GNU/Linux 7.7.

  • virtual-server-4.13.gpl
  • webmin-1.730
  • usermin-1.640
  • mysql-5.5.40-0+wheezy1

File /etc/webmin/mysql/config exists and the correct mysql root password is stored as pass= (I don't know if this is relevant). When I execute a backup manually:

virtualmin backup.pl --id xxx

...the first output line is:

user= pass=

Wed, 01/07/2015 - 17:51
apapakl

Same exact problem here (centos 6.6)

Wed, 01/07/2015 - 18:08
cygnus

Same here, I investigated, only one of my servers backuped normally and it happened that it had the same password as the mysql admin password.

When I changed mysql admin password in webmin to match password of my other servers, my servers backuped.

So it seems that backup routine is broken and now uses the mysql admin password whatever is the server it tries to backup ..

Please help

Wed, 01/07/2015 - 19:56
andreychek

Howdy,

Sorry to hear you're having problems with the backups! There's a bug report regarding that issue here:

http://virtualmin.com/node/35764

Thu, 01/08/2015 - 01:11 (Reply to #6)
Manfred

same problem with the backups :-/

cannot access the link you posted :-(

"... Access denied You are not authorized to access this page. ..."

EDIT: after reentering my login credentials I could access the bug report

Thu, 01/08/2015 - 04:36
Hendrik

Ubuntu Linux 12.04.3

Thu, 01/08/2015 - 05:22
Welshman
Welshman's picture

Same problem on all my servers as of last night.

First nightly backups after recent Webmin and VM updates.

Deb7 Ubuntu 12.04 & 14.04

Any idea when a fix is coming.

Thanks.

Chaos Reigns Within, Reflect, Repent and Reboot, Order Shall Return.

Thu, 01/08/2015 - 14:47
apapakl

There is a quick fix for this from JamieCameron (http://virtualmin.com/node/35764#comment-142284). Many thanks!

Fri, 01/09/2015 - 03:03
MattWilcox

Chalk another person up with this MySQL error causing failed backups problem.

Also; I apparently am not authorised to see those links to a quick fix.

Fri, 01/09/2015 - 03:09
mpattman

You need to create an account (and be logged in) to view the comment with the quick fix in it.

Fri, 01/09/2015 - 07:16
rick111

[quote] For those who need a quick fix for this (which reverts Virtualmin to the old insecure behavior of writing backups with root permissions can do the following :

Edit the file /usr/{share,libexec}/webmin/virtual-server/feature-mysql.pl

Change lines 947-948 to :

local $err = &mysql::backup_database($db, $dbfile, 0, 1, undef, undef, undef, undef, undef, 1);

Run /etc/webmin/restart [/quote]

Sat, 01/10/2015 - 07:36
dabol

or read this : https://www.virtualmin.com/node/35794

The simpler fix is to edit /etc/webmin/mysql/config and add the line login=root

it works...

Sat, 01/10/2015 - 12:47
jvieille

"The simpler fix is to edit /etc/webmin/mysql/config and add the line login=root" Thanks! this is OK Will this be in the next We min/Virtualmoin release?

Sun, 01/11/2015 - 04:05
Joe
Joe's picture

Fixed in 4.13-2. Apologies for the inconvenience.

--

Check out the forum guidelines!

Sun, 01/11/2015 - 04:33
dabol

update just installed, i have removed the "login=root" in /etc/webmin/mysql/config

works fine ^^ thanks you !