Virtualmin virtual-server module version 4.17 released

9 posts / 0 new
Last post
#1 Wed, 05/06/2015 - 03:27
Joe
Joe's picture

Virtualmin virtual-server module version 4.17 released

Howdy all,

I've rolled out version 4.17 of the Virtualmin virtual-server module.

Changes since 4.16:

  • Updated the Trac script installer to version 1.0.5, ownCloud to 8.0.2, MediaWiki to 1.24.2 and 1.19.24, Node.JS to 0.12.2, phpMyFAQ to 2.8.22, OpenCart to 2.0.2.0, Drupal to 7.36, Pydio to 6.0.6, vTigerCRM to 6.2.0, CMS Made Simple to 1.12, X2Engine to 5.0.6, Ghost to 0.6.0, and phpMyAdmin to 4.4.2.
  • Improved support for replicating and deleting domains that use a shared home directory and MySQL database to synchronise state across two or more Virtualmin systems.
  • Fixes an Apache configuration permissions issue that prevented backup restoration in some circumstances.

As always, holler if anything is broken! This is also the first release built and deployed from our new build and staging environment, so it took a lot longer than usual. Jamie notified me of the new version several days ago, but it took a while to get everything spinning nicely. We may still have issues that I haven't found, so if you see problems with the packages or repos, specifically, I definitely want to know about it.

Regards,

Joe

Wed, 05/06/2015 - 05:40
pixel_paul
pixel_paul's picture

When updating on CentOS 5, the following error occurs

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(PayloadIsXz) is needed by wbm-virtual-server-4.17-1.noarch
Complete!
(1, [u'Please report this error in http://bugs.centos.org/yum5bug'])

Thanks,

Paul

Wed, 05/06/2015 - 10:20
berndtnetwork

I have been waiting for this update so I can Migrate a couple cpanel accounts over to the new server setup using Virtualmin gpl

On version 4.16 it did not bring in the Maildir for the user accounts. But, it had imported everything else with no problem. I only had to fix a problem with Virtualmin installing the wrong outdated ssl cert.

Today after I had updated to 4.17 it is doing the same exact thing...

Inversion 4.15 this had worked with no problem.

Kind of frustrating because the only work around is to delete the users and recreate them in order to get the Maildir setup correctly and then extract the back and copy the folders over manually. Not fun at all if the user has a 6gb Maildir with over 100 folders.

Wed, 05/06/2015 - 11:18
andreychek

Sorry that it's not working for you!

There's a bug report for that here (I think it's yours):

https://virtualmin.com/node/36922

Jamie will look into what's not working for you, and we'll get a fix for that out so you can get your migration working. If we can't get a new release out quickly to fix just that issue, I'll ask Jamie if he can package something up just for you, since you've been waiting awhile for that functionality.

-Eric

Wed, 05/06/2015 - 11:54 (Reply to #4)
berndtnetwork

Thank you Eric, and yes the bug report is mine. I thought maybe it was only happening on one machine but I can confirm it did the same on another that I am using for projects that get tested before they move over to the production server.

Wed, 05/06/2015 - 12:59
voxframe

I'm sitting in the same boat looking for cpanel email migration. Is it easy to drop down to 4.15, do the import, and then come back up to 4.17? That might be my best bet at the moment.

Wed, 05/06/2015 - 14:06
andreychek

Sure, you could certainly install the older version, then after the migration is complete, upgrade to the newer Virtualmin version.

-Eric

Wed, 05/06/2015 - 14:32 (Reply to #7)
berndtnetwork

Hello Eric,

How do you downgrade Virtualmin from 4.17 to 4.15? and can you do that without breaking the virtual servers .

Regards,

Peter

Fri, 05/08/2015 - 15:49
robindesbois

Hello,

I have this problem since I upgraded to Virtualmin 4.17, the backup fails.

...
Creating TAR file of home directory ..
HTTP/1.0 500 Perl execution failed Server: MiniServ/1.740 Date: Thu, 7 May 2015 22:30:34 GMT Content-type: text/html; Charset=iso-8859-1 Connection: close
Error - Perl execution failed

Echec de l'ouverture /home/mici/.virtualmin-src pour l'écriture : Permission denied

Same issue on 2 different servers, Debian 7 and 7.4. ".virtualmin-src" does not exist in that folder. There was no problem with Virtualmin 4.16

Thank you for your work.

Rob.

Edit: creating the file /home/user/.virtualmin-src solves the problem. The file must be owned by the user, not by root

Bye