WHMCS or Boxbilling unable to connect

3 posts / 0 new
Last post
#1 Sun, 06/07/2015 - 12:19
zreon

WHMCS or Boxbilling unable to connect

Hey everyone,

Long time cpanel user here who has recently been testing out Virtualmin. So far I love how smooth and fast everything is running. I am having an issues getting any billing panel to connect to it though to create accounts. Initially I was trying it with WHMCS and the connection kept timing out. I then tried Boxbilling, which just flat out said could not connect to the server. Since according to the forums for those billing panels, they are both working correctly with Virtualmin, I believe something may be misconfigured within Virtualmin. I can't find any settings related to the Remote API though.

Is there something that has to be enabled somewhere to allow these type of API calls? I am able to connect in a web browser to domain.com:10000/virtual-server/remote.cgi

I am currently using Virtualmin GPL during my testing phase.

Tue, 06/16/2015 - 03:36
vtvtran4000

Hi guys,

Pls help me!.

Now we are using the licensed virtualmin. And when our boxbilling connects to this licensed virtualmin then it notices 'could not connect to the server 0'.

And we need this urgently. So pls guys help us.

Thanks so much!.

Tue, 06/16/2015 - 09:58
andreychek

Howdy,

I'm unfortunately not sure why the software was unable to connect in each of the cases you guys described.

While I don't have experience with Boxbilling, you may want to double-check what hostname and port it's configured to look for Virtualmin on.

Is there any sort of debug mode that could be enabled in Boxbilling, that would show us all what exactly it's trying to do, and what is failing?

-Eric