Virtualmin on Centos 7

Hello,

I have Virtualmin working on fine on Centos 6.7, so I decided to try Centos 7. I have a couple of issues I need help with. In the initial setup after Virtualmin install, the wizard says it does not know how to setup ClamAV "you have to set it up manually." How do I do that?

On the latest Virtualmin installation, the following menu items are missing in Webmin after installation: Webmin->System-> Initial System Bootup & System Logs.

What would I do to get these menu items back?

Status: 
Active

Comments

Howdy -- hmm, that's an unusual message regarding ClamAV.

What is the output of this command:

rpm -qa | grep -i clam

[root@bndwgnphx ~]# rpm -qa | grep -i clam
clamav-server-0.98.5-1.el7.centos.vm.x86_64
clamav-0.98.5-1.el7.centos.vm.x86_64
clamav-filesystem-0.98.5-1.el7.centos.vm.noarch
clamav-update-0.98.5-1.el7.centos.vm.x86_64
clamav-data-0.98.5-1.el7.centos.vm.noarch
clamav-lib-0.98.5-1.el7.centos.vm.x86_64

Try running this command:

yum install clamav-scanner-0.99-2.el7.noarch clamav-server-systemd-0.99-2.el7.noarch clamav-scanner-systemd-0.99-2.el7.noarch

After that, are you then able to enable the ClamAV feature in Virtualmin?

[root@bndwgnphx ~]# yum install clamav-scanner-0.99-2.el7.noarch clamav-server-systemd-0.99-2.el7.noarch clamav-scanner-systemd-0.99-2.el7.noarch
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
* base: centos.mirror.ndchost.com
* epel: dl.fedoraproject.org
* extras: centos.sonn.com
* updates: mirror.cs.uwp.edu
174 packages excluded due to repository priority protections
No package clamav-scanner-0.99-2.el7.noarch available.
No package clamav-server-systemd-0.99-2.el7.noarch available.
No package clamav-scanner-systemd-0.99-2.el7.noarch available.
Error: Nothing to do
[root@bndwgnphx ~]#

I use plugin-priorities because I have the EPEL repository installed, and set to priority 10. Every other repository is set to proirity=1. EPEL is in their because I use it to install denyhosts and fail2ban. But I didn't install it until after I finished the Virtualmin installation.

How about this, what's the output of this command:

yum search clam

============================== N/S matched: clam ===============================
clamav.x86_64 : End-user tools for the Clam Antivirus scanner
clamav-data.noarch : Virus signature data for the Clam Antivirus scanner
clamav-data-empty.noarch : Empty data package for the Clam Antivirus scanner
clamav-debuginfo.x86_64 : Debug information for package clamav
clamav-devel.x86_64 : Header files and libraries for the Clam Antivirus scanner
clamav-filesystem.noarch : Filesystem structure for clamav
clamav-lib.x86_64 : Dynamic libraries for the Clam Antivirus scanner
clamav-milter.x86_64 : Milter module for the Clam Antivirus scanner
clamav-milter-systemd.noarch : Systemd initscripts for the clamav
: sendmail-milter
clamav-milter-sysvinit.noarch : SysV initscripts for the clamav sendmail-milter
clamav-scanner.noarch : Clamav scanner daemon
clamav-scanner-systemd.noarch : Systemd initscripts for clamav scanner daemon
clamav-scanner-sysvinit.noarch : SysV initscripts for clamav scanner daemon
clamav-server.x86_64 : Clam Antivirus scanner server
clamav-server-systemd.noarch : SysV initscripts for clamav server
clamav-server-sysvinit.noarch : SysV initscripts for clamav server
clamav-unofficial-sigs.noarch : Scripts to download unoffical clamav signatures
clamav-update.x86_64 : Auto-updater for the Clam Antivirus scanner data-files

Shoot, I didn't mean to include version numbers in the package command I mentioned earlier. I wonder if that's the cause of it not working.

What happens if you try this command here:

yum install clamav-server-systemd.noarch clamav-scanner-systemd.noarch clamav-scanner.noarch

Installed: clamav-scanner.noarch 0:0.98.5-1.el7.centos.vm
clamav-scanner-systemd.noarch 0:0.98.5-1.el7.centos.vm
clamav-server-systemd.noarch 0:0.98.5-1.el7.centos.vm

Complete!

What would I do now? Rerun the wizard in Virtualmin?

If you look in System Settings -> Features and Plugins, is the Virus Filtering feature enabled?

If not, feel free to enable it.

If so, take a look in Email Messages -> Spam and Virus Scanning. There, you would have the option to set the mode the the ClamAV scanner uses (which is what the post-install wizard had been doing).

Going forward, if I install Virtualmin on Centos 7 again, the key would be to manually install those 3 clamav packages first?

I think I am all set on the virus scanning. Thank you.

In my original question, I also mentioned that two webmin menu items are missing: Webmin->System-> Initial System Bootup & System Logs.

When I look at the install log, I see these 5 items that were not installed due to the unavailability of packages:

No package mysql-server available.
No package rh-postgresql available.
No package rh-postgresql-server available.
Package logrotate-3.8.6-7.el7_2.x86_64 already installed and latest version
No package mod_perl available.
No package mod_python available.

Is this OK, or is using the Virtualmin Install script on Centos 7 doomed to failure?

Joe's picture
Submitted by Joe on Sat, 03/26/2016 - 16:31 Pro Licensee

You should not need to manually install anything. And, no, the install script on CentOS 7 is not doomed to failure. It's worked every time I've tested it. I'm willing to believe there is a regression but it's not expected to fail. CentOS 7 is the current recommended version of CentOS for Virtualmin.

I don't think we've gotten reports of similar problems, so there may be something unique to your situation. But, I'll look into it a bit further.

Those packages that don't get installed are from older versions of CentOS. The messages are harmless, and unrelated to ClamAV. When RHEL/CentOS 5 reaches end of life, those packages will no longer be referenced in the install script and those messages won't appear. The same dependency list is used across all versions of CentOS/RHEL, because missing packages are not fatal errors and don't interfere with the installation.

Well, do I recall that you mentioned having another repository with some custom priorities setup?

What you may want to do next time is to install things onto an entirely fresh version of CentOS 7. Once Virtualmin is setup and working, then try setting up any additional repositories and priorities that you require.

I wanted to add a postscript to this issue of installing Virtualmin on Centos 7. I have been experimenting with low end dedicated servers. I can reproduce the error of clamav virus scanning not being available in the set up wizard on all these dedicated servers and VPS Virtualmin installations. I fix it by first running the command given earlier in the thread:

yum install clamav-server-systemd.noarch clamav-scanner-systemd.noarch clamav-scanner.noarch

These are clean Centos 7 installs, nothing done except yum update after the OS installation. No other repos installed.

Is there something wrong with what I am doing or does the Virtualmin install script need updating?

Thanks.

Thanks, I'll look deeper into that.

Hi

I just had the same issue on a brand new installation of CentOS Linux 7.2.1511 and Virtualmin 5.02 Pro with Webmin 1.795 So I would say this is an issue to be looked into.

  • Tim

Thanks for letting us know, that's something I'm working on.

I just had the same issue on a brand new installation of CentOS Linux 7.2.1511 minimal and Virtualmin GPL install-Script.

ewersk, can you run this command on your server:

rpm -qa | grep -i clam

The ClamAV packages should be installing properly at this point... though we'll ensure that with the commad above. Thanks!

I recently did a clean install of Virtualmin Pro on a Centos 7 installation and the Clam AV problem was fixed. I had no problem

his is the mail system at host mail.drsimch.com.

I'm sorry to have to inform you that your message could not be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can delete your own text from the attached returned message.

The mail system

shamim.khulna@yahoo.com: host mta6.am0.yahoodns.net[66.196.118.240] said: 554 Message not allowed - [320] (in reply to end of DATA command) Reporting-MTA: dns; mail.drsimch.com X-Postfix-Queue-ID: 5B742E04602F X-Postfix-Sender: rfc822; shamim@drsimch.com Arrival-Date: Tue, 1 Nov 2016 10:24:16 +0600 (BDT)

Final-Recipient: rfc822; shamim.khulna@yahoo.com Original-Recipient: rfc822;shamim.khulna@yahoo.com Action: failed Status: 5.0.0 Remote-MTA: dns; mta6.am0.yahoodns.net Diagnostic-Code: smtp; 554 Message not allowed - [320] Subject Re: test From GM SHAMIM SHABBIR To iqbal@drsimch.com, shamim.khulna@yahoo.com, khulna.shamim@gmail.com Date Today 10:24 hhhhhhhhhhhhhhhhhhhhhhhhhhh

gmshamimshabbir, you appear to be seeing an unrelated issue there.

However, it also looks like you may be using Virtualmin GPL. If you're using Virtualmin GPL, you'd actually want to use the Forums for support. We monitor those, along with lots of wonderful folks in the community. Thanks!