Error on Virtualmin(free) install (ProfFTPD)

9 posts / 0 new
Last post
#1 Fri, 08/05/2005 - 16:05
DannyWeaver

Error on Virtualmin(free) install (ProfFTPD)

I'm running Debian sarge on a test machine. I've recently decided to move from Fedora to Debian and have been using it as a desktop and as my webserver for a while now. I run into the problem when setting up virtualmin.

I've installed proftpd and have told virtual min config as much, however when going through the process of installing I get the following error:

Error Message

The ProFTPd server does not appear to be installed on your system, or has not yet been set up properly in Webmin's ProFTPd Server module. If your system does not use ProFTPd, it should be disabled in Virtualmin's module configuration page.

End of Error Message

When I click through to configure ProFTPD Server module, I get this error:

Error Message

The program /usr/sbin/proftpd does not appear to be the ProFTPD server. Maybe it is not installed, or your module configuration is incorrect. Output from the command /usr/sbin/proftpd -v was :

  • ProFTPD Version 1.2.10

End of Error Message

Any help would be much appreciated. I've always used proftpd and am not familiar with any other ftp client. So I'd like to stick with it. Especially since it is supposed to be compatible with virtualmin.

Thanks in advance.

Fri, 08/05/2005 - 16:06
DannyWeaver

One thing I did not touch on, I verfied that the module config was exact. Then I double checked it.

Sat, 08/06/2005 - 12:29
Joe
Joe's picture

That's really strange, as that looks exactly like my configuration that works (it's on Fedora, but the ProFTPD version is the same). ProFTPD is the recommended FTP server for Virtualmin, so I won't recommend you change.

Are you running the latest version of Webmin? If you're using the Debian provided version, it has historically always been way out of date (but perhaps a new maintainer has stepped in to resolve that issue, I don't know).

--

Check out the forum guidelines!

Sat, 08/06/2005 - 14:58 (Reply to #3)
DannyWeaver

I installed from the tar.gz on the webmin site. Everything went smooth but apache2 and that was fixed in a jiff. I'm completely stumped by the proftpd error. I did install proftpd from the debian repositories, I think I'll remove it and try installing a noarch package.

Mon, 08/08/2005 - 16:00
JonathanCartland

I had the same problem - fixed with updated ProFTPD module from webmin.

Mon, 08/08/2005 - 16:03
DannyWeaver

Thanks, I hadn't had time to mess with it. I'll post my results once I try it.

Mon, 08/08/2005 - 22:52
DannyWeaver

Tried and failed. However in the attempt I've gotten a few good ideas I'm going to give a shot.

Mon, 08/15/2005 - 10:03
DannyWeaver

Dissabling the check for ProFTPD has resolved the issue. While it still works it is certainly an odd error.

Mon, 08/15/2005 - 18:24
Joe
Joe's picture

Sounds like a minor bug in Webmin. As soon as I get Debian installed on our Xen test server I'll figure out exactly what's happening, assuming I can reproduce it. I'm sure it's something simple.

--

Check out the forum guidelines!