Only name.domain@domain.com works

4 posts / 0 new
Last post
#1 Sun, 10/16/2005 - 11:16
SimonHobbs

Only name.domain@domain.com works

Hi

As an experiment, I have created a virtual domain: hobbs.id.au

I have created a mailbox for the account, which is supposed to be "christy@hobbs.id.au", however it doesn't work. What does work is "christy.hobbs@hobbs.id.au", but I don't need it. So something is stopping the mapping...

As a result of what I have set up through vitualmin, my mapping file (/etc/postfix/virtual) has the following in it.

hobbs.id.au hobbs.id.au christy@hobbs.id.au christy.hobbs

Am I missing something, or just going about it the wrong way?

Thanks Simon

Sun, 10/16/2005 - 23:52
Joe
Joe's picture

Hmm...that mapping should almost certainly work the way you want it to.

Are there any clues in the /var/log/maillog about where the mail goes when you send to christy@hobbs.id.au? Does it bounce?

--

Check out the forum guidelines!

Mon, 10/17/2005 - 01:13 (Reply to #2)
SimonHobbs

Hi Joe

This appears to be the appropriate part of the log.

Oct 17 00:29:31 vps sendmail[[8846]]: j9H4TTsa008846: christy@hobbs.id.au... User unknown

Oct 17 00:29:31 vps sendmail[[8846]]: j9H4TTsa008846: from=info@urbits.com, size=671, class=0, nrcpts=0, proto=ESMTP, relay=smta09.mail.ozemail.net [[203.103.165.130]]

I tried deleting and reentering the mapping. I also tried adding the email again in "Additional Email Addresses" which of course gave me the error: Failed to save mailbox : A mailbox or mail alias that clashes with the additional address 'christy@hobbs.id.au' already exists.

Regards
Simon

Mon, 10/17/2005 - 01:59 (Reply to #3)
SimonHobbs

Some troubleshooting

I've doubled checked that the problem is not specifically with the user "christy.hobbs" by mapping the email address to another user and testing.

I've made the domain explicit in main.cf. The end of the file now looks like:
<blockquote>readme_directory = /usr/share/doc/postfix-2.0.18/README_FILES
alias_database = hash:/etc/postfix/aliases
myorigin = $mydomain
mydestination = hobbs.id.au urbits.com.au
mail_spool_directory = /home/mail
virtual_alias_maps = hash:/etc/postfix/virtual
virtual_alias_domains = hobbs.id.au
</blockquote>

Other than that I've been unable to find a decent step by step troubleshooting guide.

Simon