Trouble with email not coming from the virtual domain

5 posts / 0 new
Last post
#1 Tue, 11/01/2005 - 12:05
GeorgeNincehelser

Trouble with email not coming from the virtual domain

Here's the problem (names aren't real)...

I've got a host system named xyzzy.com

I create a virtual domain named plover.com

If a plover.com user trys to send mail through SquirrelMail, the mail goes out as user@xyzzy.com instead of user@plover.com as I'd like it to.

I realize I could have each user change the "from" address in their profiles, but I'd like to have this set up automatically.

Is there something I'm missing?

Thanks George

Tue, 11/01/2005 - 23:43
Joe
Joe's picture

I've been told that we can do something fanciful with Squirrelmail to support virtual hosting with a single system-wide installation, and so I will be spending some time figuring out how to do that shortly.

In the meantime, there is no automatic way to do this (the "official" webmail client for Virtualmin Professional is Usermin, and it should work this way out of the box, I think, though I know there are some issues to be addressed in the Usermin configuration--it's coming in the next release).

--

Check out the forum guidelines!

Wed, 11/02/2005 - 10:09
GeorgeNincehelser

Thanks! I was feeling kind of stupid that I couldn't get it to work easily.

I'm not set on using SquirrelMail. I'm just using it because it was already there. I'll check out the usermin version...that may be good enough for now.

Eventually I'd like to use something more feature-rich like OpenWebMail. I'm open to suggestions, though.

Thanks again!

George

Wed, 11/02/2005 - 15:20
GeorgeNincehelser

Ok. I got SquirrelMail working.

What I had to do was add the "compatibility" and "vlogin" modules to SquirrelMail.

"compatibility" required a patch to SquirrelMail, but the instructions with the module covered that well.

I did have to monkey around with the conf.pl of the "vlogin" module. I had to set $dontUseHostName and $smHostIsDomainThatUserLoggedInWith to 1.

I'm not sure why I had to set the $dontUseHostName. Until I did that, I couldn't not log into SquirrelMail at all. I guess it was appending the domain name to the login.

Anyway, it's working for me now. Thanks!

George

Thu, 11/03/2005 - 02:55
FaisalMehmood

So does it work cross platform ? What i mean is .. if you install it in a remote folder .. can it be used by ANYONE anywhere ? Using thier login info ?