another Mysql problem

7 posts / 0 new
Last post
#1 Sat, 01/07/2006 - 20:05
Brandonjones

another Mysql problem

Hello!

If I log into any of my virtual accounts with usermin and click Applicatations -> Mysql Database I come up with this error...

The MySQL client program /usr/bin/mysql does not appear to be the correct version. Webmin only supports MySQL versions 3 and above.

The command /usr/bin/mysql -V returned :

/usr/bin/mysql Ver 14.12 Distrib 5.0.18, for pc-linux-gnu (i686) using readline 5.0

I have no issues with installing anything, it all went very smooth. This seems to be my only issue. I cant access the database from my virtual accounts, I am assuming this is directly related. I'll post the last snippet of the log after a reboot also so you can see what version's im running

[[Sat Jan 07 21:56:04 2006]] [[notice]] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec) PHP Warning: PHP Startup: Unable to load dynamic library './mysql.so' - ./mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0 [[Sat Jan 07 21:56:06 2006]] [[notice]] Digest: generating secret for digest authentication ... [[Sat Jan 07 21:56:06 2006]] [[notice]] Digest: done [[Sat Jan 07 21:56:06 2006]] [[notice]] LDAP: Built with OpenLDAP LDAP SDK [[Sat Jan 07 21:56:06 2006]] [[notice]] LDAP: SSL support unavailable [[Sat Jan 07 21:56:07 2006]] [[notice]] Apache/2.0.55 (Unix) PHP/5.1.1 mod_ssl/2.0.55 OpenSSL/0.9.7a DAV/2 configured -- resuming normal operations [[Sat Jan 07 21:58:38 2006]] [[error]] an unknown filter was not added: PHP

Its running on RH9 if that makes a difference.

Thank you!

Brandon

Sun, 01/08/2006 - 00:46
SNayDragon

Just because this has happened to me...

Make sure you have the php-mysql package installed. The problems you are describing sounds, to me, like that package is missing.

Sun, 01/08/2006 - 06:08
Brandonjones

I'm pretty sure all the packages are functioning as the should, i dont get any errors except for when I try to access mysql from one of the virtual accounts that I have setup. On another account that I built myself with apache and bind mysql worked fine, so somewhere in virtualmin or usermin I think is whats causing my issue. I'm sure the problem is on my end, not saying otherwise. Just wondering if anyone could stear me in the right direction.

http://206.53.56.220/phpinfo.php

That will give you the phpinfo on my domain if that helps any. I'm fairly new to linux but I can say that I have definatly learned alot the past couple weeks (except how to spell...lol)

Thanks again!

Brandon

Sun, 01/08/2006 - 06:13
Brandonjones

Sorry for the spam here, but thought that I better add I have 4 IP's pointed here also.

xxx.xxx.xxx.26 is where the virtual accounts are
xxx.xxx.xxx.220 is my ns1 name server
xxx.xxx.xxx.221 is my ns2 name server
xxx.xxx.xxx.222 is not used for anything yet

Sun, 01/08/2006 - 10:47
SNayDragon

OK, took a look at phpinfo... You really do not seem to have mysql support setup in your php.

Where did you get the package to install mysql (or did you use the one that came with the distro?)

Sorry, it's been a while since I played with RH9, so, I don't remember where the packages came from.

See if, in wherever your packages come from, there is one labelled php-mysql-*

I had to install it on my CentOS (arguably RH based) and my FC boxes (which are RH based).

Sun, 01/08/2006 - 12:02
Brandonjones

It is a dedicated server that I leased, it did not have anything at all on it. I actually called them back and had them intall apache with php and mysql support. Sounds like it may be something that they caused?

I should also add that I had installed Hosting Helper on it, and it was working fine communicating with mysql.

That was before I installed usermin and virtualmin, everything works perfect except this issue im having with mysql. It creats the databases and it looks like it sets up all the permissions but I cant access mysql through the virtual accounts.

Hope that helps. Is there any modules that i should check for specificly?

Sun, 01/08/2006 - 14:37
Brandonjones

ok php-mysql was on there, but I removed it and am trying to reinstall it now with Yum...