And this?

10 posts / 0 new
Last post
#1 Fri, 01/13/2006 - 04:20
LarsReimers
LarsReimers's picture

And this?

After install of Virtualmin Pro, the kernel have change from kernel-2.6.14-1.1656_FC4 to kernel-2.6.11-1.1369_FC4, that is a downgrading of the kernel, are that correct or some bug? We can´t boot up from the first kernel anymore!

Fri, 01/13/2006 - 04:30
Joe
Joe's picture

Hey Lars,

That's crazy talk! We don't touch the kernel. ;-)

We do, however, run a yum update at the end of the install (to insure our packages replace some system packages that dependency resolution alone wouldn't pick up). I'm not sure how the kernel would be downgraded in the process, however. I suspect it is something wrong with yum or the kernel packages in question, though I haven't seen this on any of my Fedora Core 4 systems (and I have a lot of them).

To fix the problem:

Make sure the kernel you want is actually installed:

rpm -q kernel

There should be a list of several...make sure the latest is there. If not, run a yum update:

yum update kernel

Then, assuming the latest gets installed, make sure it is the default kernel in /etc/grub.conf. The last kernel installed by yum is usually "0". So, confirm that the kernel you want is the first in the list of available kernels and set "default=0". Save it, and reboot.

If any of these things doesn't quite seem right, or doesn't work as I suggest, come back with more, and I'll be happy to help you straighten it out.

But I'm still not taking credit for the problem. ;-)

--

Check out the forum guidelines!

Fri, 01/13/2006 - 04:41
LarsReimers
LarsReimers's picture

Dear Joe!

The result of this below:

login as: root
root@eriksgatan.net's password:
Last login: Fri Jan 13 12:11:45 2006 from 83.209.37.13
[[root@eriksgatan ~]]# rpm -q kernel
kernel-2.6.11-1.1369_FC4
kernel-2.6.14-1.1656_FC4
[[root@eriksgatan ~]]# yum update kernel
Setting up Update Process
Setting up repositories
Cannot find a valid baseurl for repo: updates-released
Error: Cannot find a valid baseurl for repo: updates-released
[[root@eriksgatan ~]]#

Fri, 01/13/2006 - 04:58
LarsReimers
LarsReimers's picture

If I try to boot up from the kernel that have 1656_FC4 in the end I get this error: e2fsck: Cannot continue, aborting. But if we use that kernel that was build after install of Virtualmin Pro, ends with 1369_FC4 no problem with boot up, that is odd?

Fri, 01/13/2006 - 05:12
Joe
Joe's picture

Hey Lars,

Ok, I <i>have</i> seen the error you're seeing with the 1.1656_FC4 kernel. It does the same thing on my laptop (which does not have Virtualmin installed, BTW), but not on my desktop machine (which does have Virtualmin installed). Seems to be a problem with a couple of revisions of the kernel from Fedora. Again, it's nothing to do with Virtualmin, except that the Virtualmin installation triggered the yum update. Any update would have caused things to turn out the same way.

So, you'll probably want to back track on kernel revisions, installing them manually with rpm, until you find the most recent one that doesn't have this problem. I'll file a bug with the Fedora folks about this, if one hasn't already been filed, as I've seen it too. I kinda figured I'd broken something on my laptop (I've got non-standard wireless and graphics drivers installed on my lappy, so I always assume I broke something when something goes wrong).

If you do install additional kernels manually, be sure to install rather than upgrade. i.e. &quot;rpm -i --oldpackage kernel-version.arch.rpm&quot; rather the &quot;rpm -U --oldpackage kernel-version.arch.rpm&quot;. Upgrading causes other kernels to be replaced. Anyway, I think &quot;--oldpackage&quot; will allow you to install an older version. If not, you'll have to remove the offending new kernel first with &quot;rpm -e kernel-2.6.14-1.1656_FC4&quot;.

Or, if you don't have users on your system yet, you can probably safely wait out the Fedora folks until they release a kernel that works.

You next reply indicates that yum is not working on your system. This is a problem! It may be related to DNS problems (which your post about license errors indicates you might have). You'll want to look further into this...I can help if you aren't sure what to look at. But I suspect DNS in general is having trouble on your server, so look into that first.

--

Check out the forum guidelines!

Fri, 01/13/2006 - 05:27
LarsReimers
LarsReimers's picture

Ok Joe, we will do a new fresh installation later this day and see what happend.
I&Acirc;&acute;m not sure what DNS I'll use, we have two alternative, first we have from our ISP that delivery our internet connection, and there we also have two IP addresses, and we also have from the ISP Nettica where the domain name eriksgatan.net are reigstered, and the eriksgatan.net are that domain name we use on the server, so shuld we use the DNS IP from the first one, or from Nettica, i'm lost in the djungel ;-)

Tue, 02/28/2006 - 02:36
MarcoA.MateosSanchez

Well.

Fresh install FC4

Reboot machine several times any porblem.

After install latest Virtualmin pro, get on all shutdown this message:

Virify file system.

/dev/sda2 is mounted.

WARNING!! Runnnig e2fsck on mounted filesystem may cause SEVERE filesystem damage.

Do you really want to continue (y/n) ?

I f check y system go quiclky and run.

If check n also run quickly.

I thin a problem of any rc.X script.

Any idea?

Tue, 02/28/2006 - 02:39
MarcoA.MateosSanchez

Forget..
If use new kernel instaled (upgrade for intallation of virtualmin pro) or a compiled kernel, this problems appears.

If use OLD kernel of a fresh and very OLD FC4 any problems...

Tue, 02/28/2006 - 11:52 (Reply to #8)
Joe
Joe's picture

Hey Marco,

This is a problem with one or more of the Fedora kernels. It happens on my laptop with one of the recent versions--I had to setup grub to boot an older kernel. Oddly enough, it doesn't happen on my desktop or any of my FC4 servers. It is definitely not Virtualmin related...and I'm afraid I don't have a good answer on how to correct it. The Fedora folks will need to fix their kernel.

--

Check out the forum guidelines!

Sun, 09/03/2006 - 16:07
AnastasiosMagoutas

I had the same problem on a CentOS server and I managed to solve the problem by modifying the init file on the initrd image of the new kernel. The problem was that there was an extra rw on the following command.

mount -o grpquota,usrquota,rw --ro -t ext3 /dev/root /sysroot

Since the filesystem was mounted it was not possible to execute e2fsck.

I changed the command to

mount -o grpquota,usrquota --ro -t ext3 /dev/root /sysroot

and everything worked great, after recreating the initrd image file and replacing the old one.

Since I'm not an expert I don't guarantee that everything that worked for me will also work for you.

PS: The last kernel that was working fine was 2.6.9-22 and the solution worked on all the following e.g. 2.6.9-42.0.2