Virtualmin virtual-server module version 5.07 released

13 posts / 0 new
Last post
#1 Fri, 03/10/2017 - 19:36
Joe
Joe's picture

Virtualmin virtual-server module version 5.07 released

Howdy all,

I've rolled out Virtualmin virtual-server module version 5.07. This is a bugfix release to fix a handful of PHP-FPM and Let's Encrypt related issues.

As always, let us know if you run into any bugs.

Cheers,

Joe

Fri, 03/10/2017 - 20:36
ckwsp101

Was running Virtualmin 5.06gpl-2 on Centos 7

After update to from Virtualmin web page now running 5.07 received the following warning.

: An error occurred checking the licence : Invalid host or serial number A renewal can be purchased at http://www.virtualmin.com/shop

What caused switch from gpl to above required license ? How can to recover my gpl version?

Operating system CentOS Linux 7.3.1611 Webmin version 1.831 Virtualmin version 5.07 Theme version Authentic Theme 18.32 Time on system Friday, March 10, 2017 6:34 PM Kernel and CPU Linux 3.10.0-514.6.2.el7.x86_64 on x86_64 Processor information Intel(R) Xeon(R) CPU E5-2673 v3 @ 2.40GHz, 2 cores System uptime 12 days, 5 hours, 46 minutes Running processes 140 CPU load averages 0.64 (1 min) 0.58 (5 mins) 0.61 (15 mins) Real memory 3.28 GB total / 1.33 GB used Virtual memory 4.88 GB total / 354.24 MB used Local disk space 220 GB total / 135.32 GB free / 84.68 GB used Package updates All installed packages are up to date

Warning! A problem was detected with your Virtualmin license : An error occurred checking the licence : Invalid host or serial number A renewal can be purchased at http://www.virtualmin.com/shop

Fri, 03/10/2017 - 20:47
ckwsp101

/var/log/yum.log shows

Mar 10 21:19:24 Updated: 2:wbm-virtual-server-5.07.gpl-1.noarch

Sat, 03/11/2017 - 07:24
arminh

Hello,

same problem with the GPL version.

Sat, 03/11/2017 - 08:51
Welshman
Welshman's picture

My centos7 server is fine after update. Did notice deb and ubuntu have different version update.

Try not using the authentic theme.

Chaos Reigns Within, Reflect, Repent and Reboot, Order Shall Return.

Sat, 03/11/2017 - 09:18
ckwsp101

On my centos 7 system issue also present using Virtualmin Framed Theme.

A problem was detected with your Virtualmin license : An error occurred checking the licence : Invalid host or serial number A renewal can be purchased at http://www.virtualmin.com/shop

Virtualmin 5 comes with a brand new HTML 5 theme! Would you like to try it now?

Sat, 03/11/2017 - 14:58
Joe
Joe's picture

Sorry folks. My fault. I updated my roll-up scripts with the 5.06 release, and it had some bugs...I thought I'd fixed the bug previously. But, I missed a step...so, same problem happened again. It should be fixed with the 5.07.gpl-2 release.

Sorry for the inconvenience, again. I'm gonna get these damned build scripts right some day.

--

Check out the forum guidelines!

Sat, 03/18/2017 - 10:44 (Reply to #7)
ckwsp101

Thank you

update working on Centos 7rrrrrrrrrrrrrrr

Sun, 03/12/2017 - 09:00
jhango

i just updated to 5.07 on ubuntu 16 lts, so far no problem...

Sun, 03/12/2017 - 09:55
Wikiki

Hi,

since the last update to 5.07.gpl-2 (today) I do not have access to virtualmin anymore. Hopefully all my virtual servers still running but I can't access to virtualmin web site. I'm using CentOS Linux 7 (Core) and I updated from 5.07.gpl-1

Can you please help me ?

Regards

Sun, 03/12/2017 - 10:41 (Reply to #10)
Wikiki

Hi again,

I found the issue. It was related to a missing ssl.key in a virtualserver. After copying all ssl.* files I was able to do a /etc/init.d/webmin restart and access to virtualmin again then regenerate a certificat for the concerned virtualserver.

Regards

Sat, 03/18/2017 - 03:51
unborn
unborn's picture

updated today and no issues - debian jessie.

Configuring/troubleshooting Debian servers is always great fun

Tue, 03/28/2017 - 04:04
OliverF

Howdy!

A quick bug report :)

Debian oldstable here, webmin+virtualmin, lamp.

I briefly tried switching from fcgi to FPM, as php execution mode.

With the previous version of Virtualmin, FPM worked, but Apache wouldn't restart when php was set to using FPM, which forced me to switch back.

Here, with the current-ver of virtualmin, php pages won't work at all, returning every time the same thing in the Apache error log, here is an example [Tue Mar 28 10:53:38 2017] [warn] proxy: No protocol handler was valid for the URL /index.php. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule.

No proxy configured to be in use here, though.

Hang in there dear developers, you'll get it working eventually :)