Mime Types? How to set new one?

3 posts / 0 new
Last post
#1 Sun, 04/09/2006 - 20:49
AdamHolt

Mime Types? How to set new one?

I have a web client that Im hosting, and he has a database of files, they all end in .sims2pack

He wants to set the mime type on his account so that .sims2pack files download in the browser instead of the browser trying to open them.

How is this accomplished using virtualmin?

He tells me that it is possible because the place where he downloads them from brings up a window in his internet explorer program prompting him to either open or save it. He wants the same thing to happen when people try to download the file from his site.

How is this done?

Thank you for your time.

Sun, 04/09/2006 - 21:59
Joe
Joe's picture

Hey Adam,

There are several ways to go about it. You can do it system-wide or for just the one domain using the Apache module (depending on privileges you've granted your user, he may also be able to add MIME types for his domain). To add it for just one domain:

Click on Webmin in the left menu

Click on Apache Webserver

Click on the virtual domain you'd like to make the change to

Click MIME Types

And in the Extra MIME Types field labeled Type enter application/sims2pack

And in the Extra MIME Types field labeled Extensions enter .sims2pack

This can also be done via the .htaccess file in the domain public_html directory (assuming you have allowed htaccess overrides for this location). Lots of possibilities. Apache is very flexible about definining these sorts of things.

Note, however, that I'm not really sure of the "right" MIME type for sims2pack. I'm just guessing based on a quick Google for the type. It'll probably work how you want.

--

Check out the forum guidelines!

Sun, 04/09/2006 - 23:03
AdamHolt

Thanks Joe, I tried that but I.E.6.0 still trys o download it as an XML file. I dont understand it, it's like the server just spits it out, and I.E. Trys to determine what type of file it is and decides it's an xml file and trys to display it in the browser.

Im checking with the author of the software program we use because in the softwares admin panel it downloads right, but not in the public area of the site. It seems more and more likely that it's a software problem from the authors of Glinks.

Thanks though