sendmail vs postfix

8 posts / 0 new
Last post
#1 Wed, 05/17/2006 - 09:07
DanLong

sendmail vs postfix

I'm trying to change to sendmail on VirtualminPro and keep running into the same problem. I go in and stop postfix, make sure it's stoppped (well hit refresh anyway), then when I try to start sendmail I get this error:

Failed to start sendmail : Starting sendmail: [[ OK ]] Starting sm-client: sendmail: fatal: flush queue mode requires no recipient [[FAILED]] when I go back I see postfix running again.

Wed, 05/17/2006 - 20:35
DanLong

How do I shut off postfix? I don't see anyway that actually keeps it shutdown. I don't seem to be able to start sendmail with another MTA running. I check back and there is postfix still running after I shut it down.

May 17 20:11:55 hosta sendmail: sm-client shutdown failed
May 17 20:11:55 hosta sendmail: sendmail startup succeeded
May 17 20:11:55 hosta sendmail: sendmail: fatal: flush queue mode requires no recipient
May 17 20:11:56 hosta sendmail: sm-client startup failed
May 17 20:14:01 hosta sendmail: sendmail shutdown failed
May 17 20:14:01 hosta sendmail: sm-client shutdown failed
May 17 20:14:01 hosta sendmail: sendmail startup succeeded
May 17 20:14:01 hosta sendmail: sendmail: fatal: flush queue mode requires no recipient
May 17 20:14:02 hosta sendmail: sm-client startup failed
May 17 20:15:06 hosta su(pam_unix)[[7018]]: session opened for user postgres by (uid=0)
May 17 20:15:06 hosta su(pam_unix)[[7018]]: session closed for user postgres

Thu, 05/18/2006 - 02:20
jpenix

Wait I'm confused... where are you seeing Postfix running? The log you posted only shows lines about sendmail and PostgreSQL... nothing about Postfix.

And the error you're getting with Sendmail isn't because Postfix is still running. If that were the case you'd get errors about Sendmail not being able to bind to port 25.

You might want to search Google on the "fatal: flush queue mode requires no recipient" error and see what the solution is.

Thu, 05/18/2006 - 07:20
DanLong

Hi,
I assume postfix is running because everytime I return to the postfix module the button says stop postfix.

I even took postfix out of bootup yet it shows up as running

Doing a google search I found this interesting note:

""> The output said:
> Starting sendmail: [[ OK ]]
> Starting sm-client: sendmail: fatal: flush queue mode requires no
> recipient
> [[FAILED]]
>
> Does not look like Postfix to me.

Yes, the usual RedHat insanity. Suppress real output, replace by
meaningless self-generated output.""

But I got no answer on this fatal flush queue thing, except to revert to postfix.

Wed, 05/24/2006 - 09:11
DanLong

This turned out to be a RH feature thingy. I needed to actually go root and and use a routine to turn one or the other off.

Tue, 09/26/2006 - 10:44
michaelhumphries

can you elaborate on this RH Thingy as i am having the same problem and cannot find a good answer to this

Tue, 09/26/2006 - 10:58
ADobkin

I think he is talking about "alternatives". Try the following commands for more information:

alternatives (should be in /usr/sbin by default)

man alternatives

alternatives --display mta

ls -l /etc/alternatives

Tue, 09/26/2006 - 22:22 (Reply to #7)
Joe
Joe's picture

Alan is quite right. Using the alternatives command for the switch is strongly recommended (you can do it manually, but you'll end up breaking stuff if you don't get the steps and links exactly right).

I'll also add that "alternatives" isn't just a "Red Hat thingy". It is also the recommended way to make this kind of change on Debian and Ubuntu, as well (in fact, it was created for Debian and Red Hat/Fedora adopted it as the "Right Way" to handle this particular set of problems). I suspect many other distros also use alternatives.

--

Check out the forum guidelines!