Wrong group id in PHP-FPM

2 posts / 0 new
Last post
#1 Mon, 06/12/2017 - 04:33
randallflagg

Wrong group id in PHP-FPM

It happens often that when migrating from php-fcgi to php-fpm that the right group id is not retrieved.

/var/log/php5-fpm.log

[12-Jun-2017 11:04:35] ERROR: [pool 13389002531805] cannot get gid for group 'domain'

where domain should be domain.com

the file /etc/php5/fpm/pool.d/13389002531805.conf must be changed by hand from

[13389002531805]
user = domain.com
group = domain
listen = 8002
pm = dynamic
pm.max_children = 9999
pm.start_servers = 1
pm.min_spare_servers = 1
pm.max_spare_servers = 5
php_admin_value[upload_tmp_dir] = /home/domain.com/tmp
php_admin_value[session.save_path] = /home/domain.com/tmp
php_value[max_execution_time] = 60

TO -->

[13389002531805]
user = domain.com
group = domain.com
listen = 8002
pm = dynamic
pm.max_children = 9999
pm.start_servers = 1
pm.min_spare_servers = 1
pm.max_spare_servers = 5
php_admin_value[upload_tmp_dir] = /home/domain.com/tmp
php_admin_value[session.save_path] = /home/domain.com/tmp
php_value[max_execution_time] = 60
Fri, 03/30/2018 - 16:03
watermark

I ran into this issue as well and I was able to solve the issue as described above.

I reviewed the domain config file stored in "/etc/webmin/virtual-server/domains". For some reason, the "ugroup" was set to the non-existent group that virtualmin was using in the pool config. I'm pretty sure we did a "change domain" on this domain in the past, so it may be left-over from that.