[SOLVED] Error during update of webmin-virtualmin-awstats

15 posts / 0 new
Last post
#1 Fri, 09/22/2017 - 04:06
adelphia
adelphia's picture

[SOLVED] Error during update of webmin-virtualmin-awstats

Hi. I am showing that there is an update for webmin-virtualmin-awstats to a new version 5.6. However, The update is failing on both my live and test servers with the same information:

Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
webmin-virtualmin-awstats : Depends: webmin-cron but it is not installable
                             Depends: webmin-software but it is not installable
E: Unable to correct problems, you have held broken packages.

The error is exactly the same on both systems and I have ensured all packages (using Virtualmin Package Updates) are installed an updated; webmin-virtualmin-awstats is the only update showing.

Is this a bug or is the package broken (as suggested in the error part of the message)?

Thanks for any help to get this resolved.

Chris

Fri, 09/22/2017 - 05:14
Ned

I have the same problem too!

I am using Debian 9, 64 Bit.

Fri, 09/22/2017 - 05:18
Miloshio
Miloshio's picture

+1 Ubuntu 16.04 latest stack...

Fri, 09/22/2017 - 06:02
petertjuh

+1 Happens on all of our machines right now, all debian different versions machines btw

An update to apache2-doc from 2.2.22-13+deb7u11 to 2.2.22-13+deb7u12 is needed. This update has been successfully installed.

An update to apache2-suexec-custom from 2.2.22-13+deb7u11 to 2.2.22-13+deb7u12 is needed. This update has been successfully installed.

An update to apache2-utils from 2.2.22-13+deb7u11 to 2.2.22-13+deb7u12 is needed. This update has been successfully installed.

An update to webmin-virtualmin-awstats from 5.5 to 5.6 is needed. However, this update could not be installed! Try the update manually using the Package Updates module.

none

Fri, 09/22/2017 - 06:08
freddes51

+1

Debian 7.1

Fri, 09/22/2017 - 06:48
Joe
Joe's picture

Try it again. (Make sure to check for new updates. You need 5.6-2.)

I know it's fixed on CentOS, but my Debian/Ubuntu VMs seem to have lost network connectivity and I'm too tired to figure out why right now. So, let me know if it's fixed or not, if you're on any apt-get distro.

--

Check out the forum guidelines!

Fri, 09/22/2017 - 08:16 (Reply to #6)
adelphia
adelphia's picture

Thanks Joe. Have checked again and the update is now showing 5.6.2 and all installs OK.

Chris: Adelphia Interactive
Desktop: Windows 10 Pro x64
Server: Ubuntu 16.0.4.2LTS
Webmin/Virtualmin: Latest (daily updates)

Fri, 09/22/2017 - 08:16 (Reply to #7)
adelphia
adelphia's picture

Thanks Joe. Have checked again and the update is now showing 5.6.2 and all installs OK.

Sorry for duplicate but I can't delete it. Site was on a go slow when I posted.

Chris: Adelphia Interactive
Desktop: Windows 10 Pro x64
Server: Ubuntu 16.0.4.2LTS
Webmin/Virtualmin: Latest (daily updates)

Fri, 09/22/2017 - 06:57
freddes51

It's ok for me debian 7.1

thanks ;)

Fri, 09/22/2017 - 06:59
freddes51

It's ok for me debian 7.1

thanks ;)

Fri, 09/22/2017 - 07:49
Ned

webmin-virtualmin-awstats 5.6-2 is OK - Debian 9 64 bit

Thank you!

Fri, 09/22/2017 - 07:51
Ned

webmin-virtualmin-awstats 5.6-2 is OK - Debian 9 64 bit

Thank you!

Fri, 09/22/2017 - 08:54
jvieille

OK on Ubuntu 16.04, but fails on Ubuntu 12.04 that stays at 5.5

Building complete list of updates .. Now updating webmin-virtualmin-awstats .. Installing package(s) with command apt-get -y install webmin-virtualmin-awstats ..

Reading package lists... Building dependency tree... Reading state information... Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: webmin-virtualmin-awstats : Depends: webmin-cron but it is not installable Depends: webmin-software but it is not installable E: Unable to correct problems, you have held broken packages.

Fri, 09/22/2017 - 09:58 (Reply to #13)
Joe
Joe's picture

Ubuntu 12.04 is EOL. You aren't getting any updates for any of your system packages, and thus your system is already exploitable.

The virtualmin-universal repo, however, should work for any Ubuntu/Debian distro. Run apt-get update before doing the upgrade.

--

Check out the forum guidelines!

Fri, 09/22/2017 - 10:26
jvieille

Thanks, it worked!