PHP With GD Support....

3 posts / 0 new
Last post
#1 Sat, 09/23/2006 - 22:03
gte451f

PHP With GD Support....

Has anyone had problems getting PHP 5.1.6 to build on their 64bit Suse box?

I have all the needed devel packages installed and try to run...

./configure --with-gd=/usr/lib64 --with-jpeg-dir=/usr/lib64 --with-png-dir=/usr/lib64 --with-xpm-dir=/usr/X11R6/lib64 --with-zlib-dir=/usr/lib64 --with-freetype-dir=/usr/lib64 --enable-gd-native-ttf

But get this error everytime...

... checking for GD support... yes checking for the location of libjpeg... /usr/lib64 checking for the location of libpng... /usr/lib64 checking for the location of libXpm... /usr/X11R6/lib64 checking for FreeType 1.x support... no checking for FreeType 2... /usr/lib64 checking for T1lib support... no checking whether to enable truetype string function in GD... yes checking whether to enable JIS-mapped Japanese font support in GD... no configure: error: libjpeg.(a|so) not found. ...

Running a "find / -name libjp* Show the libjpeg.so and .a files in /usr/lib64

Any ideas?

Mon, 10/02/2006 - 14:10
Joe
Joe's picture

Hey Jim,

Why not use the packages provided by SUSE? Then you can just install the php5-gd package and be done with it. And you get the benefit of having a tested version of everything.

--

Check out the forum guidelines!

Sun, 11/19/2006 - 08:47
gte451f

I'm still stuck on this if anyone has some ideas...

I would like to but I have APC, ImageMagick up and running along with a new version of PHP 5.2. Going with the packages means 5.0.4 and having to get APC re-installed. Not to mentioned "uninstalling" the compiled version. Is there even an uninstall option for removing compile programs?

It just seems that if I can get this one hiccup, I can have just about everything up and running.