Website and PHP options gone

After upgrading to the latest version of webmin and virtualmin under Website and PHP options the options for changing from php_mod to cgi and fastcgi also execution time are gone.

I have restarted the server, the webmin and also used recheck configuration from virtualmin with no luck.

Status: 
Active

Comments

Hi I have added the $p = "web"; to the /usr/share/webmin/virtual-server/edit_phpmode.cgi file and it works. But this is something that need to be done automatically under update and it is still a bug.

I have the same issue with webmin-virtual-server=6.02.gpl. Using Ubuntu 16.04 and just updated latest Virtualmin package. I set the $p variable the same and I can see the options but it doesn't set the Run CGI script as server owner. It always stays on NO: https://screenshots.firefox.com/jDe6wxQhQj6Dc8tJ/35.167.126.116

If I downgrade to webmin-virtual-server=6.01.gpl-3 it works perfectly.

Which webserver are you using there - Nginx or Apache?

Status:
Fixed (pending)
»
Active

I'm using nginx. I installed lemp light.

This bug is independent of the webserver. We'll release an update soon to fix it..

ronnikc's picture
Submitted by ronnikc on Mon, 12/11/2017 - 03:53 Pro Licensee

It's been a couple of days now and still no bug fix release? This is rendering administration of accounts almost useless. Do you have any plans to get this out there soon?

The quick fix is to apply the patch from comment #5.

ronnikc's picture
Submitted by ronnikc on Wed, 12/13/2017 - 08:11 Pro Licensee

Files:
File: by_default_2017-12-07_at_11.30.31.png
»

Huh? Why not release a patch release of virtualmin, if you've solved the issue? We're not going through hundreds of servers to patch files around that should be fixed upstream, here.

Expect a new minor version of Virtualmin today or tomorrow

Still waiting on the release.

I have this issue also (V 6.02 Pro)

What about the Pro version?

Pro updates should be available now.