Migrate-domain - did it ever work for Plesk Onyx (Version 17.5.3)?

5 posts / 0 new
Last post
#1 Sun, 12/17/2017 - 13:12
karl.opel
karl.opel's picture

Migrate-domain - did it ever work for Plesk Onyx (Version 17.5.3)?

For a couple of days I have been struggling with importing a Plesk Onyx 17.5.3 backup, containing 3 domains in a .tar file.

Is this supposed to be working using the type plesk9?

Anyway, the scripts never find a domain. Enforcing with --domain did not help. So I started to debug the migration-plesk9.pl a bit.

To start with, it seems that the structure in the $domains Hash has changed. Instead of "domain", there now is "domain-info" containing the actual domains. After adapting the script accordingly, it will finally find domains and start to migrate BUT it does not find any actual contents. So I have my domain and the users but not the website.

Did anyone succeed migrating from a current version of Plesk?

Many thanks in advance!

Mon, 12/18/2017 - 13:25
karl.opel
karl.opel's picture

Maybe my question was too corny?

Let's rephrase it: Could someone please confirm the versions of Plesk that are suitable to provide a backup that can actually be successfully imported by virtualmin's migrate-domain option?

Thanks, Karl

Wed, 09/19/2018 - 23:25
anil3a

Thanks guys. I successfully migrated a domain from Plesk Onyx Version 17.8.11 to Virtualmin version 6.03.

Tue, 10/01/2019 - 09:29
caaf

How have you done this?

Thu, 10/03/2019 - 10:12
karl.opel
karl.opel's picture

The secret is to create one backup file per domain. Then the migration works. If you have a tarball containing multiple domains, it failed for me.