Bind DNS problem?

5 posts / 0 new
Last post
#1 Thu, 11/30/2006 - 00:59
rawoo

Bind DNS problem?

I need some serious help. I think my issue is with Bind DNS, but am not sure.

I have a fresh installation of Webmin on CentOS 4.4 with virtualmin GPL and have added a domain through the virtualmin module. Also, I've changed the name server at Godaddy to point to my box at linuxserver.thinkdaddy.com. After waiting a few hours, my index page shows up with linuxserver.thinkdaddy.com in the browser but nothing for www.thinkdaddy.com or thinkdaddy.com.

Dig gives me the following: [[root@linuxserver /]]# dig @192.168.1.100 thinkdaddy.com

;[<>> DiG 9.2.4[<>> @192.168.1.100 thinkdaddy.com ; (1 server found) ;; global options: printcmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57075 ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION: ;thinkdaddy.com. IN A

;; ANSWER SECTION: thinkdaddy.com. 38400 IN A 192.168.1.100

;; AUTHORITY SECTION: thinkdaddy.com. 38400 IN NS linuxserver.thinkdaddy.com.

;; Query time: 2 msec ;; SERVER: 192.168.1.100#53(192.168.1.100) ;; WHEN: Wed Nov 29 22:42:30 2006 ;; MSG SIZE rcvd: 74

I'm not sure where to go from here. Any ideas?

Thu, 12/14/2006 - 17:12
rawoo

Never mind. Problem solved.

Mon, 01/15/2007 - 22:41
ChrisMorgan

Hi Rich
How did you resolve this, i have a similar issue.

Tue, 01/16/2007 - 10:56
rawoo

Hi Chris,
I changed all IP address to my static &quot;public&quot; IP address. This goes for mail, www, ftp, and so on. Then wait a few hours to a day for everything to update throughout the net.

If you are using an external firewall/router, remember to open up all appropriate ports on both your external device and server.

Best of luck,
Richard

Wed, 01/17/2007 - 10:49
ChrisMorgan

Thanks Rich.
This helped me track down a few errors in my own dns config.
only one of the nameservers had updated the domain, so the install did see the qualified hostname.

This also help fix my issue which was the host file wasn't correct on my server.

Chris