bugzilla fails to install on virtual subdomain server (with Perl CPAN error)

Virtualmin system created from near-virgin CEntOS install fails to install (virtualmin-pro script) with the error:

Installing Perl module Email::MIME::Modifier from CPAN .. .. the CPAN Perl module is not installed on your system.

I would expect Virtualmin to take care of installing all dependencies but this one doesn't seem to be managed...

I'm not familiar with Perl/CPAN and there does not seem to be an obvious way to install CPAN from virtualmin console or other means.

Screenshots of top and bottom of log are attached, and complete transcript of re-install is as follows:

Found http://ftp.mozilla.org:80/pub/mozilla.org/webtools/archived/bugzilla-3.6... in cache ..

Perl module Email::MIME::Modifier is required .. Installing package perl(Email::MIME::Modifier) ..

Installing package(s) with command /bin/yum -y install perl(Email::MIME::Modifier) .. Loaded plugins: fastestmirror, langpacks Loading mirror speeds from cached hostfile * base: mirror.riverfrontnetworks.com * epel: mirror.cogentco.com * extras: mirror.es.its.nyu.edu * remi-php72: repo1.dal.innoscale.net * remi-safe: repo1.dal.innoscale.net * updates: bay.uchicago.edu Resolving Dependencies --> Running transaction check ---> Package perl-Email-MIME.noarch 0:1.926-2.el7 will be installed --> Processing Dependency: perl(Email::MIME::Encodings) >= 1.314 for package: perl-Email-MIME-1.926-2.el7.noarch --> Processing Dependency: perl(Email::MIME::ContentType) >= 1.016 for package: perl-Email-MIME-1.926-2.el7.noarch --> Processing Dependency: perl(Email::MessageID) for package: perl-Email-MIME-1.926-2.el7.noarch --> Running transaction check ---> Package perl-Email-MIME-ContentType.noarch 0:1.017-1.el7 will be installed ---> Package perl-Email-MIME-Encodings.noarch 0:1.315-1.el7 will be installed ---> Package perl-Email-MessageID.noarch 0:1.404-1.el7 will be installed --> Finished Dependency Resolution Dependencies Resolved ================================================================================ Package Arch Version Repository Size ================================================================================ Installing: perl-Email-MIME noarch 1.926-2.el7 epel 45 k Installing for dependencies: perl-Email-MIME-ContentType noarch 1.017-1.el7 epel 19 k perl-Email-MIME-Encodings noarch 1.315-1.el7 epel 18 k perl-Email-MessageID noarch 1.404-1.el7 epel 18 k Transaction Summary ================================================================================ Install 1 Package (+3 Dependent packages) Total download size: 101 k Installed size: 197 k Downloading packages: -------------------------------------------------------------------------------- Total 176 kB/s | 101 kB 00:00 Running transaction check Running transaction test Transaction test succeeded Running transaction Installing : perl-Email-MIME-Encodings-1.315-1.el7.noarch 1/4 Installing : perl-Email-MessageID-1.404-1.el7.noarch 2/4 Installing : perl-Email-MIME-ContentType-1.017-1.el7.noarch 3/4 Installing : perl-Email-MIME-1.926-2.el7.noarch 4/4 Verifying : perl-Email-MIME-1.926-2.el7.noarch 1/4 Verifying : perl-Email-MIME-ContentType-1.017-1.el7.noarch 2/4 Verifying : perl-Email-MessageID-1.404-1.el7.noarch 3/4 Verifying : perl-Email-MIME-Encodings-1.315-1.el7.noarch 4/4 perl-Email-MIME.noarch 0:1.926-2.el7 Dependency Installed: perl-Email-MIME-ContentType.noarch 0:1.017-1.el7 perl-Email-MIME-Encodings.noarch 0:1.315-1.el7 perl-Email-MessageID.noarch 0:1.404-1.el7 Complete! Installed: .. install complete.

Installing Perl module Email::MIME::Modifier from CPAN .. .. the CPAN Perl module is not installed on your system.

Absolutely nothing appears to be installed in the apache subfolder for the subdomain.

Status: 
Active

Comments

Howdy -- hmm, it looks like it thinks the module didn't install, but I also don't see an error there.

What is the output of this command:

rpm -qa | grep -i perl-Email-MIME

$ rpm -qa | grep perl-Email-MIME

perl-Email-MIME-ContentType-1.017-1.el7.noarch

perl-Email-MIME-1.926-2.el7.noarch

perl-Email-MIME-Encodings-1.315-1.el7.noarch

$

Okay, it does look like that CPAN module was successfully installed.

What happens if you attempt to install Bugzilla again? Does it by chance install properly now?

Or does it still say the CPAN module isn't installed?

The output in this bug report was actually from the attempt to re-run the install script.

I did NOT (unfortunately) save the original error log.

When it first failed, i immediately re-ran things and that is the transcript that that is attached.

Re-running the script now always produces the same output.

I can create another temporary sub-domain, in which to install bugzilla, and can trap/record that log.

How useful would that be? It would take only 5 to 10 minutes to do that...

Thanks for the offer, but there's no need to do that... it seems like it's either not properly detecting the installed CPAN module, or, the module isn't working as expected.

We'll look into that for a future release, but we'd also like to get Bugzilla installed for you in the meantime.

What happens if you run this command as root on the command line, which would install the latest version of the module from the CPAN repository:

cpan -i Email::MIME::Modifier

After doing that, are you then able to install Bugzilla?

i had looked before and no 'cpan' to be found on the system path:

$ cpan -i Email::MIME::Modifier

bash: cpan: command not found...

But interestingly, when logged in as root:

cd /

find . | grep cpan

find: ‘./run/user/1000/gvfs’: Permission denied

./etc/webmin/cpan

./etc/webmin/cpan/config

./var/webmin/modules/cpan

./usr/share/augeas/lenses/dist/cpanel.aug

./usr/share/perl5/LWP/Protocol/cpan.pm

./usr/libexec/webmin/pam/cpan_modules.pl

./usr/libexec/webmin/authentic-theme/images/modules/cpan

./usr/libexec/webmin/authentic-theme/images/modules/cpan/cat.gif

./usr/libexec/webmin/authentic-theme/images/modules/cpan/icon.gif

./usr/libexec/webmin/authentic-theme/images/modules/cpan/mod.gif

./usr/libexec/webmin/blue-theme/cpan

./usr/libexec/webmin/blue-theme/cpan/images

./usr/libexec/webmin/blue-theme/cpan/images/cat.gif

./usr/libexec/webmin/blue-theme/cpan/images/icon.gif

./usr/libexec/webmin/blue-theme/cpan/images/mod.gif

./usr/libexec/webmin/ldap-client/cpan_modules.pl

./usr/libexec/webmin/proc/cpan_modules.pl

./usr/libexec/webmin/gray-theme/cpan

./usr/libexec/webmin/gray-theme/cpan/images

./usr/libexec/webmin/gray-theme/cpan/images/cat.gif

./usr/libexec/webmin/gray-theme/cpan/images/icon.gif

./usr/libexec/webmin/gray-theme/cpan/images/mod.gif

./usr/libexec/webmin/cpan

./usr/libexec/webmin/cpan/CHANGELOG

./usr/libexec/webmin/cpan/cgi_args.pl

./usr/libexec/webmin/cpan/config

./usr/libexec/webmin/cpan/module.info.ko_KR.UTF-8

./usr/libexec/webmin/cpan/config-solaris

./usr/libexec/webmin/cpan/config.info

./usr/libexec/webmin/cpan/module.info.ko_KR.euc

./usr/libexec/webmin/cpan/config.info.ca

./usr/libexec/webmin/cpan/download.cgi

./usr/libexec/webmin/cpan/config.info.ca.UTF-8

./usr/libexec/webmin/cpan/module.info.ms_MY

./usr/libexec/webmin/cpan/config.info.cz

./usr/libexec/webmin/cpan/edit_mod.cgi

./usr/libexec/webmin/cpan/config.info.cz.UTF-8

./usr/libexec/webmin/cpan/config.info.de

./usr/libexec/webmin/cpan/install.cgi

./usr/libexec/webmin/cpan/config.info.de.UTF-8

./usr/libexec/webmin/cpan/module.info.nl

./usr/libexec/webmin/cpan/config.info.es

./usr/libexec/webmin/cpan/index.cgi

./usr/libexec/webmin/cpan/config.info.es.UTF-8

./usr/libexec/webmin/cpan/config.info.fr

./usr/libexec/webmin/cpan/config.info.fr.UTF-8

./usr/libexec/webmin/cpan/module.info.no

./usr/libexec/webmin/cpan/config.info.hr

./usr/libexec/webmin/cpan/module.info.no.UTF-8

./usr/libexec/webmin/cpan/config.info.hu

./usr/libexec/webmin/cpan/lang

./usr/libexec/webmin/cpan/lang/ca

./usr/libexec/webmin/cpan/lang/ca.UTF-8

./usr/libexec/webmin/cpan/lang/cz

./usr/libexec/webmin/cpan/lang/cz.UTF-8

./usr/libexec/webmin/cpan/lang/de

./usr/libexec/webmin/cpan/lang/de.UTF-8

./usr/libexec/webmin/cpan/lang/en

./usr/libexec/webmin/cpan/lang/en.UTF-8

./usr/libexec/webmin/cpan/lang/es

./usr/libexec/webmin/cpan/lang/es.UTF-8

./usr/libexec/webmin/cpan/lang/fr

./usr/libexec/webmin/cpan/lang/fr.UTF-8

./usr/libexec/webmin/cpan/lang/hr

./usr/libexec/webmin/cpan/lang/hu

./usr/libexec/webmin/cpan/lang/hu.UTF-8

./usr/libexec/webmin/cpan/lang/it

./usr/libexec/webmin/cpan/lang/it.UTF-8

./usr/libexec/webmin/cpan/lang/ja_JP.UTF-8

./usr/libexec/webmin/cpan/lang/ja_JP.euc

./usr/libexec/webmin/cpan/lang/ko_KR.UTF-8

./usr/libexec/webmin/cpan/lang/ko_KR.euc

./usr/libexec/webmin/cpan/lang/ms

./usr/libexec/webmin/cpan/lang/ms.UTF-8

./usr/libexec/webmin/cpan/lang/ms_MY

./usr/libexec/webmin/cpan/lang/ms_MY.UTF-8

./usr/libexec/webmin/cpan/lang/nl

./usr/libexec/webmin/cpan/lang/nl.UTF-8

./usr/libexec/webmin/cpan/lang/no

./usr/libexec/webmin/cpan/lang/no.UTF-8

./usr/libexec/webmin/cpan/lang/pl

./usr/libexec/webmin/cpan/lang/pl.UTF-8

./usr/libexec/webmin/cpan/lang/ru.UTF-8

./usr/libexec/webmin/cpan/lang/ru_RU

./usr/libexec/webmin/cpan/lang/ru_SU

./usr/libexec/webmin/cpan/lang/sv

./usr/libexec/webmin/cpan/lang/sv.UTF-8

./usr/libexec/webmin/cpan/lang/uk_UA

./usr/libexec/webmin/cpan/lang/zh_CN

./usr/libexec/webmin/cpan/lang/zh_CN.UTF-8

./usr/libexec/webmin/cpan/lang/zh_TW.Big5

./usr/libexec/webmin/cpan/lang/zh_TW.UTF-8

./usr/libexec/webmin/cpan/lang/ru_RU.UTF-8

./usr/libexec/webmin/cpan/lang/uk_UA.UTF-8

./usr/libexec/webmin/cpan/config.info.hu.UTF-8

./usr/libexec/webmin/cpan/module.info.pl

./usr/libexec/webmin/cpan/config.info.it

./usr/libexec/webmin/cpan/config.info.it.UTF-8

./usr/libexec/webmin/cpan/module.info.ca

./usr/libexec/webmin/cpan/config.info.ja_JP.UTF-8

./usr/libexec/webmin/cpan/module.info.cz

./usr/libexec/webmin/cpan/config.info.ja_JP.euc

./usr/libexec/webmin/cpan/module.info.cz.UTF-8

./usr/libexec/webmin/cpan/config.info.ko_KR.UTF-8

./usr/libexec/webmin/cpan/module.info.de

./usr/libexec/webmin/cpan/config.info.ko_KR.euc

./usr/libexec/webmin/cpan/module.info.pl.UTF-8

./usr/libexec/webmin/cpan/config.info.ms

./usr/libexec/webmin/cpan/config.info.ms.UTF-8

./usr/libexec/webmin/cpan/module.info.ru.UTF-8

./usr/libexec/webmin/cpan/config.info.ms_MY

./usr/libexec/webmin/cpan/module.info.es

./usr/libexec/webmin/cpan/config.info.ms_MY.UTF-8

./usr/libexec/webmin/cpan/module.info.ru_RU

./usr/libexec/webmin/cpan/config.info.nl

./usr/libexec/webmin/cpan/config.info.nl.UTF-8

./usr/libexec/webmin/cpan/config.info.no

./usr/libexec/webmin/cpan/module.info.fr

./usr/libexec/webmin/cpan/config.info.no.UTF-8

./usr/libexec/webmin/cpan/module.info.ru_SU

./usr/libexec/webmin/cpan/config.info.pl

./usr/libexec/webmin/cpan/config.info.pl.UTF-8

./usr/libexec/webmin/cpan/module.info.hu

./usr/libexec/webmin/cpan/config.info.ru.UTF-8

./usr/libexec/webmin/cpan/module.info.sv

./usr/libexec/webmin/cpan/config.info.ru_RU

./usr/libexec/webmin/cpan/config.info.ru_SU

./usr/libexec/webmin/cpan/module.info.zh_CN

./usr/libexec/webmin/cpan/config.info.sv

./usr/libexec/webmin/cpan/module.info.hu.UTF-8

./usr/libexec/webmin/cpan/config.info.sv.UTF-8

./usr/libexec/webmin/cpan/module.info.zh_CN.UTF-8

./usr/libexec/webmin/cpan/config.info.uk_UA

./usr/libexec/webmin/cpan/module.info.zh_TW.Big5

./usr/libexec/webmin/cpan/config.info.zh_CN

./usr/libexec/webmin/cpan/module.info.it

./usr/libexec/webmin/cpan/config.info.zh_CN.UTF-8

./usr/libexec/webmin/cpan/config.info.zh_TW.Big5

./usr/libexec/webmin/cpan/module.info.ja_JP.UTF-8

./usr/libexec/webmin/cpan/config.info.zh_TW.UTF-8

./usr/libexec/webmin/cpan/cpan-lib.pl

./usr/libexec/webmin/cpan/cpan.cgi

./usr/libexec/webmin/cpan/module.info.zh_TW.UTF-8

./usr/libexec/webmin/cpan/delete_file.cgi

./usr/libexec/webmin/cpan/images

./usr/libexec/webmin/cpan/images/cat.gif

./usr/libexec/webmin/cpan/images/icon.gif

./usr/libexec/webmin/cpan/images/mod.gif

./usr/libexec/webmin/cpan/images/smallicon.gif

./usr/libexec/webmin/cpan/module.info

./usr/libexec/webmin/cpan/postinstall.pl

./usr/libexec/webmin/cpan/uninstall.cgi

./usr/libexec/webmin/cpan/uninstall_mods.cgi

./usr/libexec/webmin/cpan/module.info.ja_JP.euc

./usr/libexec/webmin/cpan/config.info.ru_RU.UTF-8

./usr/libexec/webmin/cpan/config.info.uk_UA.UTF-8

./usr/libexec/webmin/ldap-useradmin/cpan_modules.pl

./usr/libexec/webmin/jabber/cpan_modules.pl

./usr/libexec/webmin/mysql/cpan_modules.pl

./usr/libexec/webmin/postgresql/cpan_modules.pl

./usr/libexec/webmin/useradmin/cpan_modules.pl

./usr/libexec/webmin/webmin/cpan_modules.pl

./usr/libexec/webmin/virtual-server/migration-cpanel.pl

./usr/libexec/usermin/authentic-theme/images/modules/cpan

./usr/libexec/usermin/authentic-theme/images/modules/cpan/cat.gif

./usr/libexec/usermin/authentic-theme/images/modules/cpan/icon.gif

./usr/libexec/usermin/authentic-theme/images/modules/cpan/mod.gif

./usr/libexec/usermin/blue-theme/cpan

./usr/libexec/usermin/blue-theme/cpan/images

./usr/libexec/usermin/blue-theme/cpan/images/cat.gif

./usr/libexec/usermin/blue-theme/cpan/images/icon.gif

./usr/libexec/usermin/blue-theme/cpan/images/mod.gif

./usr/libexec/usermin/gray-theme/cpan

./usr/libexec/usermin/gray-theme/cpan/images

./usr/libexec/usermin/gray-theme/cpan/images/cat.gif

./usr/libexec/usermin/gray-theme/cpan/images/icon.gif

./usr/libexec/usermin/gray-theme/cpan/images/mod.gif

Okay, try running this command:

yum install perl-CPAN

And after that, re-run this command:

cpan -i Email::MIME::Modifier

If that still doesn't work -- try this command instead:

perl -MCPAN -e 'install Email::MIME::Modifier'

Well. I now think that i am screwed.

With the first command, cpan -i Email::MIME::Modifier, i was asked to install/configure CPAN. Knowing nothing about CPAN - i responded to the configuration wizard by accepting ALL defaults; this included accepting "Local::Lib" configuration versus "sudo" configuratation.

Once i realized this mistake, i spent several hours attempting to reconfigure CPAN, including 'yum remove perl-CPAN', but everything i have done refuses to allow me to completely reconfigure CPAN. At best i am asked only one configuration setting, the urllist.

I tried deleting /root/.cpan/CPAN/MyConfig.pm (also 'rm -rf /root/.cpan').

There is no /etc/perl/CPAN folder.

cd / find . | grep Config.pm

find: ‘./run/user/1000/gvfs’: Permission denied

./root/.cpan/CPAN/MyConfig.pm

./root/.cpan/build/ExtUtils-MakeMaker-7.34-7fNLFW/t/testdata /reallylongdirectoryname/arch2/Config.pm

./root/.cpan/build/ExtUtils-MakeMaker-7.34-7fNLFW/t/testdata/reallylongdirectoryname/arch1/Config.pm

./root/.cpan/build/ExtUtils-MakeMaker-7.34-7fNLFW/lib/ExtUtils/MakeMaker/Config.pm

./root/.cpan/build/ExtUtils-MakeMaker-7.34-7fNLFW/blib/lib/ExtUtils/MakeMaker/Config.pm

./root/.cpan/build/Encode-2.98-YmixNj/lib/Encode/Config.pm

./root/.cpan/build/Encode-2.98-YmixNj/blib/lib/Encode/Config.pm

./root/perl5/lib/perl5/ExtUtils/MakeMaker/Config.pm

./usr/lib64/perl5/vendor_perl/Encode/Config.pm

./usr/lib64/perl5/vendor_perl/Template/Config.pm

./usr/lib64/perl5/Config.pm

./usr/share/perl5/vendor_perl/HTTP/Config.pm

./usr/share/perl5/vendor_perl/ExtUtils/MakeMaker/Config.pm

./usr/share/perl5/vendor_perl/Log/Log4perl/Config.pm

./usr/share/perl5/vendor_perl/Virtualmin/Config.pm

./usr/share/perl5/vendor_perl/AppConfig.pm

./usr/share/perl5/Net/Config.pm

./usr/share/perl5/CPAN/HandleConfig.pm

./usr/share/automake-1.13/Automake/Config.pm

./usr/local/lib64/perl5/Encode/Config.pm

I tried google search for "how to change cpan from local::lib to sudo" and found the exact question from three weeks ago - but no other specific response, other than running "o conf init" from the CPAN shell, which never asks the "Local::Lib" vs "sudo" mode question.

I tried re-running cpan shell "o conf init" and NOT allowing "Automatic" setup mode, but immediately start to get perl-ish configuration questions to which i have no clue as to reasonable answers.

My intuition tells me that one or more of the above listed '*Config.pm' files could be removed and would result in enough amnesia for cpan to request ALL configuration options - but i don't have the luxury of doing random deletes on a production system.

How screwed am i? And again this is a production server.

Well. Several hours later - just for giggles - i go to virtualmin and attempt to "Install Scripts" Bugzilla.

There 7632 lines of output (which is too long to paste here). How do i attach a new text file here that is about 450K in size?

There would appear to be many dozens of 'test failures' or 'dubious return codes' reported in the transcript.

The last few lines are rather useless and are entered here.

Installing Perl module DateTime::TimeZone from CPAN ..

Reading '/root/.cpan/Metadata' Database was generated on Sun, 17 Jun 2018 07:29:03 GMT DateTime::TimeZone is up to date (2.19).

.. done

Now installing Bugzilla version 3.6.13 ..

Bugzilla dependency problems detected :

.. failed! See the error message above for the reason why.

That final failure summary, "Bugzilla dependency problems detected:", has a blank black box after it. I would have expected a specific propagated error/warning message to be there - but not.

At this point i am now way-in over my head, and don't want to screw anything up for this production system...

Hmm, I'm really not sure what's going on there.

I'll do some testing on my test CentOS 7 system to see if I can reproduce a similar issue... that will help us understand more about the issue there.

Well. I just spent a couple of hours installing virtualmin pro onto a virgin centos VM.

Created domain "example.com", then created subdomain "ersa.example.com" via virtualmin UI.

Under "ersa.example.com" went to "Install Scripts", selected Bugzilla, and then "install".

Several perl modules appear to yum install:

Dependency Installed:

perl-Email-Address.noarch 0:1.898-3.el7

perl-Email-Simple.noarch 0:2.214-1.el7

perl-Module-Pluggable.noarch 1:4.8-3.el7

perl-Return-Value.noarch 0:1.666001-8.el7

Complete!

Installed:

.. install complete.

But then below the white text in black box appears:

Installing Perl module Email::Send from CPAN ..

.. the CPAN Perl module is not installed on your system.

Manually did yum install perl-CPAN

and then

cpan -i Email::MIME::Modifier

Then a long install transcript follows with the tail looking like:

Files=20, Tests=36, 2 wallclock secs ( 0.08 usr 0.03 sys + 0.98 cusr 0.20 csys = 1.29 CPU)

Result: FAIL

Failed 18/20 test programs. 19/36 subtests failed.

make: *** [test_dynamic] Error 2

RJBS/Email-MIME-1.946.tar.gz

2 dependencies missing (Email::Address::XS,Email::MIME::ContentType); additionally test harness failed

/usr/bin/make test -- NOT OK

//hint// to see the cpan-testers results for installing this module, try:

reports RJBS/Email-MIME-1.946.tar.gz

Running make install

make test had returned bad status, won't install without force

It's beginning to look like it's entirely a CPAN/bugzilla installation problem.

I have the original 1671 line 'tee' of the 'cpan -i Email::MIME::Modifier' operation, and there appear to by dozens to hundreds of FAILS.

What's the best way that i could send the log for assistance in debugging? (it's 89K in size)

Well, if the Perl modules aren't installing without error, we unfortunately may not be able to fix that... that could indicate an issue with the current Perl modules.

However, I'm going to do some testing of all that on my system to see what I can figure out.

Note that if it's an option, you could always try it on a different distribution. It could be related to the particular set of library versions on CentOS 7.

I'll let you know what I find out after some testing, though note that I won't be able to look into that today, as that'll take some time.

Yes. I need a current install as soon as possible, so will provision a standalone VM and attempt to let Bugzilla install itself there (yum install bugzilla - that has worked before...). If i get any data points or insight into the problem i will post it here. Thank you for attention to this matter.

Well, probably not good news for the virtualmin install script developers: I was able to build and install bugzilla on a standalone (non-virtualmin) server.

i followed these instructions: https://www.vultr.com/docs/how-to-install-bugzilla-5-0-x-on-centos-7

and end up with a functional copy of bugzilla at the target URL...

To me, this information means that the perl modules are fine,

(Just to verify things, i quickly retried virtualmin's Bugzilla Install Script and my "problem" still continues to manifest itself.)

Thanks for your info!

I've been looking into this today.

I tried the installation on two different distros (Ubuntu 14.04 and CentOS 7), and in both cases, the Perl module installs are failing.

An alternate theory is that the required dependencies have changed over time.

Virtualmin is installing them one at a time on the command line though... which option in your guide did you use to perform the module install, did you run this command:

sudo /usr/bin/perl /var/www/html/bugzilla/install-module.pl --all

I see that's one of the options they're showing for installing the Perl modules... I'm wondering if that particular script is pulling in specific versions, rather than simply grabbing the latest version, which is what Virtualmin does.

In either case, we need to review those, as the Bugzilla Install Script doesn't appear to be working.

As said previously Bugzilla did install to completion on Centos 7. I now have a host at http://bugzilla.jovi-enterprises.net, but it is an unsatisfactory solution due to lack of integration with Let's Encrypt support with our virtualmin managed domains, and it's now on an isolated virtual machine requiring it's own management and backup.

Yes. Among other things, i DID use the --all option (several times) with various "checks" and "hand-feeding the beast" to make certain it worked. (I could NOT afford to NOT have it succeed in the installation, but i'm not a Perl nor a Bugzilla expert by any means.) I would say the key thing of note: I used the "sudo" option for CPAN install (vs. the "Local::Lib" variant) - don't know if that made a difference, but the virtualmin installation of Perl is now STUCK in "Local::Lib" mode and i have not succeeded in removing things such that a re-install allows me to pick the "sudo" mode. The "sudo vs Local::Lib may be entirely a red-herring and really of no consequence, but it was a key difference on the isolated machine install vs. what virtualmin appeared to be doing.

Thanks for all the information you've provided, that helps!

We'll look into the Bugzilla script to try and sort out why that's not working properly.

When might official support for Buzilla be restored in Virtualmin?