Update of virtualmin always gives problems

9 posts / 0 new
Last post
#1 Mon, 04/09/2007 - 11:59
KoenRens

Update of virtualmin always gives problems

When I update virtualmin, I allways have problems, for over half a year now.

Everytime I update it (by installing the new version over the old one in webmin modules), entire webmin hangs.

In the past I was always able to fix this problem by: service webmin stop service usermin stop

Then: ps ax | grep webmin

Which gives a huge list of processes: 28058 ? S 0:00 /usr/bin/perl /usr/libexec/webmin/virtual-server/writ elogs.pl 11761255933553 /home/wsbeta/logs/access_log 28062 ? S 0:00 /usr/bin/perl /usr/libexec/webmin/virtual-server/writ elogs.pl 11701953655048 /home/maffia-kill/logs/access_log 28063 ? S 0:00 /usr/bin/perl /usr/libexec/webmin/virtual-server/writ elogs.pl 117010205515155 /home/billing/logs/access_log 28067 ? S 0:00 /usr/bin/perl /usr/libexec/webmin/virtual-server/writ elogs.pl 117008468318630 /home/ecards/logs/access_log .....

I then kill all the processes with kill -9 pid About over 200 processes. And then I can start webmin again.

But now everytime I kill a process, it just comes back???

How can I instantly kill al these processes? :(

Mon, 04/09/2007 - 12:16
KoenRens

This is faster:
ps -e | grep logs

31434 ? 00:00:00 writelogs.pl
31438 ? 00:00:00 writelogs.pl
31442 ? 00:00:00 writelogs.pl
31447 ? 00:00:00 writelogs.pl
31448 ? 00:00:00 writelogs.pl
31453 ? 00:00:00 writelogs.pl
31472 ? 00:00:00 writelogs.pl
31476 ? 00:00:00 writelogs.pl
31477 ? 00:00:00 writelogs.pl
31478 ? 00:00:00 writelogs.pl
31479 ? 00:00:00 writelogs.pl
31487 ? 00:00:00 writelogs.pl
31488 ? 00:00:00 writelogs.pl
31489 ? 00:00:00 writelogs.pl
31490 ? 00:00:00 writelogs.pl
31491 ? 00:00:00 writelogs.pl
31492 ? 00:00:00 writelogs.pl
31493 ? 00:00:00 writelogs.pl
31494 ? 00:00:00 writelogs.pl
31495 ? 00:00:00 writelogs.pl
31496 ? 00:00:00 writelogs.pl
31497 ? 00:00:00 writelogs.pl
31500 ? 00:00:00 writelogs.pl
31522 ? 00:00:00 writelogs.pl
31527 ? 00:00:00 writelogs.pl

Then kill all of them, repeat the first command in this post and kill them again.
Then start webmin again and now your webmin + virtualmin should work again.

What a hassle for a good hostingpanel. :p

Mon, 04/09/2007 - 14:21
TonyShadwick

Two things here.

1. You really shouldn't have to do this, perhaps a dev can help you there.

2. killall writelogs.pl (or killall -(signal) writelogs.pl, don't use -9 unless you absolutely must!)

Tue, 04/10/2007 - 03:42
Joe
Joe's picture

Howdy Koen,

As Tony said, you shouldn't have to do that. I dunno exactly what's going on there, the writelogs.pl process is not even run under the same process as Webmin--the two are wholly separate. It just seems related, but really isn't. ;-)

I'll ask Jamie to chime in here with thoughts on debugging the problem.

--

Check out the forum guidelines!

Tue, 04/10/2007 - 12:53
Joe
Joe's picture

Hi Koen,

Those writelogs.pl processes are run from Apache, not from the main Webmin server process .. and will be running all the time. If you need to restart Webmin, the best command to run is just :
/etc/webmin/restart

As for what causes this hang in the first place, it is hard to say .. I haven't seen it on any of my test systems. Do you do the upgrade from the command line (with yum install), or via some other method?

Also, the upgrade process can take a few minutes to complete .. how long was it hung for?

--

Check out the forum guidelines!

Thu, 04/19/2007 - 02:02
Dirk

Hi,
so this:
http://www.virtualmin.com/forums/message-view?message%5fid=104212
seems to be the same problem?

Dirk

Thu, 04/19/2007 - 02:30 (Reply to #6)
Joe
Joe's picture

Hey Dirk,

Nope. Different problems. I don't know that we ever figured out what was happening on Koen's box. But I've got my debian system booting up now to reproduce your problem.

--

Check out the forum guidelines!

Sat, 04/28/2007 - 15:19
KoenRens

"Also, the upgrade process can take a few minutes to complete .. how long was it hung for? "

Update to newest version of virtualmin said: completed.
I updated it throught webmin itself, not the command line.

After the "completed" text webmin seems to get in a loop.
It doesn't load anything anymore.
I then shutdown webmin and usermin.
Start up again => same problem, loops
Kill +/- 800 manually writelogs.pl processes (they immediately start again) , start webmin/usermin => works again.

Sat, 04/28/2007 - 17:50 (Reply to #8)
Joe
Joe's picture

Hey Koen,

The writelogs.pl processes are not at all related to Webmin's process. They are spawned by Apache, and of course they'll come back (or your Apache would have to die because it would have nowhere to write logs to). If you have +/- 800 domains, then you'll have as many writelogs.pl processes. You can disable the writelogs.pl processes if you want to, by setting Apache to write directly rather than via a process. This is in the Server Configuration:Website Options for each of your domains. But, again this has no relation to Webmin.

So, we still don't know what's happening with your Webmin restarts and why they're failing (a bunch of writelogs.pl won't have any impact, unless some limit on your server is being hit--I'm not sure if 800 would hit any limits...maybe if the total process count over 1024, but I doubt any modern system has a process limit of 1024).

What happens if you just restart Webmin manually from the command line:

/etc/init.d/webmin restart

--

Check out the forum guidelines!