5 posts / 0 new
Last post
#1 Thu, 04/12/2007 - 12:01
Vedstesen

PHP4

Hey all.

Thanks Joe for helping me with spamassassing and clamav.

But php4..... Having trouble installing it.

Yum install php4 php4 and php4-pear are installed.

I restart apache. ok.

Then trying to install php4-imap. when I got this error: Stopping httpd: [[ OK ]] Starting httpd: /bin/bash: line 1: 19018 Segmentation fault /usr/sbin/httpd [[FAILED]]

Ok. I remove php4-imap, and apache will start again.

I have tried php4-gd, php4-imap, php4-mysql, php4-ldap and php4-domxml.

Same error.

Horde need imap for work.

Can somebody tell me how to fix this?

By the way: Virtualmin Pro on Fedora Core 6

Fri, 04/13/2007 - 02:54
Vedstesen

Okay..

I posted this messages to fast.

Now I have tried the faq on this.

yum install php4*

and edited php.conf and php4.conf.

Fine apache will restart and the most of php working.

But But But.....

Still having trouble to install horde.
It says:
Failed to install script : module php-pear does not exist

Hmm... What now. All the php4 are installed.
That do I miss?`

Peter

Mon, 04/16/2007 - 10:32
Vedstesen

Hmmm....

Can it be true, I am the only one having this problem?

Please give me some help here!

Do I have to uninstall php5 before intalling php4. And then install php5 again?

Help
I can't get Horde installed.

Peter Vedstesen

Mon, 04/16/2007 - 16:30 (Reply to #3)
Joe
Joe's picture

Hey Peter,

Kevin's right on this one (this dependency will be added to a coming-soon release of virtualmin-base).

I'll also comment on this:

<i>Do I have to uninstall php5 before intalling php4. And then install php5 again?</i>

Definitely not. That would indicate horribly stupid and broken php packages, and since I built them, we know that's not possible. ;-)

--

Check out the forum guidelines!

Mon, 04/16/2007 - 15:02
kcackler

yum install php-pear