Webmin menu disappeared as server's admin???

To Virtualmin

Suddenly the Webmin menu has disappeared from our 2 Virtualmin Pro instances??

Please see attached images from the past and the same menu options avail now on the same server and log in. Where did the Webmin menu go, where you could manage cron jobs, protected web directories and more as an owner of a virtual server. Now we can see Virtualmin and Dashboard, but those two are the same?

Is this a bug or what happened.

Webmin : 1.890 Virtualmin Pro: 6.04 Pro Usermin : 1.741

I look forward to hearing from you.

  • Tim
Status: 
Closed (fixed)

Comments

To clarify, is this happening when logged in as root, or as a domain owner?

Joe knows the cause of this one, I've asked him to chime in.

Joe's picture
Submitted by Joe on Sat, 10/13/2018 - 18:59 Pro Licensee

Status:
Active
»
Fixed (pending)

Yeah, this one is a theme bug in Authentic. Ilia thought the option in Virtualmin config about hiding the Webmin tab meant "don't give users access to any Webmin modules" so he was also hiding the Webmin Modules menu in Virtualmin. It's fixed in recent versions of the theme, and in the devel versions of Webmin.

I can roll the devel Webmin package out to the CentOS repos (it's already in Debian/Ubuntu repos to address other issues on Ubuntu). Should be able to get that done tonight or in the morning.

Hi Joe

That's just perfect :) I look forward to get the new "authentic" theme on so that the webmin menu will appear again for domain owners :)

Tim

We are using version 19.19 on both Virtualmin instances.

  • Tim

Yeah I'm using that same Authentic version on my personal server, and I'm seeing the same issue as well, eclipse.

We definitely need to get a new Authentic version out there to address that, thanks for pointing this out!

Hi,

When can we expect a new version out?

  • Tim
Joe's picture
Submitted by Joe on Thu, 10/18/2018 - 23:57 Pro Licensee

You can force a theme update to the current devel release in the "Theme Options" page at the bottom. Current development release (19.20-beta5) has this fixed (though I think we're going to refine it a bit and move it into Virtualmin proper pretty soon, rather than having it be part of the theme).

The Webmin devel release that I just rolled out didn't have this fix, unfortunately, but the next Webmin version will get the next stable release of Authentic. It's likely coming in the next week or so. We're gonna try to do one more stable Webmin before we start work on branching new versions of everything for Virtualmin 7 coming around end of year.

Hi Joe

Ok, I will wait for the real version to be out, please keep me posted.

  • Tim

To Virtualmin

What is the status of this?? It's a problem that the webmin menu isn't visible.

  • Tim
Joe's picture
Submitted by Joe on Sun, 11/25/2018 - 21:11 Pro Licensee

Status:
Fixed (pending)
»
Closed (fixed)

This should be fixed in the current Webmin version, as far as I know?

Status: Fixed ยป Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.