Can't connect to Webmin port - “Cron 15430088014649 missing any time spec”

3 posts / 0 new
Last post
#1 Fri, 11/23/2018 - 18:44
Bestulo
Bestulo's picture

Can't connect to Webmin port - “Cron 15430088014649 missing any time spec”

Webmin has started, but I can't access it from the web (can't curl/wget from terminal either). When I restart it, it throws the error I gave in the title. I've tracked the source of the error to this line of code:

https://github.com/webmin/webmin/blob/master/miniserv.pl#L5969

If I try to connect to any other port that is not Webmin's, the connection gets immediately rejected, but if I use Webmin's port, I wait and wait until it times out (in the browser, curl stays forever).

I don't know how to install and run it properly on Debian 9. Does anybody have an idea of what I can do to fix this?

besto@host:~/tmp$ sudo /etc/init.d/webmin restart
Stopping Webmin server in /usr/share/webmin
Starting Webmin server in /usr/share/webmin
Cron 15430088014649 missing any time spec
besto@host:~/tmp$

Tue, 01/08/2019 - 01:52
NickSchick

I second this motion - I am having a similar issue on a new set up server restored from backups

[root@theta1 ~]# /etc/init.d/webmin restart
Stopping Webmin server in /usr/libexec/webmin
Starting Webmin server in /usr/libexec/webmin
Pre-loaded virtual-server/virtual-server-lib-funcs.pl in virtual_server
Pre-loaded virtual-server/feature-unix.pl in virtual_server
Pre-loaded virtual-server/feature-dir.pl in virtual_server
Pre-loaded virtual-server/feature-dns.pl in virtual_server
Pre-loaded virtual-server/feature-mail.pl in virtual_server
Pre-loaded virtual-server/feature-web.pl in virtual_server
Pre-loaded virtual-server/feature-webalizer.pl in virtual_server
Pre-loaded virtual-server/feature-ssl.pl in virtual_server
Pre-loaded virtual-server/feature-logrotate.pl in virtual_server
Pre-loaded virtual-server/feature-mysql.pl in virtual_server
Pre-loaded virtual-server/feature-postgres.pl in virtual_server
Pre-loaded virtual-server/feature-ftp.pl in virtual_server
Pre-loaded virtual-server/feature-spam.pl in virtual_server
Pre-loaded virtual-server/feature-virus.pl in virtual_server
Pre-loaded virtual-server/feature-webmin.pl in virtual_server
Pre-loaded virtual-server/feature-virt.pl in virtual_server
Pre-loaded virtual-server/feature-virt6.pl in virtual_server
Cron 154598851614124 missing any time spec

Webmin/Virtualmin become unresponsive -> Then must restart and it will restore interface

Sat, 04/27/2019 - 16:27
adamjedgar

.i found a post here (which i have not yet tried) that might fix it... https://github.com/webmin/webmin/issues/994

As far as i can tell, this shouldnt stop webmin from running. I am not sure why mine has also done this out of the blue this morning. I wonder if a complete system restart would fix the error on mine?

AJECreative is the home of $5 webhosting, $15/month VPS servers (1cpu,1gb RAM, 25GB storage)
Centos7, Debian9, or Ubuntu18LTS
Available Control Panels = Centos-Webpanel, Cyberpanel, or Virtualmin

https://ajecreative.com.au