Install script fails to find packages

3 posts / 0 new
Last post
#1 Mon, 05/21/2007 - 01:40
DavidKoontz

Install script fails to find packages

I'm installing on a semi-fresh CentOS 4 box. Running yum clean headers doesn't resolve anything.

Attempting to import various system RPM-GPG-KEY files...Errors may occur, if you've already imported them. It is safe to ignore these errors. INFO - Succeeded. INFO - Installing dependencies using command: /usr/bin/yum -y -d 2 install bind bind-chroot bind-utils caching-nameserver httpd postfix bind spamassassin procmail perl perl-DBD-Pg perl-DBD-MySQL quota iptables openssl python mailman subversion ruby rdoc ri mysql mysql-server postgresql postgresql-server rh-postgresql rh-postgresql-server logrotate webalizer php php-domxl php-gd php-imap php-mysql php-odbc php-pear php-pgsql php-snmp php-xmlrpc php-mbstring mod_perl mod_python cyrus-sasl dovecot spamassassin mod_dav_svn cyrus-sasl-gssapi mod_ssl ruby rubygems perl-XML-Simple perl-Crypt-SSLeay INFO - ...in progress, please wait... -No Match for argument: rdoc No Match for argument: ri |No Match for argument: rh-postgresql No Match for argument: rh-postgresql-server -No Match for argument: php-domxl /No Match for argument: rubygems -No Match for argument: perl-XML-Simple |Error: Missing Dependency: libaprutil-0.so.0 is needed by package mod_perl Error: Missing Dependency: libaprutil-0.so.0 is needed by package httpd Error: Missing Dependency: libpq.so.3 is needed by package dovecot Error: Missing Dependency: libapr-0.so.0 is needed by package httpd Error: Missing Dependency: libpq.so.3 is needed by package perl-DBD-Pg Error: Missing Dependency: libpq.so.3 is needed by package php-pgsql Error: Missing Dependency: libapr-0.so.0 is needed by package mod_perl Error: Missing Dependency: subversion = 1.1.4-2.ent is needed by package mod_dav_svn ...in progress, please wait... failed. Error (if any): 0

---> Package perl-Digest-HMAC.noarch 0:1.01-13 set to be updated ---> Downloading header for perl-HTML-Tagset to pack into transaction set. ---> Package perl-HTML-Tagset.noarch 0:3.03-30 set to be updated ---> Downloading header for aspell-en to pack into transaction set. ---> Package aspell-en.i386 50:0.51-11 set to be updated --> Running transaction check --> Processing Dependency: libaprutil-0.so.0 for package: mod_perl --> Processing Dependency: libpq.so.3 for package: perl-DBD-Pg --> Processing Dependency: libpq.so.3 for package: php-pgsql --> Processing Dependency: libapr-0.so.0 for package: mod_perl --> Processing Dependency: libapr-0.so.0 for package: httpd --> Processing Dependency: libaprutil-0.so.0 for package: httpd --> Processing Dependency: subversion = 1.1.4-2.ent for package: mod_dav_svn --> Processing Dependency: libpq.so.3 for package: dovecot --> Finished Dependency Resolution

Mon, 05/21/2007 - 03:24
Joe
Joe's picture

Hey David,

That's not fresh enough. It looks like you've got some non-OS repositories setup on your box, and they're conflicting pretty badly with ours. You'll first need to remove the non-standard stuff that conflicts with our packages, or, if you're happy with those packages you'll need to use the manual install process (you'll also need to make sure you're Apache, whatever its source, is rebuilt with suexec_docroot set to /home).

If you'd like to use our packages (which are based on the original CentOS packages, and Fedora Extras when no CentOS standard package exists) you'll need to remove all of the "missing dependency" stuff above.

--

Check out the forum guidelines!

Mon, 05/21/2007 - 14:56
LoganBarnett

Joe, I'm working with David here on the CentOS box.
We only recollect installing Postgresql. We've taken that out along with the custom repositories (so it's just CentOS-Base now). I ran the script again and this is the full log:

Checking for curl or wget...found /usr/bin/wget -nv
Checking for perl...found /usr/bin/perl
15:39:03 URL:http://software.virtualmin.com/lib/spinner [[182/182]] -> "spinner" [[1]]
Loading log4sh logging library...
15:39:03 URL:http://software.virtualmin.com/lib/log4sh [[21395/21395]] -> "log4sh" [[1]]
INFO - Started installation log in virtualmin-install.log
INFO - Checking for fully qualified hostname...
INFO - Hostname OK: fully qualified as rts.railsmachina.com
INFO - Installing serial number and license key into /etc/virtualmin-license
INFO - Loading OS selection library...
15:39:04 URL:http://software.virtualmin.com/lib/oschooser.pl [[4448/4448]] -> "oschooser.pl" [[1]]
INFO - Succeeded.
INFO - Loading OS list...
15:39:04 URL:http://software.virtualmin.com/lib/os_list.txt [[3336/3336]] -> "os_list.txt" [[1]]
INFO - Succeeded.
INFO - Operating system name: CentOS Linux
INFO - Operating system version: 4.5
INFO - Installing virtualmin-release package for CentOS Linux 4.5...
INFO - Disabling SELinux during installation...
/usr/sbin/setenforce: SELinux is disabled
INFO - setenforce 0 failed: 1
error: /usr/share/rhn/RPM-GPG-KEY: import read failed.
15:39:04 URL:http://129450:9FF9454AD@software.virtualmin.com/rhel/4.5/i386/virtualmin... [[10908/10908]] -> "virtualmin-release-latest.noarch.rpm" [[1]]
INFO - Succeeded.
Running updatedb so locate works...this will take a little while.
Attempting to import various system RPM-GPG-KEY files...Errors may occur,
if you've already imported them. It is safe to ignore these errors.
INFO - Succeeded.
INFO - Installing dependencies using command: /usr/bin/yum -y -d 2 install bind bind-chroot bind-utils caching-nameserver httpd postfix bind spamassassin procmail perl perl-DBD-Pg perl-DBD-MySQL quota iptables openssl python mailman subversion ruby rdoc ri mysql mysql-server postgresql postgresql-server rh-postgresql rh-postgresql-server logrotate webalizer php php-domxl php-gd php-imap php-mysql php-odbc php-pear php-pgsql php-snmp php-xmlrpc php-mbstring mod_perl mod_python cyrus-sasl dovecot spamassassin mod_dav_svn cyrus-sasl-gssapi mod_ssl ruby rubygems perl-XML-Simple perl-Crypt-SSLeay
INFO - ...in progress, please wait... |No Match for argument: rdoc
No Match for argument: ri -No Match for argument: rh-postgresql No Match for argument: rh-postgresql-server |No Match for argument: php-domxl /No Match for argument: rubygems -No Match for argument: perl-XML-Simple -Error: Missing Dependency: libaprutil-0.so.0 is needed by package mod_perl
Error: Missing Dependency: libaprutil-0.so.0 is needed by package httpd
Error: Missing Dependency: libapr-0.so.0 is needed by package httpd
Error: Missing Dependency: libapr-0.so.0 is needed by package mod_perl
Error: Missing Dependency: subversion = 1.1.4-2.ent is needed by package mod_dav_svn ...in progress, please wait... failed. Error (if any): 0

Displaying the last 15 lines of the install.log to help troubleshoot this problem:
--> Processing Dependency: subversion = 1.1.4-2.ent for package: mod_dav_svn
--> Processing Dependency: aspell-en for package: aspell
--> Processing Dependency: perl-HTML-Tagset]= 3.03 for package: perl-HTML-Parser
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package perl-Digest-HMAC.noarch 0:1.01-13 set to be updated
---> Package perl-HTML-Tagset.noarch 0:3.03-30 set to be updated
---> Package aspell-en.i386 50:0.51-11 set to be updated
--> Running transaction check
--> Processing Dependency: libapr-0.so.0 for package: mod_perl
--> Processing Dependency: subversion = 1.1.4-2.ent for package: mod_dav_svn
--> Processing Dependency: libaprutil-0.so.0 for package: httpd
--> Processing Dependency: libapr-0.so.0 for package: httpd
--> Processing Dependency: libaprutil-0.so.0 for package: mod_perl
--> Finished Dependency Resolution

FATAL - Fatal Error Occurred: Something went wrong during installation: 1
FATAL - Cannot continue installation.
FATAL - Attempting to remove virtualmin repository configuration, so the installation can be
FATAL - re-attempted after any problems have been resolved.
warning: /etc/yum.repos.d/virtualmin.repo saved as /etc/yum.repos.d/virtualmin.repo.rpmsave
FATAL - Removing temporary directory and files.
FATAL - If you are unsure of what went wrong, you may wish to review the log
FATAL - in /root/virtualmin-install.log.

I'm not entirely sure if we were getting this before, but I noticed this error:
error: /usr/share/rhn/RPM-GPG-KEY: import read failed.

Any suggestions? Thanks in advance!