Authorize.Net CIM will soon require TLS 1.2 support to process transactions and your server environment may need to be updated.

10 posts / 0 new
Last post
#1 Thu, 12/27/2018 - 14:59
tmiller91

Authorize.Net CIM will soon require TLS 1.2 support to process transactions and your server environment may need to be updated.

Hello,

I recently migrated a cPanel backup to a brand new Virtualmin default installation.

I'm running a single WordPress website and this is new when now logging in:

Authorize.Net CIM will soon require TLS 1.2 support to process transactions and your server environment may need to be updated. Please contact your hosting provider to confirm that your site can send and receive TLS 1.2 connections and request they make any necessary updates.

I'm not finding any answers on the forums to resolve this error message.

It seems to also be affecting the REST API, as calls from a third party are not completing with error: woocommerce_rest_cannot_view, Sorry, you cannot list resources, 401

The only way I can get the REST API calls to work is using Insecure Mode.

Any suggestions?

Thu, 12/27/2018 - 16:41
andreychek

Howdy,

Hmm, what distro/version is it that you're using there?

And which PHP version is WordPress configured to use?

Most distros, even a distro as old as CentOS 6 (our oldest supported distro), appear to come with tools that would support TLS 1.2.

-Eric

Thu, 12/27/2018 - 18:28
tmiller91

I'm on CentOS 7.5 x64 using PHP 7.0.27

Thu, 12/27/2018 - 18:29
tmiller91

It looks like the old cPanel server was running PHP 5.6. Would this be the issue?

If yes, how would I resolve that and get PHP 5.6 running?

Thu, 12/27/2018 - 19:09
tmiller91

I also tried following: https://www.virtualmin.com/documentation/web/multiplephp

[root@server ~]# yum install rh-php56 rh-php56-php-mysqlnd Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * base: ewr.edge.kernel.org * epel: ftp.cse.buffalo.edu * extras: centos2.zswap.net * updates: reflector.westga.edu No package rh-php56 available. No package rh-php56-php-mysqlnd available. Error: Nothing to do

Thu, 12/27/2018 - 19:28
andreychek

PHP 5.6 reaches it's end of life in 2 days, they may have removed it from that repository for that reason.

However, if it worked with PHP 5.6, it really should work with PHP 7.0.

It may have to do with some other dependency on your system. What OpenSSL and Curl version are installed there?

-Eric

Thu, 12/27/2018 - 19:52
tmiller91

curl 7.29.0 (x86_64-redhat-linux-gnu) libcurl/7.29.0 NSS/3.36 zlib/1.2.7 libidn/1.28 libssh2/1.4.3 Protocols: dict file ftp ftps gopher http https imap imaps ldap ldaps pop3 pop3s rtsp scp sftp smtp smtps telnet tftp Features: AsynchDNS GSS-Negotiate IDN IPv6 Largefile NTLM NTLM_WB SSL libz unix-sockets

OpenSSL 1.0.2k-fips 26 Jan 2017

Thu, 12/27/2018 - 21:47
andreychek

Howdy,

Hmm, that all looks fairly normal, and those components appear as if they should work well.

You're of course always welcome to ask questions like that here, but in this case, unless someone tosses out another suggestion in the meantime, you may end up needing to ask the folks who make the particular software that you're using there.

Is it WooCommerce you're using there? If so, you may want to ask the WooCommerce folks what it is they're using internally to connect to the Authorize.net API... they'd have a better idea of what tools or libraries are being used to make the TLS 1.2 connections.

-Eric

Fri, 12/28/2018 - 08:48 (Reply to #8)
tmiller91

Old Registered Stream Filters: zlib.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, bzip2.*, convert.iconv.*, mcrypt.*, mdecrypt.*

New Registered Stream Filters: zlib.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, bzip2.*, convert.iconv.*

Missing mcrypt and mdecrypt.

However, when running yum install php-mcrypt* it says its already installed. php-mdecrypt* says no package available.

Could this be the issue?

Fri, 12/28/2018 - 08:54
tmiller91