How do i install this???

11 posts / 0 new
Last post
#1 Fri, 05/25/2007 - 22:51
justinreid

How do i install this???

Ok, fresh installation of Ubuntu on the server. Downloaded install.sh to the desktop (the 50 domain version)

<br/><br/>according to the (seemingly vague) instructions i am to

<p><i>Download the file from the Software Registrations page at Virtualmin.com. All of your purchased products will be available for download throughout the life of your license period. Copy the file on to the server to be installed, using scp on Linux or Mac OS X client machines or WinSCP or PSCP on Windows.</i></p>

<p><b>(it's on the desktop - did i do bad??)</b></p>

<i>Then, as root, run these two commands:

<br/># chmod +x install.sh

<br/># ./install.sh </i> <p>Nothing happens??? I feel retarded can someone walk me through it in a little more detail please?

<br/>regards,

<br/>Justin

</p>

Fri, 05/25/2007 - 23:54
justinreid

alrighty then, found it to be an ID 10 Tee error on my part.
moved the install.sh into my home folder and all worked well.

I've been reading through the forums here trying to find what is the best OS to use and (as an Ubuntu fan) have found that 6.06 is the way to go?

Has anyone had any luck with 7.0.4 as yet? I'm running 7.04 at the moment but can go &quot;backwards&quot; if the need arises although i'd prefer to stay where i am. Is there any reason (in newbie talk please :O) ) as to why i should use 6.06 as opposed to 7.04 (other than &quot;because that's the way the monkey's say it has to be done&quot;)

Cheers.

Justin

Sat, 05/26/2007 - 02:44 (Reply to #2)
Joe
Joe's picture

Hey Justin,

Thanks for becoming an Early Adopter! We'll be here to help--no need to worry. We'll even perform the installation for you, if things go astray (as it seems they have).

<i>Has anyone had any luck with 7.0.4 as yet? I'm running 7.04 at the moment but can go &quot;backwards&quot; if the need arises although i'd prefer to stay where i am. Is there any reason (in newbie talk please :O) ) as to why i should use 6.06 as opposed to 7.04 (other than &quot;because that's the way the monkey's say it has to be done&quot;)</i>

7.04 is not supported. We prefer the TLS releases of Ubuntu, because they have significantly longer life cycle. If we commit to an OS, I'll be building packages for it for years--while 7.04 will no longer be supported by the Ubuntu folks by this time next year! That puts me (and you) up a creek without a paddle. ;-)

So, we recommend Ubuntu 6.06LTS, if you like Ubuntu.

That said, now that we know how folks want to use Virtualmin Professional a bit better (and how much people really want to use their favorite OS, even if it's not on our supported list), I believe we'll be introducing the concept of &quot;Grade A&quot;, &quot;Grade B&quot;, and &quot;Grade C&quot; supported operating systems in the future...it will address the folks who like to be on the bleeding edge. Grade A systems will be recommended, fully supported, and we'll commit to supporting them for years. Grade B systems will be fully supported, but our support for them will end on the same day the OS vendor ends support (this group will include Fedora and Ubuntu non-LTS versions). Grade C systems will be systems that are difficult to support for some other reason, but we have a significant number of users...these will be supported via a very basic installer and reasonable documentation for manual configuration. Grade B systems will always be Grade B because they are that way for specific reasons (short life cycle or broken package management). Grade C systems could graduate to B or A, as popularity, life cycle, and technical merits dictate.

--

Check out the forum guidelines!

Fri, 05/25/2007 - 23:55
justinreid

Hmmmf, the monkey's say:

&quot;
The following packages have unmet dependencies:
virtualmin-base: Depends: php4-mysql but it is not installable
Depends: postgresql but it is not installable
Depends: php4-pgsql but it is not installable
Depends: php4 but it is not installable
Depends: php4-cgi but it is not installable

FATAL - Fatal Error Occurred: Installation failed: 1
FATAL - Cannot continue installation.
FATAL - Attempting to remove virtualmin repository configuration, so the installation can be
FATAL - re-attempted after any problems have been resolved.
FATAL - Removing temporary directory and files.
FATAL - If you are unsure of what went wrong, you may wish to review the log
FATAL - in /root/virtualmin-install.log.

&quot;
am trying 6.1...

Sat, 05/26/2007 - 02:46 (Reply to #4)
Joe
Joe's picture

Hey Justin,

I believe this indicates that the universe repository is not available.

If you'd like to send over the IP and login details, I'll be happy to drop in and perform the installation for you.

6.10 is expected to work, but is not recommended (it's already been EOL'ed by Ubuntu, as far as I know). 6.06LTS is definitely the way to go.

--

Check out the forum guidelines!

Thu, 06/07/2007 - 13:48 (Reply to #5)
RickHaga

I was running into this problem and found that there were repositories commented out in the sources.list file. I ran vi and removed the comments and then ran apt-get update to update all the new ones. Once this was completed, I ran the install.sh and it went flawlessly on 6.06LTS. I couldn't get it to run on any of the newer versions.

Sat, 05/26/2007 - 01:45
justinreid

6.1 same errros...
6.06 same fn error

FATAL - Fatal Error Occurred: Something went wrong during installation: 1
FATAL - Cannot continue installation.
FATAL - Attempting to remove virtualmin repository configuration, so the installation can be
FATAL - re-attempted after any problems have been resolved.
FATAL - Removing temporary directory and files.
FATAL - If you are unsure of what went wrong, you may wish to review the log
FATAL - in /root/virtualmin-install.log.
patton@patton:~$

money back and cube panel time? ffs auto install is supposed to be easy isn't it? wasted 8 freakin hours on this and gone through the following intalls all with the same errors... 7.04, 6.1, 6.06

Sat, 05/26/2007 - 02:58
justinreid

so i guess i have to put 6.06 back on the server?
how do you want me to send the details to you and is there anything i need to do before sending them?

Sat, 05/26/2007 - 03:20
justinreid

6.06 is back on the server, how do you want me to pass you these details, is there an email address for this site that actually works?

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

Sat, 05/26/2007 - 03:37 (Reply to #9)
Joe
Joe's picture

Hey Justin,

<i>is there an email address for this site that actually works?</i>

Sure, joe@virtualmin.com.

<i>A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:</i>

What address did you send to that failed?

--

Check out the forum guidelines!

Sat, 05/26/2007 - 17:44
justinreid

Thanks very much Joe for staying up until 4am to get this installed for me, I haven't yet tested it out (too tired) but am looking forward to having a play with it today.

My initial frustrations with the product were well and truly cleared up after receiving friendly expert support. I look forward to the next year (at least!) with Virtualmin

I owe you guys a beer or more methinks! VB?