How to install PEAR?

3 posts / 0 new
Last post
#1 Tue, 07/10/2007 - 19:50
SteveHeinsch

How to install PEAR?

Im using php 5.2.2 from vm and if I try to yum install php-pear it wants to install php 5.1x from centos. Is there a way to install pear as there are many packages taht I would like to use.

Thanks, Steve

Sat, 07/14/2007 - 01:56
Joe
Joe's picture

CentOS 4 (or 3) doesn't have php 5 in its repository. You've got some other repository configured that's conflicting with ours. php-pear ought to be the php 4 pear version, and shouldn't conflict with our php5 packages. I think it'll also work with php 5, though I think I need to spend a bit of time poking at the way the PEAR module handles different versions.

--

Check out the forum guidelines!

Mon, 09/24/2007 - 09:25
SteveHeinsch

I am still really needing php5-pear. I installed pear...
[code:1]yum install php-pear[/code:1]
it installed php4 from vm and php-pear.
So now in vm, I can set which version of php to use per website as I already had php5.2vm installed.
Now I went to install the horde base script and get this message:
<div class='quote'>The PHP Pear modules Log Mail Mail_Mime DB are required, but Pear for PHP version 5 is not installed - proceeding anyway.
Now installing Horde version 3.1.4 ..</div>

Horde does not work...it just comes up with blank screens. Is there any way to add a php5-pear to the vm repo?

Thanks,
Steve